Problem w/ radiator fan wiring. Advise appreciated! - Nissan Titan Forum
Electrical & Wiring Forum for discussion of all your Electrical & Wiring troubles and needs. Sponsored by Optima Batteries. Advertisement

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 1 (permalink) Old 06-27-2011, 06:17 PM Thread Starter
Registered User
 
Join Date: May 2011
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Problem w/ radiator fan wiring. Advise appreciated!

Hello again everyone!

I have had my new, used titan for a month now and had to take it back to the dealership for a couple of warranty issues. I got a 90 day warranty from the used car dealer. This is my problem:

The radiator sprung a leak and they replaced two weekends ago. I had it back for less than a day and started to have electrical problems. It was dieseling when I turned it off and would keep running and sputtering for up to a minute. I was also having some problems with the lights. When I went to disconnect the battery, I could see there was a badly burned section of harness.

It was taken back to the dealership this past weekend. They told me it was "done" today, but I could not accept it once I saw it. The burned wires were just re-wrapped in electrical tape and a 10 gauge jumper wire was installed directly from the battery to a couple of relays. There were also numerous frayed and loose wires connected to the relays, which were mounted to the radiator support bracket on the passenger's side.

These relays looked suspicious so I traced the wires out to see what they went to. Each relay controls one of two electric fans in a very original looking radiator shroud. One of the fans does not even work because the ground to its corresponding relay is cut and hanging loose.

I took the lids off of the circuit breaker panels and found the 40 amp fuse that feeds the fans. This is seemingly bypassed by the rigged up relay and jumper wire setup. The jumper wire has a 20-amp circuit breaker attached to it and the activation signal to the relay comes from a splice to an ignition-hot fuse (new as of this weekend). This means that the power dawn by the fans exceeds the load rating of its wiring components and that the fans are always on (or at least the one with the functional relay) and no longer controlled by a temperature sensor as Nissan presumably intended.

When I brought this to the attention of the owner of the dealership, he told me that the people who traded the truck in to him said the relays and wiring were installed because the electric fan setup was aftermarket and that the truck originally had a belt driven fan. I told him that I believed he had been lied to. This conversation took place after the service department had closed, so I left the truck there and was given a loaner truck off of the lot. I am supposed to go back tomorrow afternoon to speak with the mechanic who had serviced it.

My questions for you kind folks are as follows:

1) Is there, could there be, or was there ever a chance that this vehicle had a belt driven fan and the perfect looking radiator shroud and electric fan setup is aftermarket? This would of course mean that the factory installed a breaker the original panel for no apparent purpose.

2) Where should I look for the portion of the factory wiring harness that powers these fans? The wires that attach to the fans come out of the plastic shroud (engine side of the radiator) through a hole that is right between the two fans. Ideally, I would like to reconnect it to the factory 40A circuit breaker using the original wiring (or at least correctly installed replacement wiring).

3) Am I correct in assuming that if these fans were wired correctly, they would be activated by a temperature sensor (presumably by the computer or a relay connected to the circuit breaker)?

The headlights are some aftermarket LED/Halo/Projector crap and the wiring is an absolute hack job. It looks like the LEDs and Halos were disconnected on purpose (probably for state inspection).

They also forgot to reattach the vacuum hoses to the AEM intake when they removed it to change the radiator out previously.

I am perfectly capable of fixing all of this myself, but I feel as if this should be covered by my warranty. I am a ASE certified electrical systems technician, but could use some input from people who are a little bit more familiar with Titans than I am at this point.

I am strongly tempted to rip out every piece of aftermarket wiring right in front of the mechanic tomorrow and tell him that I will be back in a week to pick it up and I expect the fans to be powered by the factory circuit breaker and activated by a temperature sensor with everything tucked neatly away within the factory harness.

I appreciate any input that y'all have to offer. Thanks in advance!

-Aaron
Fast71SS is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Titan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
External Tranny Cooler - Help/Advise Needed and Appreciated! DaveS Titan General Discussion 5 07-07-2010 10:08 PM
problem with mirrors. please advise beason Titan General Discussion 1 07-28-2009 11:38 AM
wiring or fuse location for radiator fan kennynoel Titan FAQ & Howto Area 3 06-09-2008 09:24 PM
Leaking radiator. Help appreciated. Footloose301 Titan Engine, Transmission & Drivetrain 0 11-01-2007 07:35 PM
Radiator Trouble...PLEASE ADVISE!!! BRACEYOSELF777 Titan General Discussion 13 10-03-2006 12:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On