Nissan Titan Forum - View Profile: hitandrun176

hitandrun176 hitandrun176 is offline

Registered User

  Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. mustardman
    12-30-2013 02:30 PM - permalink
    mustardman
    140amp fuse on battery do you what it for
  2. hitandrun176
    12-16-2013 07:50 PM - permalink
    hitandrun176
    replaced seal with new one and put in updated axle shaft havent had a problem yet
  3. skrewflanders
    11-14-2013 02:54 PM - permalink
    skrewflanders
    I saw that your pinion seal on the driver's side front diff, I also have an 04 that's done this twice. What did you do to fix it and has it happened again? Any help would be appreciated, thanks!

  About Me

  • About hitandrun176
    Car
    2004 Nissan Titan SE Endurance
    Mods
    Banks Ram Air
    Location
    Annapolis, MD
    Interests
    Fliping Trucks and Cars for money with my brother inlaw
    Occupation
    Constuction,
  • Signature
    04 King-Cab SE 4WD BT
    flowmaster 40s, a-pillar
    Superchips cortex 93oct tune
    leds thanks to porkchop
    2* timing thanks to Titanblue
    10" dvc subs thanks to 9Ballrook
    HIDs 5k, 5% tint, Banks CAI



  Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: Yesterday 04:39 PM
  • Join Date: 02-08-2012

  Friends

Showing Friends 1 to 9 of 9

  iTrader Score

iTrader Profile Recent Ratings
iTrader Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for hitandrun176
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0