Nissan Titan Forum - View Profile: bills1974

bills1974 bills1974 is offline

Premium User

  Visitor Messages

Showing Visitor Messages 1 to 10 of 36
  1. Walrus
    08-16-2012 09:01 PM - permalink
    Walrus
    He bought a Juke and now he doesn't like us anymore.
  2. 4mula1fan
    01-15-2012 10:12 AM - permalink
    4mula1fan
    Nice VeeDub BA...
  3. KING_Polaris
    11-15-2011 11:34 AM - permalink
    KING_Polaris
    Already fixed it, it wasn't even hose failure, the hose just simply popped off... cheap clamps, I'm going to replace them soon. It was the front cooler line, not the two bottom ones. No damage was done to the truck so I'm good to go. That's why I messaged you because it sounded an awful lot like your problem you had and I knew it wasn't a cracked radiator because my radiator is brand spankin' new. lol. Thanks Bill!
  4. KING_Polaris
    11-13-2011 08:30 AM - permalink
    KING_Polaris
    Bill, I think the same thing happened to me last night that happened with you when you had tranny fluid all over the place. Last night I was driving back home and the truck went limp on me and I would have to rev harder to get moving, I pulled over immediately afterwards and sure enough... tranny fluid everywhere... How long did it take you to replace the hoses? I hope they are just the hoses... I put in that Koyo radiator that you sold me so I don't think it would be the radiator failing... its too new. lol
  5. Maverick-99
    08-22-2011 11:17 PM - permalink
    Maverick-99
    dang man sounds pretty simple, i just bought a badge off amazon for like 7 bucks and im gunna hook that baby up. ive had some leds in there for a while now and i think itll look pretty sweet, i was thinking about taking a dremel and cutting out around the emblem to make it shine better but after the 3week shipping wait i have ill post some pictures and see what yall think... preciate the help man! and congrats on Ride of the month!!
  6. bills1974
    08-16-2011 05:47 AM - permalink
    bills1974
    Thanks man, It's actually the OEM grill that I added to and it's actually pretty cheap and easy to do. Here's what I got:

    Speed Scene grill inserts
    2 blue LED strips
    5" Autobot emblem from eBay

    When installing the inserts, put the LED strips in between the OEM and inserts and obviously run the wires along the inside of the grill. Put emblem in the middle right over where the OEM used to be.

    Reinstall and hook up LED's, that's it
  7. Maverick-99
    08-16-2011 01:39 AM - permalink
    Maverick-99
    dude, i gotta know whats with the grill?!?! where the hell did you find that awesome thing!! my girlfriend saw it and literally screamed at the top of her lungs and now... thanks to you... i goota get one!!! haha its the most unique one ive seen yet bud!
  8. bills1974
    07-19-2011 02:47 PM - permalink
    bills1974
    They should, I didn't have to do anything. I just had the shop mount the TPMS when they mounted the tires and everything worked.
  9. pztitan
    07-19-2011 02:41 PM - permalink
    pztitan
    Hey bill. I got a question for you, will my TPMS work on my Rockstars? if they do is there anything to look out for or reset ? Thanx in advance
  10. pztitan
    06-28-2011 02:05 PM - permalink
    pztitan
    hey bills1974 when you get a chance revisit my old thread do-i-need-lift-35x12-50-r18s-kmc-rockstars. Mods are done

  About Me

  • About bills1974
    Car
    2008 Nissan Titan SE CC
    Mods
    See Signature
    Location
    Delray Beach, FL
  • Signature
    2014 Jeep Wrangler Unlimited

    Cowl Done With Bedliner
    Radiator Bypassed - Transmission Fluid
    Wife's Ride: 2014 Infiniti Q50 S
    My Other Ride: 2007 Sea Doo Speedster 200


    AKA: Crossdresser Whore™
    The Bald Avenger®

    "It's really bad when I have to go into the fridge to count how many beers I had last night because I lost track."
    "Why is the rum always gone?"

  Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Join Date: 09-12-2007

  Friends

Showing Friends 1 to 10 of 43
  • 06_footy
    • 06_footy is offline
  • 08BLIZZARD
    • 08BLIZZARD is offline
  • 37L1
    • 37L1
    • Super Moderator
    • 37L1 is offline
  • 4mula1fan
    • 4mula1fan is offline
  • Arachnid
    • Arachnid is offline
  • ArmyAviation
    • ArmyAviation is offline
  • bbomar
    • bbomar is offline
  • Blackbeauty
    • Blackbeauty is online now
  • Blavis
    • Blavis is offline
  • BleedCrimson33
    • BleedCrimson33 is offline

  Contact Info

Instant Messaging
Send an Instant Message to bills1974 Using...
This Page
http://www.titantalk.com/forums/members/29376-bills1974.html

  iTrader Score

iTrader Profile Recent Ratings
iTrader Score:
Positive Feedback:
7
100.0%
Members who left positive:
Members who left negative:
7
0
Total positive feedback: 7
View Complete Feedbacks for bills1974
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0