My engine is running extremely rough - Nissan Titan Forum
Titan Engine, Transmission & Drivetrain Technical discussion about the engine, transmission, and drivetrain.

 
LinkBack Thread Tools Rate Thread Display Modes
#1 (permalink) Old 08-20-2011, 07:06 PM
Registered User
 
Join Date: Aug 2011
Posts: 4
Thanks: 6
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
My engine is running extremely rough

I pulled up to a red light and the engine started to run extremely rough and was barely running. It acted like it was only hitting on 2-3 cylinders. I tried to give it some gas to pull off to the side of the road and it died. Tried to start it again and the same thing. I let it sit for about 2 minutes and it fired right up and ran like a top. I get to my dad's house to take a look around and could not find anything and it sits for about an hour and a half and then I start it up to go home and I make it about a half mile down the road and it does it again and this time it will not clear up. It will start up and run rough enough to power the steering and brakes but will not budge from it's tracks. Any help will be appreciated.
nonchalant is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-20-2011, 09:35 PM
Premium User
Nissan Titan Status - Premium Member
 
vipzach's Avatar
 
Join Date: Dec 2006
Location: Choctaw, OK
Posts: 32,855
Thanks: 11,754
Thanked 3,428 Times in 2,667 Posts
iTrader Score: 6 reviews
Re: My engine is running extremely rough

What year, how many miles?

First guess........IPDM.

Why is there never enough time to do it right the first time,
But always enough time to do it again?

Zlacher whore™
vipzach is online now  
The Following User Says Thank You to vipzach For This Useful Post:
nonchalant (08-21-2011)
#3 (permalink) Old 08-21-2011, 12:59 AM
Registered User
 
honda250xtitan's Avatar
 
Join Date: Jan 2010
Location: Phoenix, Arizona
Posts: 9,942
Thanks: 5,257
Thanked 3,367 Times in 2,486 Posts
Garage
iTrader Score: 8 reviews
Re: My engine is running extremely rough

second guess... fuel pump.

clogged cats?

2011 White CC pro4x
Flowmaster Y
Gibson Muffler/ 3" tail pipe/ 5" black tip
Airaid MXP 4" Intake
PRG UCA's
Bilstein 5100's Middle Perch/2" spacer
PRG Camber Bolts
Homemade Traction Bars
Fuel Boost 18x9
Toyo Open Country ATII 325-60-18
BORA 1.25 Wheel Adapters/ Pinch Weld Mod
Weathertech Floor Mats



Traded In: 06 KingCab 4x4
6" ProComp, Bilsteins 5100's, 08 4x4 coils, PRG UCA's, Banks CatBack, Nismo Cai, Superchips Cortex, Custom Bumper, 35's on 18's
honda250xtitan is offline  
The Following User Says Thank You to honda250xtitan For This Useful Post:
nonchalant (08-21-2011)
#4 (permalink) Old 08-21-2011, 04:28 AM
Registered User
 
Join Date: Aug 2011
Posts: 4
Thanks: 6
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: My engine is running extremely rough

2005 with 87000miles. I undone the exhaust manifold from the cats to let it breathe and it still is the same. I tried it again this morning and it fired right up and ran fine for about 10 seconds and went back to running rough. While it is doing it the SES light,the 4WD light and the four wheel drive diagram are all three flashing very quickly.

Last edited by nonchalant; 08-21-2011 at 04:31 AM.
nonchalant is offline  
#5 (permalink) Old 08-21-2011, 05:58 AM
Registered User
 
snorkel's Avatar
 
Join Date: Aug 2010
Location: goldsboro, nc
Posts: 253
Thanks: 3
Thanked 28 Times in 26 Posts
iTrader Score: 0 reviews
Re: My engine is running extremely rough

have you done the ipdm relay recall? i think its the ipdm relay, research here about ipdm relay.
snorkel is offline  
The Following User Says Thank You to snorkel For This Useful Post:
nonchalant (08-21-2011)
#6 (permalink) Old 08-21-2011, 06:15 AM
Premium User
Nissan Titan Status - Premium Member
 
Kronos1965's Avatar
 
Join Date: Sep 2004
Location: Raleigh, NC
Posts: 9,082
Thanks: 1,596
Thanked 2,285 Times in 1,395 Posts
iTrader Score: 0 reviews
Re: My engine is running extremely rough

Quote:
Originally Posted by snorkel View Post
have you done the ipdm relay recall? i think its the ipdm relay, research here about ipdm relay.
I would switch out the fog light relay with the IPDM first to test the theory.

I wouldn't rule out the MAF sensor going bad as well.

HippieWhore™
Be the kind of person your dog thinks you are.
Kronos1965 is offline  
The Following User Says Thank You to Kronos1965 For This Useful Post:
nonchalant (08-21-2011)
#7 (permalink) Old 08-21-2011, 07:05 AM
Registered User
 
TitanBlue's Avatar
 
Join Date: Jul 2006
Location: Annapolis, MD
Posts: 6,097
Thanks: 1,743
Thanked 907 Times in 622 Posts
iTrader Score: 3 reviews
Re: My engine is running extremely rough

Some have had the fuel pump fail too. Get the codes read right away.

2006 XE CC Pref Pkg BT with AEM Brute Force CAI, PowerAid TB Spacer, TB Reversed Valve ByPass Mod, 2007+ Intake, JBA Headers, MagnaFlow 24" Muffler, 2008+ Rear Axle, Stillen: F & R Sway Bars, Black Diff Cover, Engine Dress Up Kit, 4 pc StreetScene SS Mesh Grille, PRG End Links, Street Traction Bars & Shackles, UpRev Osiris Tuner 93 Performance Tuned, 18" SE Rims, Functional Hood Scoop ...


IRC VK56 Member "Special Operations"

MD Chapter Director
TitanBlue is offline  
The Following User Says Thank You to TitanBlue For This Useful Post:
nonchalant (08-21-2011)
#8 (permalink) Old 08-21-2011, 09:11 AM
Registered User
 
NBhunter80's Avatar
 
Join Date: Dec 2008
Location: New Brunswick, Canada
Posts: 3,695
Thanks: 523
Thanked 773 Times in 572 Posts
iTrader Score: 0 reviews
Re: My engine is running extremely rough

IPDM relay sounds likely, or even a bad battery. MAF sensor or fuel pumps are also possibilities. Also, are you sure that you didn't get some bad gas? But I agree to get codes read ASAP and park the truck until you resolve the issue. Good luck!


2005 Titan LE King Cab 4x4 Offroad Big Tow FFV.

Radiant Silver with charcoal leather interior, black Nissan OEM brush guard, 33x12.50r17LT Hercules Trail Digger tires on OEM OR 7-spoke 17" rims, Rough Country 3" lift, 1" rear block, Bilsteins 5100s front and rear, Hawk LTS brake pads, MOOG lower ball joints, 2011 Pro4x rear end, Axle vent mod, 2 degree timing advance, NGK Iridium spark plugs, Stock Airbox mod with K&N filter, Magnaflow 14" SI/SO muffler on stock pipes with T304 stainless double-wall tip, Optima Yellow Top D34 battery, OEM Rockford Fosgate audio system, Protecta chrome tool box, 6000K HID headlights, TomTom GO 920 Navigation system.

2012 Nissan Rogue SV AWD - Wife's ride
NBhunter80 is offline  
The Following User Says Thank You to NBhunter80 For This Useful Post:
nonchalant (08-21-2011)
#9 (permalink) Old 08-21-2011, 12:24 PM
Registered User
 
Join Date: Aug 2011
Posts: 4
Thanks: 6
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: My engine is running extremely rough

I have been researching it too and will try it(swapping the fog light relay) when I get home. I will keep you posted. Thanks for the help.
nonchalant is offline  
#10 (permalink) Old 08-21-2011, 02:24 PM
Registered User
 
Join Date: Aug 2011
Posts: 4
Thanks: 6
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Thumbs up Re: My engine is running extremely rough

I got home from work and changed relays and it fired right up and and continues to run. I will call my local Nissan dealer to talk about the recall. I am just not real confident about driving it there. Thanks again for all the help and pointing me in the right direction.
nonchalant is offline  
#11 (permalink) Old 08-21-2011, 02:31 PM
Registered User
 
TitanBlue's Avatar
 
Join Date: Jul 2006
Location: Annapolis, MD
Posts: 6,097
Thanks: 1,743
Thanked 907 Times in 622 Posts
iTrader Score: 3 reviews
Re: My engine is running extremely rough

The IPDM Relay recall was not active on my June 2006 build date. I went ahead and bought the new Relay they use anyway, but have not installed it. Due to it being a Recall item, they sell it for roughly $3. P/N 284B7-CW29E, I got mine for $2.64 at local dealer.

2006 XE CC Pref Pkg BT with AEM Brute Force CAI, PowerAid TB Spacer, TB Reversed Valve ByPass Mod, 2007+ Intake, JBA Headers, MagnaFlow 24" Muffler, 2008+ Rear Axle, Stillen: F & R Sway Bars, Black Diff Cover, Engine Dress Up Kit, 4 pc StreetScene SS Mesh Grille, PRG End Links, Street Traction Bars & Shackles, UpRev Osiris Tuner 93 Performance Tuned, 18" SE Rims, Functional Hood Scoop ...


IRC VK56 Member "Special Operations"

MD Chapter Director

Last edited by TitanBlue; 08-21-2011 at 02:33 PM.
TitanBlue is offline  
Reply

Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Guys running the Rough Country level kit Corbin Titan Suspension 10 02-23-2011 12:53 PM
Cold EXTREMELY rough starts, then no problems... ddr698 Titan Engine, Transmission & Drivetrain 2 02-11-2011 05:57 PM
1st post, problems w/Titan running ROUGH rowdyr Titan General Discussion 7 03-01-2010 09:11 PM
Service Engine Light - Rough Running slowrider Titan Problems & Dealer Service 7 03-31-2009 07:32 AM
Engine Running Rough oktex88 Titan Problems & Dealer Service 10 02-13-2005 12:43 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On