Titan Cranks but wont start!!! - Nissan Titan Forum
Titan Engine, Transmission & Drivetrain Technical discussion about the engine, transmission, and drivetrain.

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 (permalink) Old 03-19-2017, 04:31 PM Thread Starter
Registered User
 
kxracer85's Avatar
 
Join Date: Sep 2014
Location: Indialantic, FL
Posts: 16
Thanks: 3
Thanked 0 Times in 0 Posts
Garage
iTrader Score: 0 reviews
Titan Cranks but wont start!!!

Alright so I have been bit by the Titan none start bug.

2005 Nissan titan Crew cab has run great for all 4 years that I've owned it, up until about a month ago.

I normally drive no more than 30 mins one way with this truck but do drive it daily. About a month ago I made a longer than usual trip in it and noticed upon stopping at a light that the truck was idling very rough and the RPM were low. Once moving it ran great just noticed it when stop in Drive. I had also ran the tank down to about a 1/16th of a tank so I thought maybe I picked up some garbage in the tank. I sea foamed the tank and the brake boaster and did the ECU, Throttle resets, and cleaned the MAF and Throttle body. It didn't change anything and continued to idle rough and I also started to notice a strong exhaust smell and very black tail pipe that's usually completely clean. I had a BD programmer that I only use for the WOT, and decided to bump the RPM's up 150 and that seemed to make the truck run good again minus the strong exhaust smell and worse than usual MPG's. Truck ran fine like that for about 2 weeks and one day upon leaving the house it cranked and didn't start, tried a second time and it started. I didn't think much of it and left the house. I stopped of at the gym, came out and again it wouldn't start. It cranked but wouldn't start. I sat there trying to start it for 20 mins and then bam it started up and ran great. continued to drive it for the rest of the week with no problems and then one day a little over a week ago I left for work and it wouldn't start at all. I searched the around, swapped the ecm relays, nothing. Bought a new ecm relay, nothing. Battery is fine. Ordered a Crankshaft sensor, fuel pump, and IPDM board. Crankshaft sensor came in Friday so I changed that out first. Truck started right up after replacing that and was running perfect. Turned it on and off 3-4 times and no problems. Thought I had it figured out, went down the street to get some food. Came out truck started sputtered and stalled and will not start. It cranks great but will not start. It is really frustrating. Any ideas? IPDM board should be here this week along with the fuel pump. Dealership says my vin isn't under the recall and said only the relay goes bad not the whole board, but I thought i read the whole board can go.



2WD CC Big Tow FF SE Titan

Mods: JBA Shorty headers, JBA Full Exhaust, K&N CAI, Bully Dog PP, 20" Rockstars on 265/60-20 Falken Wildpeak AT's, 08+ 4X4 springs, Bilstein 5100's on middle perch, 2" rear block, Front Big Brake kit. HID's, Cover King Seat covers, Pioneer double din head unit, Kicker door speakers, 10" Kicker sub and amp, Tinted windows
kxracer85 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-19-2017, 06:17 PM
Registered User
 
Dieselfuelonly's Avatar
 
Join Date: Apr 2011
Location: Commonwealth of PA
Posts: 251
Thanks: 28
Thanked 42 Times in 33 Posts
iTrader Score: 0 reviews
Re: Titan Cranks but wont start!!!

If you can gain access to a fuel pressure gauge and check the FP when the symptoms occur.
2005 is over 10 yrs old now you didn't mention the mileage but my '05 is rolling onto 130,000 soon.
I had just replaced the fuel pump assembly a few months back and both of the filters were trashed w/ debris. Running fuel pumps low on fuel are not good for the motor or as you said about debris pulling into the socks.

The IPDM could be the culprit also. There is a system check you can do for the IPDM which is available in the service manual or if you search the forums on here.

If you have access to a snapon/otc or equivilent scanner you should be able to access the IPDM and individual run a test and check the relays through the scanner.

There are also plenty of diagnostic checks listed in the factory service manual you can perform.

If you search google for an 2005 Nissan Titan Factory service manual you should be able to find your way around to sourcing it.

Good luck

2005 Titan
Long TruCool added w/ removal of radiator in the loop
Dieselfuelonly is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Titan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Cranks but wont start silverfire Titan General Discussion 25 05-22-2016 09:19 PM
O7 titan cranks but want start Loki1985 Electrical & Wiring 0 08-09-2015 06:44 PM
Titan cranks, but WON'T start...DTC P0340 Camshaft Pos. Sensor Rock777 Titan Engine, Transmission & Drivetrain 2 07-04-2011 02:24 PM
No start titan! Cranks but no cigar Soyomakate Titan Engine, Transmission & Drivetrain 5 02-16-2011 01:27 PM
titan cranks but will not start kyle797 Titan Problems & Dealer Service 5 02-22-2009 03:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On