EVAP Large Leak - Nissan Titan Forum
Titan Engine, Transmission & Drivetrain Technical discussion about the engine, transmission, and drivetrain.

Reply
 
LinkBack Thread Tools Rate Thread Display Modes
#1 (permalink) Old 05-01-2008, 03:32 PM
Registered User
 
mcclintock89's Avatar
 
Join Date: Apr 2008
Location: Normal, IL
Posts: 252
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
EVAP Large Leak

i fueled up the other day and i put some lucas oil fuel injector cleaner in the tank and later that day my ses light came on. it was an EVAP large leak. i thought it was the gas cap so i just went and bought a locking gas cap and put that on then i deleted the code and it came on again. any ideas of where this might come from?
mcclintock89 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-01-2008, 04:10 PM
Registered User
 
Shane06fl's Avatar
 
Join Date: Jul 2006
Location: Apopka FL
Posts: 3,793
Thanks: 240
Thanked 664 Times in 492 Posts
iTrader Score: 1 reviews
Re: EVAP Large Leak

Put your factory gas cap back on and make sure it's tight.

Nothing proven but I have been warned to not use any of the fuel treatments. It can mess up the EVAP system connected to the fuel tank. Run that tank out and fill back and your SES light might go away.

Good luck

2005 Titan KC SE ***Sold 9/6/14***
Big Tow
4x4 SE
Deep Water
2005 Titan CC
Big Tow
4x4 SE
Silver

New Ride
2013 Chevy Silverado LT Z71 CC short bed
5.3L LC9 engine
Heavy duty tow package/cooling
4wd
loaded to the gills
mirrors sucks (for now)

2004 Keystone 24RS

---------------------------------------------------
Shane06fl is offline  
#3 (permalink) Old 05-01-2008, 06:36 PM
Registered User
 
TitanTech659's Avatar
 
Join Date: Dec 2005
Location: Lincoln, NE
Posts: 499
Thanks: 1
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Re: EVAP Large Leak

The fuel treatment didn't cause the Large EVAP Leak code. More than likely you either didn't get your gas cap on tight or the tether got stuck under it when you put it on. The locking gas caps have been known to cause this code as well. Just put the old one back on and make sure it is tight. If the light still comes back on you'll probably have to get a new factory gas cap.

Surrounded by idgits, we press on.
TitanTech659 is offline  
#4 (permalink) Old 05-01-2008, 06:52 PM
Registered User
 
sudden urge's Avatar
 
Join Date: Jan 2006
Location: Chicago area
Posts: 6,823
Thanks: 781
Thanked 1,191 Times in 870 Posts
iTrader Score: 4 reviews
Re: EVAP Large Leak

I have been running the Stant locking cap for 26 months without a problem.

Chicago area 05 KC SE 4x2 FFV, smoke, 2.94 gearing. Mods: Hypertech Max Energy, JBA catback, Airaid 4" MXP CAI, Hellwig HD traction springs, 08 rear shackles, Nasta nerf bars, Kenwood KSC-SW1 powered sub. Best full street trim (5120#) 1/4 mile track time of 14.632 running Bully Dog 87+2 and S&B CAI. 1/8 mile 9.30@74.49 with a 2.11 60'.
sudden urge is offline  
#5 (permalink) Old 05-01-2008, 07:55 PM
Registered User
 
mcclintock89's Avatar
 
Join Date: Apr 2008
Location: Normal, IL
Posts: 252
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Re: EVAP Large Leak

yea i have the stant locking gas cap. explain what a teether is
mcclintock89 is offline  
#6 (permalink) Old 05-02-2008, 09:24 AM
Registered User
 
mcclintock89's Avatar
 
Join Date: Apr 2008
Location: Normal, IL
Posts: 252
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Re: EVAP Large Leak

yea i checked it out last night after i got home and i noticed that i could smell gas when i stuck my head in around the gas tank. any suggestions?
mcclintock89 is offline  
#7 (permalink) Old 05-02-2008, 06:33 PM
Registered User
 
TitanTech659's Avatar
 
Join Date: Dec 2005
Location: Lincoln, NE
Posts: 499
Thanks: 1
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Re: EVAP Large Leak

Quote:
Originally Posted by mcclintock89
yea i have the stant locking gas cap. explain what a teether is
The tether is the cord that holds the cap to the fuel door so you don't loose your cap. Sometimes they can get stuck under the cap causing an EVAP code. Around the gas tank where? By the filler tube or around the tank itself?

Surrounded by idgits, we press on.
TitanTech659 is offline  
#8 (permalink) Old 05-06-2008, 09:21 PM
Registered User
 
mcclintock89's Avatar
 
Join Date: Apr 2008
Location: Normal, IL
Posts: 252
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Re: EVAP Large Leak

alright i just got a new tank of a gas the other day so all the fuel injector cleaner would be out of the question. i also put on the regular gas cap but today my light came back on after i erased the code. would my CIA have anything to do with it? cause i checked around all the hoses and i couldn't see or smell any sort of a gas vapor leak
mcclintock89 is offline  
#9 (permalink) Old 05-06-2008, 09:44 PM
Registered User
 
Nissan Mike's Avatar
 
Join Date: Oct 2005
Location: So Calif
Posts: 1,802
Thanks: 45
Thanked 71 Times in 43 Posts
iTrader Score: 0 reviews
Re: EVAP Large Leak

Remember also don't over fill the tank,filling until fuel floats at the top of the filler neck could cause this also!





Drive it like you rented it.....
Nissan Mike is offline  
#10 (permalink) Old 05-06-2008, 10:08 PM
Super Moderator
Nissan Titan Status - Premium Member
 
RobKar's Avatar
 
Join Date: Aug 2005
Location: San Diego
Posts: 32,275
Thanks: 7,626
Thanked 7,268 Times in 4,609 Posts
iTrader Score: 27 reviews
Re: EVAP Large Leak

you may have hole in your hose or tank



AKA TrollopInTraining™ AKA chinawhore™
2005 BT CC LE
175,000 Miles 1/16/2014
423TQ & 324HP 2/2/2013

The early bird might get the worm, but the second mouse gets the cheese.
RobKar is offline  
#11 (permalink) Old 05-07-2008, 09:11 AM
Registered User
 
mcclintock89's Avatar
 
Join Date: Apr 2008
Location: Normal, IL
Posts: 252
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Re: EVAP Large Leak

Quote:
Originally Posted by Nissan Mike
Remember also don't over fill the tank,filling until fuel floats at the top of the filler neck could cause this also!
yea that might be my problem cause both times i filled it up to the very top. i just cleared the code and i'll check the tanks and hose one more time hopefully i got it squared away. also on most cars there is a metal flap where u put the nozzle in for filling up do titans come with this? because mine did not and i'm pretty sure that when this part becomes missing it usually means someone cyphened gas from you
mcclintock89 is offline  
#12 (permalink) Old 05-07-2008, 09:06 PM
Registered User
 
James Con's Avatar
 
Join Date: Dec 2006
Location: Pennsyltucky
Posts: 461
Thanks: 2
Thanked 11 Times in 11 Posts
iTrader Score: 2 reviews
Re: EVAP Large Leak

Read this thread and check out the TSB. http://www.clubtitan.org/forums/showthread.php?t=46946I been through this with my 05. I had the p0455 code thrown. Evaporative leak heavy.( Large leak) Nissan says fuel cap for this code. BS. I changed the fuel cap and the code came back. Check the TSB and see if you have the Evap solonoid valve filter installed, If not the valve is crudded up. You have an 04 so your warranty is probably up. What you can do is take the valve out and try cleaning the solonoid shaft inside the valve, it can be seen through one of the ports on the valve. I scraped the crud, blew it out and put a drop of 3in1 oil on the shaft. It lasted for a few months before the code came back. So that told me the valve was bad. I had the TSB performed by Nissan under the extended warranty They installed a new valve and put the filter on. No problems so far.

AEM CAI, 18" Magnaflow
James Con is offline  
#13 (permalink) Old 05-09-2008, 09:00 AM
Registered User
 
mcclintock89's Avatar
 
Join Date: Apr 2008
Location: Normal, IL
Posts: 252
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Re: EVAP Large Leak

Quote:
Originally Posted by James Con
Read this thread and check out the TSB. http://www.clubtitan.org/forums/showthread.php?t=46946I been through this with my 05. I had the p0455 code thrown. Evaporative leak heavy.( Large leak) Nissan says fuel cap for this code. BS. I changed the fuel cap and the code came back. Check the TSB and see if you have the Evap solonoid valve filter installed, If not the valve is crudded up. You have an 04 so your warranty is probably up. What you can do is take the valve out and try cleaning the solonoid shaft inside the valve, it can be seen through one of the ports on the valve. I scraped the crud, blew it out and put a drop of 3in1 oil on the shaft. It lasted for a few months before the code came back. So that told me the valve was bad. I had the TSB performed by Nissan under the extended warranty They installed a new valve and put the filter on. No problems so far.

thanks for the info, yea i went through the gas cap part already and a few other things but the code kept coming back. if my valve is bad and need replaced is there anywhere that i can purchase this part outside of the dealer?

2004 KC 4x4 LE.

-K&N 77 Series Intake moded with AEM Dryflow filter
-Custom True Dual Exhaust
-Dynomax X-Flo Muffler
-Nissan iPod Interface
-Billet Grille
-Viper Security&Remote Start 5701 with Radar
-Firestone Destination A/T
-AMSoil
-2 Elemental Designs 11kv.2 Subwoofers.
-Alpine MRP-M650 Amp
-Subthump subbox
-Undercoated/Rust Proofed
-Grounding Kit
mcclintock89 is offline  
#14 (permalink) Old 05-10-2008, 11:55 AM
Registered User
 
James Con's Avatar
 
Join Date: Dec 2006
Location: Pennsyltucky
Posts: 461
Thanks: 2
Thanked 11 Times in 11 Posts
iTrader Score: 2 reviews
Re: EVAP Large Leak

Quote:
Originally Posted by mcclintock89
thanks for the info, yea i went through the gas cap part already and a few other things but the code kept coming back. if my valve is bad and need replaced is there anywhere that i can purchase this part outside of the dealer?
http://www.courtesyparts.com/ Has them, Part # 14935-AM60A ( valve) is $75.00 and Part# 50790-7S01A (filter kit) is $81.96. Do you have the filter installed on the Truck already ? If so you might just need the valve. Why don't you try cleaning the valve first and see if it fixes your problem. If it last a little while longer without the code popping again then you nailed the problem. But eighter way you should have the filter kit installed as per the TSB. Don't forget to put a drop of 3in1 oil on the solonoid shaft thats what is gonna keep it from hanging up. Good luck let me know how it turns out.

AEM CAI, 18" Magnaflow
James Con is offline  
#15 (permalink) Old 05-11-2008, 07:58 PM
Registered User
 
mcclintock89's Avatar
 
Join Date: Apr 2008
Location: Normal, IL
Posts: 252
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Re: EVAP Large Leak

Quote:
Originally Posted by James Con
http://www.courtesyparts.com/ Has them, Part # 14935-AM60A ( valve) is $75.00 and Part# 50790-7S01A (filter kit) is $81.96. Do you have the filter installed on the Truck already ? If so you might just need the valve. Why don't you try cleaning the valve first and see if it fixes your problem. If it last a little while longer without the code popping again then you nailed the problem. But eighter way you should have the filter kit installed as per the TSB. Don't forget to put a drop of 3in1 oil on the solonoid shaft thats what is gonna keep it from hanging up. Good luck let me know how it turns out.
thanks for the info. before i hack away at this project i wanna make sure i got the location of this thing right. this whole evap thing is right behind the gas tank and what not. and i take it the 3 in 1 oil i can pick up at any auto parts store, and if it's what i was looking at the screws holding it in place are put in through the top? i found this weird and it made me believe that i was looking for something else? idk i'll pull it out and see what's up with it.

2004 KC 4x4 LE.

-K&N 77 Series Intake moded with AEM Dryflow filter
-Custom True Dual Exhaust
-Dynomax X-Flo Muffler
-Nissan iPod Interface
-Billet Grille
-Viper Security&Remote Start 5701 with Radar
-Firestone Destination A/T
-AMSoil
-2 Elemental Designs 11kv.2 Subwoofers.
-Alpine MRP-M650 Amp
-Subthump subbox
-Undercoated/Rust Proofed
-Grounding Kit
mcclintock89 is offline  
Reply

Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Fixing the AC Evap Drain Leak ucf_motorcycle Titan General Discussion 6 09-17-2008 01:16 PM
EVAP Vent Control S/V 305hp Titan Problems & Dealer Service 9 05-07-2008 06:05 PM
Evap Leak FLYTECH Titan Problems & Dealer Service 1 12-23-2007 02:59 PM
Exhaust Leak & Transfer Case Leak Clinsta Titan Problems & Dealer Service 1 01-29-2007 11:27 AM
EVAP cannister problem TitanVol Titan Problems & Dealer Service 1 03-03-2005 10:29 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On