Oil pressure gauge always on high - Nissan Titan Forum
Titan General Discussion General Discussion about the Nissan Titan.

Reply
 
LinkBack Thread Tools Rate Thread Display Modes
#1 (permalink) Old 02-05-2012, 06:45 AM
Registered User
 
Join Date: Aug 2006
Location: Denver, CO
Posts: 367
Thanks: 0
Thanked 18 Times in 15 Posts
iTrader Score: 0 reviews
Oil pressure gauge always on high

About a week ago I noticed my pressure gauge is always on high. Is this from an over fill by grease monkey and if so what damage can it cause? Truck seems to run fine but I swear that needle use to react depending on how much gas I gave it.
krc333 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-05-2012, 12:45 PM
Registered User
 
Join Date: Dec 2004
Posts: 1,743
Thanks: 284
Thanked 399 Times in 266 Posts
iTrader Score: 3 reviews
Re: Oil pressure gauge always on high

Yes, too much oil pressure is bad. You can open the system while it's running (take the cap off, put a rag on) and see if it goes down. My bet is that the gauge or the sender has gone bad. When you're idling it should be reasonably low. What does your oil level say?
jdmartin is offline  
#3 (permalink) Old 02-07-2012, 12:39 PM
Registered User
 
Join Date: Aug 2006
Location: Denver, CO
Posts: 367
Thanks: 0
Thanked 18 Times in 15 Posts
iTrader Score: 0 reviews
Re: Oil pressure gauge always on high

Thanks, i'm going to check my oil level tonight when i get home and see. How do i know if that sensor is bad? Is it hard thing to replace? Does it throw a code?
krc333 is offline  
#4 (permalink) Old 02-07-2012, 02:38 PM
Premium User
Nissan Titan Status - Premium Member
 
OFELIPE's Avatar
 
Join Date: Aug 2011
Location: Rexburg, Idaho
Posts: 4,276
Thanks: 3,345
Thanked 1,226 Times in 855 Posts
iTrader Score: 3 reviews
Re: Oil pressure gauge always on high

Quote:
Originally Posted by krc333 View Post
Thanks, i'm going to check my oil level tonight when i get home and see. How do i know if that sensor is bad? Is it hard thing to replace? Does it throw a code?
turn the key to the "on/run" position, but dont start the truck, if the needle pegs without the engine running then your sending unit is shot.

StarvinMarvinWhore™
Tiny 2010 Jeep Wrangler Unlimited Rubicon
Natural Green
OFELIPE is offline  
#5 (permalink) Old 02-07-2012, 08:59 PM
Registered User
 
PAPARYNO's Avatar
 
Join Date: Aug 2007
Location: Pensacola, FL
Posts: 1,069
Thanks: 700
Thanked 293 Times in 196 Posts
iTrader Score: 1 reviews
Re: Oil pressure gauge always on high

mine does this only until the tranny heats up



CAMS CAMS CAMS CAMS CAMS CAMS CAMS CAMS CAMS CAMS CAMS

UPREV! OG

06 TITAN LE CC 4X2 Loaded w/Nav & DVD,BT, ValentineRD, G-Tech,
AEM BruteForce CAI, Stillen LongTubes, Jwt Cams, Uprev, Tranny Line Pressure Mod, Level 10 Tranny, 08 Brake Upgrade With Hawk LTS Pads and Goodridge stainless steel brake lines, 08 Intake Manifold, TB Bypass, DDM HID 8K Lows and Fogs, Stillen SwayBars
F&R, Magnaflow 50 Duals, TruTrac,NX 100Shot w/RemoteOpener


BC 0-60mph 7.81sec. 1/4mile 16.01sec.@87.0mph (Top Speed 122mph)
AC 0-60mph 5.21sec. 1/4mile 13.65sec.@99.93mph
(Top Speed 140+mph)!!
Dynotech Dyno SAE #'s N/A Map 325.71 RWHP / 364.06 TQ (old Dyno 273hp/338tq)

GO NISSAN

They say O-FiveCC who but i say gweazel77 who
PAPARYNO is offline  
#6 (permalink) Old 02-08-2012, 07:19 PM
Registered User
 
Join Date: Jan 2011
Posts: 33
Thanks: 1
Thanked 5 Times in 5 Posts
iTrader Score: 0 reviews
Re: Oil pressure gauge always on high

Cold starts no matter what outside temp until the engine warms all the way up, if I am not careful will peg the oil pressure gauge. The dealership said "oh thats normal" but Im not putting a lot of insurance in that statement, I just watch the throttle till shes completely warm. And this is with a K&N filter with royal purple synthetic 5/30.
Westy0507 is offline  
#7 (permalink) Old 02-09-2012, 01:12 PM
Premium User
Nissan Titan Status - Premium Member
 
OFELIPE's Avatar
 
Join Date: Aug 2011
Location: Rexburg, Idaho
Posts: 4,276
Thanks: 3,345
Thanked 1,226 Times in 855 Posts
iTrader Score: 3 reviews
Quote:
Originally Posted by Westy0507 View Post
Cold starts no matter what outside temp until the engine warms all the way up, if I am not careful will peg the oil pressure gauge. The dealership said "oh thats normal" but Im not putting a lot of insurance in that statement, I just watch the throttle till shes completely warm. And this is with a K&N filter with royal purple synthetic 5/30.
That's what mine did after I had my oil sending unit replaced


Sent from my Autoguide iPad app

StarvinMarvinWhore™
Tiny 2010 Jeep Wrangler Unlimited Rubicon
Natural Green
OFELIPE is offline  
#8 (permalink) Old 02-15-2012, 07:41 AM
Registered User
 
Mo-Titan's Avatar
 
Join Date: Sep 2009
Location: Joplin/Webb City, MO
Posts: 414
Thanks: 89
Thanked 183 Times in 125 Posts
iTrader Score: 24 reviews
Re: Oil pressure gauge always on high

Hurt anything to drive around with a bad sending unit? Mine pegged out this morning, oil looks fine. If it stops raining I'll try turning just the key on, but my guess is the unit is bad, cause I shut the truck off and restarted.. same pegged gauge.

Titan Sold - 3-06-2012, Plan Z = '96 BMW Z3 - Traded 7-13-12 (Friday the 13th)
Mo-Titan is offline  
#9 (permalink) Old 02-15-2012, 08:33 AM
Premium User
Nissan Titan Status - Premium Member
 
Join Date: May 2006
Location: Misplaced in SC
Posts: 14,530
Thanks: 520
Thanked 1,075 Times in 761 Posts
iTrader Score: 5 reviews
Re: Oil pressure gauge always on high

his statement "Grease Monkey" said it all. yes over filling is bad, blow out seals and alot of blow by.

2014 Silver Ram Laramie 4x4 w/ leather and Alpine sound
2008 Red Brawn Titan SE 4x4 Popular package
[
ArmyAviation is offline  
#10 (permalink) Old 02-15-2012, 12:05 PM
Registered User
 
vilim12's Avatar
 
Join Date: May 2008
Location: Cape Coral, Florida
Posts: 13,040
Thanks: 2,513
Thanked 2,875 Times in 1,923 Posts
iTrader Score: 5 reviews
Send a message via AIM to vilim12
Re: Oil pressure gauge always on high

feed it cheerios

2008 Nissan Titan Pro-4x CC LWB Smoke
vilim12 is offline  
The Following 2 Users Say Thank You to vilim12 For This Useful Post:
FREDC (08-17-2012), Mrlunchbox (03-01-2013)
#11 (permalink) Old 02-15-2012, 12:31 PM
Banned
 
JTeeter04's Avatar
 
Join Date: Sep 2010
Location: New York
Posts: 1,504
Thanks: 47
Thanked 308 Times in 211 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by vilim12 View Post
feed it cheerios
Dadum chss


Sent from my Autoguide iPhone app
JTeeter04 is offline  
The Following User Says Thank You to JTeeter04 For This Useful Post:
vilim12 (02-15-2012)
#12 (permalink) Old 02-15-2012, 12:33 PM
Premium User
Nissan Titan Status - Premium Member
 
OFELIPE's Avatar
 
Join Date: Aug 2011
Location: Rexburg, Idaho
Posts: 4,276
Thanks: 3,345
Thanked 1,226 Times in 855 Posts
iTrader Score: 3 reviews
Re: Oil pressure gauge always on high

Quote:
Originally Posted by Mo-Titan View Post
Hurt anything to drive around with a bad sending unit? Mine pegged out this morning, oil looks fine. If it stops raining I'll try turning just the key on, but my guess is the unit is bad, cause I shut the truck off and restarted.. same pegged gauge.
Not going to hurt anything with the sending unit out. Just make sure the pressur isnt actually high. ignition on/engine off will tell you.

You could also try a guage reset if it happens to be physically stuck.

Putting the cluster into test mode-
With ign off press and hold the odo. reset button, now turn the key to ON while continuing to hold down the reset button.
this will take you to a test screen, now everytime you push the reset button it will take you to a new screen, do this till it test all needles.

StarvinMarvinWhore™
Tiny 2010 Jeep Wrangler Unlimited Rubicon
Natural Green
OFELIPE is offline  
The Following User Says Thank You to OFELIPE For This Useful Post:
GENMAX (08-07-2014)
#13 (permalink) Old 02-15-2012, 12:44 PM
Registered User
 
moonlight's Avatar
 
Join Date: May 2011
Location: Toronto, Ontario
Posts: 154
Thanks: 78
Thanked 62 Times in 38 Posts
iTrader Score: 0 reviews
Re: Oil pressure gauge always on high

Quote:
Originally Posted by OFELIPE View Post
Not going to hurt anything with the sending unit out. Just make sure the pressur isnt actually high. ignition on/engine off will tell you.

You could also try a guage reset if it happens to be physically stuck.

Putting the cluster into test mode-
With ign off press and hold the odo. reset button, now turn the key to ON while continuing to hold down the reset button.
this will take you to a test screen, now everytime you push the reset button it will take you to a new screen, do this till it test all needles.
Has anyone figured out what all those other readings are when you run the test mode on the cluster? I figured out how to read live RPM and a few others but I'd love to know what all those other numbers & readings are.

2005 Infiniti QX56 -- Project Moonlight
Car Domain Youtube Vimeo

Audio: Subs: 2 JL 13W7 Mids: 2 JL C5 speakers Amps: 2 JL 1000/1, 1 JL 300/2, 1 JL 400/4 Deck: Pioneer AVIC Z110BT Aux: PS3, MacMini, Ipod Screens: re-mount OEM display to roof, touch-screen Mac display, Pioneer Deck custom mount, two 8-inch swivel-mount flip-down screens in second row (headrests to follow )
Interior: Custom upholstery, headliner, speaker mounts, speaker cover, sub box & amp rack, Champagne bottle & hidden mousepad... i think thats all
Muscle: AEM Brute Force CAI, Stillen SC, Stillen Ceramic headers & b-pipe, full custom true-dual exhaust, B&M Tranny & Oil cooler kit, Stillen Big Break Kit (front) & 3 Kinetik Batteries (2000W+ 2*1200W), *2 Magnaflow dual 3" tips

give me a VK56, or some Rossi's, either way i wanna go fast till I hit terminal velocity, ride hard till it burns, and carve till the rest are all behind me.
moonlight is offline  
#14 (permalink) Old 07-17-2013, 04:22 AM
Registered User
 
Join Date: Jul 2013
Posts: 53
Thanks: 0
Thanked 4 Times in 4 Posts
iTrader Score: 0 reviews
Re: Oil pressure gauge always on high

My truck does the same thing like right when I turn it on my gauge is on high, but after a awhile it goes back to the middle. As soon as I accelerate it goes back up to high. What would y'all recommend I do.
paco1309 is offline  
#15 (permalink) Old 07-22-2013, 03:35 AM
Premium User
Nissan Titan Status - Premium Member
 
OFELIPE's Avatar
 
Join Date: Aug 2011
Location: Rexburg, Idaho
Posts: 4,276
Thanks: 3,345
Thanked 1,226 Times in 855 Posts
iTrader Score: 3 reviews
Re: Oil pressure gauge always on high

Wow this is from a while ago lulz. The thread is back from the grave.

StarvinMarvinWhore™
Tiny 2010 Jeep Wrangler Unlimited Rubicon
Natural Green
OFELIPE is offline  
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Titan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
oil preasure gauge reading high El Mamito USMC Titan Problems & Dealer Service 5 11-14-2011 04:45 PM
oil pressure gauge going up wmg Titan Engine, Transmission & Drivetrain 3 07-20-2007 05:27 PM
Oil Pressure Gauge Pegs On High Mark FlimFlamMan Titan Problems & Dealer Service 20 01-12-2006 03:58 PM
AFE & OIL PRESSURE GAUGE 20TITAN04 Titan General Discussion 6 10-15-2005 06:43 PM
Temp gauge ran high while trailing on 4LO alvinispogi Titan General Discussion 3 07-16-2004 02:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On