OBD II connector not communicating?? - Nissan Titan Forum
Titan Performance Modifications Install a new part and cant wait to tell us about it? Great! We'd love to hear about it in here.

 
LinkBack Thread Tools Rate Thread Display Modes
#1 (permalink) Old 06-27-2008, 11:08 PM
Registered User
 
Shee Nut's Avatar
 
Join Date: Jul 2007
Location: Gilbert,Az
Posts: 132
Thanks: 5
Thanked 4 Times in 4 Posts
iTrader Score: 0 reviews
Angry OBD II connector not communicating??

I have power to the OBD II,it's just not communicating with anything.
I still haven't been able to get my Bully Dog tune to load on to my truck yet.
The BD programer powers up when you plug it in,but it doesn't make it past
"turn key to on position".
I Had my buddy plug his scanner tool in to the OBD II port and he couldn't get it to read anything either, it said "communication error"
I get power,but nothing's talking to each other WTF??
I think my forehead is gonna cave in from banging it off the ****ing steering wheel.
Any ideas guys?
Thanks.

06 XE KC Big Tow 2wd
JBA catback (muffler replaced with flowmaster 70)
Stillen CAI
2* advance
14.996 at 92.23 bone stock (2,339' DA)
14.549 at 94.07 With mods & no spare or tailgate (2,828' DA)
Shee Nut is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-28-2008, 08:39 AM
Registered User
 
dangerous's Avatar
 
Join Date: Apr 2008
Location: Cave Creek, AZ
Posts: 207
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: OBD II connector not communicating??

Quote:
Originally Posted by Shee Nut
I have power to the OBD II,it's just not communicating with anything.
I still haven't been able to get my Bully Dog tune to load on to my truck yet.
The BD programer powers up when you plug it in,but it doesn't make it past
"turn key to on position".
I Had my buddy plug his scanner tool in to the OBD II port and he couldn't get it to read anything either, it said "communication error"
I get power,but nothing's talking to each other WTF??
I think my forehead is gonna cave in from banging it off the ****ing steering wheel.
Any ideas guys?
Thanks.
Is your truck under warranty? the beauty here (in AZ) if the OBDII doesn't work they can't check your emssions. and Emissions related items generally have a longer warranty period.
My Point is: Maybe your truck has issues that can be covered under Warranty.

2008.5 Titan 4x4 LE CC,Moonroof, Tow Package, Nav/7"LCD wGPS &DVD, Step Rails, Sliding Bed Extender
ya baby.....it's got it all..

MODs
AFE Cold Air Intake Stage 2 (4/30/08)
BullyDog PowerPup 8/19/08
dangerous is offline  
#3 (permalink) Old 06-28-2008, 11:53 AM
Premium User
Nissan Titan Status - Premium Member
 
baseballfanz's Avatar
 
Join Date: Jun 2005
Location: Sugar Land, Republic of Texas
Posts: 17,122
Thanks: 2,236
Thanked 3,295 Times in 2,189 Posts
iTrader Score: 1 reviews
Re: OBD II connector not communicating??

Check the harness behind the plug to see if anything is loose.


2014 Wrangler Unlimited Sahara

Titan/Armada Part Numbers

Frequently asked fuse locations


305.5 WHP, 370.4 ft/lbs tq
baseballfanz is offline  
#4 (permalink) Old 06-28-2008, 11:56 AM
Registered User
 
Blue Thunder's Avatar
 
Join Date: Mar 2007
Posts: 108
Thanks: 9
Thanked 5 Times in 3 Posts
iTrader Score: 0 reviews
Re: OBD II connector not communicating??

Be sure your battery is good and turn off all power drawing equipment.

Classic (American Built) 2007 Majestic Blue XE KC 2WD CVTCS Preferred Package
Airaid MXP intake, Armada air dam, Extang Trifecta Signature Series, "Dog Tune"
Blue Thunder is offline  
#5 (permalink) Old 06-28-2008, 12:53 PM
Registered User
 
Join Date: Aug 2006
Posts: 82
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Re: OBD II connector not communicating??

check your fuses...........the cig lighter one

thats what it is on chevys
AZZ Titan is offline  
#6 (permalink) Old 06-28-2008, 10:28 PM
Registered User
 
Shee Nut's Avatar
 
Join Date: Jul 2007
Location: Gilbert,Az
Posts: 132
Thanks: 5
Thanked 4 Times in 4 Posts
iTrader Score: 0 reviews
Re: OBD II connector not communicating??

Well it turns out my ODBII is fine.I met up with another member today who has a Bully Dog programer
and his unit communicated just fine with my truck.
So I drive home and try my BD again, messing with it and after about 20 try's of plugging it in and unplugging it,
I got it to communicate!!
There is definetly something wrong with my programer,but it does work.
I just leave the key on,and plug it in,and unplug it,plug it in,and unplug it
about 10 times in a row until it reads "communicating with vehicle" then it works fine.
I got my tune downloaded and WOT disabled and it feels reeeaal good!!
Thank you to the guys who commented on this thread.

06 XE KC Big Tow 2wd
JBA catback (muffler replaced with flowmaster 70)
Stillen CAI
2* advance
14.996 at 92.23 bone stock (2,339' DA)
14.549 at 94.07 With mods & no spare or tailgate (2,828' DA)
Shee Nut is offline  
#7 (permalink) Old 06-29-2008, 08:07 AM
Premium User
Nissan Titan Status - Premium Member
 
baseballfanz's Avatar
 
Join Date: Jun 2005
Location: Sugar Land, Republic of Texas
Posts: 17,122
Thanks: 2,236
Thanked 3,295 Times in 2,189 Posts
iTrader Score: 1 reviews
Re: OBD II connector not communicating??

Good to hear. You should still contact BD about maybe exchanging for a new unit. I would hate to have to try 20 times every time you want to flash it.


2014 Wrangler Unlimited Sahara

Titan/Armada Part Numbers

Frequently asked fuse locations


305.5 WHP, 370.4 ft/lbs tq
baseballfanz is offline  
#8 (permalink) Old 06-30-2008, 09:53 AM
Registered User
 
Join Date: Jun 2008
Posts: 63
Thanks: 4
Thanked 4 Times in 3 Posts
iTrader Score: 0 reviews
Re: OBD II connector not communicating??

Quote:
Originally Posted by Shee Nut
Well it turns out my ODBII is fine.I met up with another member today who has a Bully Dog programer
and his unit communicated just fine with my truck.
So I drive home and try my BD again, messing with it and after about 20 try's of plugging it in and unplugging it,
I got it to communicate!!
There is definetly something wrong with my programer,but it does work.
I just leave the key on,and plug it in,and unplug it,plug it in,and unplug it
about 10 times in a row until it reads "communicating with vehicle" then it works fine.
I got my tune downloaded and WOT disabled and it feels reeeaal good!!
Thank you to the guys who commented on this thread.
I have released a new version, 1.0.3. I added some new part numbers, and fixed the Communication issue. Update to this version and let me know if you are still having the Issues.

Thanks Jrock
jrock181 is offline  
#9 (permalink) Old 06-30-2008, 12:00 PM
Registered User
 
Gonpostal's Avatar
 
Join Date: Jul 2006
Location: San Diego
Posts: 421
Thanks: 0
Thanked 2 Times in 2 Posts
iTrader Score: 2 reviews
Re: OBD II connector not communicating??

should everyone one with 102 update to 103?

Mods: CST spindles, DR coilovers, PRG UCA, Bilstein rear shocks, 1.5 deavers, OR Traction Bars, 3 inch BL, N fab bars, AEM Brute force intake, Banks exhaust, Bully Dog, 18x10 Mazzi Hulks, 37x12.50 M/T Toyo O/C.(Next Mod....Gears from hoopers and Diff Cover.
Gonpostal is offline  
#10 (permalink) Old 06-30-2008, 12:08 PM
Registered User
 
Join Date: Jun 2008
Posts: 63
Thanks: 4
Thanked 4 Times in 3 Posts
iTrader Score: 0 reviews
Re: OBD II connector not communicating??

Quote:
Originally Posted by Gonpostal
should everyone one with 102 update to 103?
If yours is working fine, Then you can stay at the version you are at, But if you want to it wouldn't hurt.
jrock181 is offline  
#11 (permalink) Old 06-30-2008, 05:20 PM
Registered User
 
Join Date: Apr 2007
Location: Kernersville, NC
Posts: 68
Thanks: 79
Thanked 11 Times in 9 Posts
iTrader Score: 0 reviews
Re: OBD II connector not communicating??

Thank you, I think this fixed my issues. after i downloaded this update, this is the first time it actually says up to date. I can now hook up the bully dog and it communicates with my truck the first time. Anyone on the fence about buying one, it is money well spent.
jimd27284 is offline  
#12 (permalink) Old 07-02-2008, 05:32 AM
Registered User
 
QShip's Avatar
 
Join Date: Oct 2004
Location: Enfield, CT
Posts: 2,924
Thanks: 839
Thanked 349 Times in 223 Posts
iTrader Score: 1 reviews
Re: OBD II connector not communicating??

Sounds like good customer service.

Friends don't let friends add boost to their Titans...

2004 SE KC 4x4 Titan
B & B Exhaust
Volant CAI
Stillen S/C
Stillen Headers
TruTrak
IPT VB
Level 10 TC
Level 10 Rebuild kit
RB tuned ECU
QShip is offline  
Reply

Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
07 alternator connector netboy Titan General Discussion 0 11-28-2007 07:21 PM
7-pin versus 4-pin connector cowzrul Titan Towing & Hauling 13 06-01-2007 09:21 AM
RF Ipod connector Tdon Titan Visual & Audio Discussion 0 01-19-2007 06:18 AM
M-46 Connector Hurst Titan Interior Discussion 2 12-21-2004 12:48 PM
AMP connector question DryHeat Titan Interior Discussion 6 09-21-2004 02:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On