A/C issue - Nissan Titan Forum
Titan Problems & Dealer Service Having a problem with your truck? Dealer service got you down? Let us know here.

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 2 (permalink) Old 04-03-2017, 07:39 PM Thread Starter
Registered User
 
Cwright22's Avatar
 
Join Date: Oct 2016
Location: Canton, OH
Posts: 58
Thanks: 18
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
A/C issue

Searched and couldn't find anyone with the same issue as mine. But forgive me if I misread.

So went to turn on the a/c on a trip this past weekend and it was blowing hot. (Just had AC checked and was low a bit but we added to it and now is good)

Only had it turned to like half cold on the temp control knob. So after a few minutes(thought maybe it needed to circulate) it still didn't turn cold. Just hot air. So I turned it up to max cold on temp knob. Then it started blowing cold.

Turned it down one notch, hot air. So let's say 10 positions in the temp knob. Max cold being 1 and 10 being max heat. 1 works cold. 2-10 are hot.

Switch problem? There is a TSB on the blend door. So could be that?

Sent from my VS995 using Tapatalk
Cwright22 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-21-2017, 03:53 AM
Registered User
 
billywtrs's Avatar
 
Join Date: Apr 2017
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: A/C issue

My Titan is a week old, and mine was blowing warm air this morning. Temp was set at 65 deg. In the afternoon it seems to be fine, I didn't turn the fan speed up more like you did, maybe I'll try that.
billywtrs is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Titan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
4x issue slammedNISSAN Titan Engine, Transmission & Drivetrain 1 12-30-2011 11:32 AM
My first issue SHIPREC13 Titan General Discussion 3 01-23-2005 12:02 PM
Is this a Horn Issue (First issue for a newbie) lsutyger Titan Problems & Dealer Service 14 10-04-2004 05:39 AM
Another QC Issue? j_farkas Titan General Discussion 6 07-24-2004 06:11 PM
Who is with me on this issue ... ttz32 Titan General Discussion 17 03-03-2004 07:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On