Trailer running lights won't work - Nissan Titan Forum
Titan Problems & Dealer Service Having a problem with your truck? Dealer service got you down? Let us know here.

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 08-27-2007, 09:21 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Trailer running lights won't work

hi,
I recently had U-haul add their standard trailer hitch and 4-way/7-way adapter electrical kit to my '06 Armada. when no lights worked then I added three relays to the relay fuse box under the hood: two aftermarket blue relays for right and left trailer turn signals and a brown relay where it says Trailer Tow Power No.2

Now the turn signals work fine on the trailer and so do brake lights. But the running lights don't work.

Any ideas on how to fix? Thanks
JWibbs is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-27-2007, 09:46 PM
Registered User
 
Nissan Mike's Avatar
 
Join Date: Oct 2005
Location: So Calif
Posts: 1,802
Thanks: 45
Thanked 71 Times in 43 Posts
iTrader Score: 0 reviews
Re: Trailer running lights won't work

Check the 2 red 10 amp fuses under your dash along the steering coulmn,they're wired in-line in the BCM harness





Drive it like you rented it.....

Last edited by Nissan Mike; 08-27-2007 at 09:49 PM.
Nissan Mike is offline  
post #3 of 4 (permalink) Old 08-27-2007, 10:28 PM Thread Starter
Registered User
 
Join Date: Aug 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: Trailer running lights won't work

looked under steering column but did not see two red fuses and not sure what the BCM harness looks like. mine is an '06 Armada...is the BCM the same as on a Titan?
JWibbs is offline  
post #4 of 4 (permalink) Old 08-27-2007, 10:32 PM
Registered User
 
Nissan Mike's Avatar
 
Join Date: Oct 2005
Location: So Calif
Posts: 1,802
Thanks: 45
Thanked 71 Times in 43 Posts
iTrader Score: 0 reviews
Re: Trailer running lights won't work

I believe so,this is a small harness wrapped in black tape either attached or running alongside the coulmn maybe a couple inches away?You are looking for 2 red mini fuses.Sorry I don't know if the Armada is the same





Drive it like you rented it.....
Nissan Mike is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Titan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Trailer Running Lights tshank Titan Problems & Dealer Service 11 06-30-2009 07:32 AM
trailer running lights dont work ehill Titan Problems & Dealer Service 6 09-11-2007 08:19 PM
Trailer Lights : running lights not working Chance2336 Titan Towing & Hauling 9 09-12-2006 06:33 PM
running lights on boat trailer bellpac Titan General Discussion 4 04-18-2005 07:26 PM
trailer running lights woes Glen Titan FAQ & How to Area 8 11-03-2004 03:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On