Squeaking in front end?? - Nissan Titan Forum
Titan Problems & Dealer Service Having a problem with your truck? Dealer service got you down? Let us know here.

 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 11 (permalink) Old 03-10-2008, 02:30 PM Thread Starter
Registered User
 
husker1206's Avatar
 
Join Date: Jan 2008
Location: Nocona, Texas
Posts: 190
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 2 reviews
Squeaking in front end??

Every time my front suspension moves, like going over uneven ground, it squeaks and it is getting annoying. Anybody else have this problem. Maybe I could just grease it, but I have no clue where it is comming from. Thanks for the comments in advance.


2005 CC LE 4x4: 2" leveling kit
35-12.50-18, Nitto Mud Grapplers
Volant CAI, Helix TBS, 2* Advance
Borla Dual Exhaust
husker1206 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 03-10-2008, 02:39 PM
Registered User
 
Pops's Avatar
 
Join Date: Apr 2007
Location: Okc
Posts: 8,849
Thanks: 2,269
Thanked 2,945 Times in 1,788 Posts
iTrader Score: 1 reviews
Re: Squeaking in front end??

It should just be the front Stabilizer Bar Bushings inside the U-Brackets next to the skid plate edges. I've had this issue with past trucks and will be pulling mine off soon to grease. If you eventually want new bushings, they're really cheap from the dealer.

Part 54613 on this diagram: http://www.courtesyparts.com/betasit...1147_1149.html

2005 Armada LE 4x4

Last edited by Pops; 03-10-2008 at 04:14 PM.
Pops is offline  
post #3 of 11 (permalink) Old 03-10-2008, 06:34 PM
Registered User
 
Guiseppe's Avatar
 
Join Date: Feb 2007
Location: Tucson
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: Squeaking in front end??

I have a squeaking problem too, at first I thought it was the suspension. But, the other day I got out of my truck and I was in the frontof it when my son shut his door. I found out it is the chrome grill. I wish there was a way to tighten it or something, it's annoying.
Guiseppe is offline  
post #4 of 11 (permalink) Old 03-11-2008, 11:54 PM Thread Starter
Registered User
 
husker1206's Avatar
 
Join Date: Jan 2008
Location: Nocona, Texas
Posts: 190
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 2 reviews
Re: Squeaking in front end??

Quote:
Originally Posted by Pops
It should just be the front Stabilizer Bar Bushings inside the U-Brackets next to the skid plate edges. I've had this issue with past trucks and will be pulling mine off soon to grease. If you eventually want new bushings, they're really cheap from the dealer.

Part 54613 on this diagram: http://www.courtesyparts.com/betasit...1147_1149.html
So just take them off and grease them or put new bushings in and that will fix it??


2005 CC LE 4x4: 2" leveling kit
35-12.50-18, Nitto Mud Grapplers
Volant CAI, Helix TBS, 2* Advance
Borla Dual Exhaust
husker1206 is offline  
post #5 of 11 (permalink) Old 03-12-2008, 07:47 AM
Registered User
 
Pops's Avatar
 
Join Date: Apr 2007
Location: Okc
Posts: 8,849
Thanks: 2,269
Thanked 2,945 Times in 1,788 Posts
iTrader Score: 1 reviews
Re: Squeaking in front end??

Quote:
Originally Posted by husker1206
So just take them off and grease them or put new bushings in and that will fix it??
Yep. Clean it up with a scrub brush and use lots of grease, it's cheap. I'm also trying to find something to help cover the sides of those a little bit to help keep the grime out. I'm thinking when I remove my stabilizer bar that I'll shop hardware stores and so forth to see if anything will work as a cover for the bushing sides.

2005 Armada LE 4x4
Pops is offline  
post #6 of 11 (permalink) Old 03-12-2008, 10:14 AM Thread Starter
Registered User
 
husker1206's Avatar
 
Join Date: Jan 2008
Location: Nocona, Texas
Posts: 190
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 2 reviews
Re: Squeaking in front end??

Quote:
Originally Posted by Pops
Yep. Clean it up with a scrub brush and use lots of grease, it's cheap. I'm also trying to find something to help cover the sides of those a little bit to help keep the grime out. I'm thinking when I remove my stabilizer bar that I'll shop hardware stores and so forth to see if anything will work as a cover for the bushing sides.
By stabilizer bar you are refering to sway bar right?? If so, I dont have mine hooked up. I unbolted it at the links, but I guess it could still be moving around in there and making noise. I will just take it all the way out today and see if that fixes it.


2005 CC LE 4x4: 2" leveling kit
35-12.50-18, Nitto Mud Grapplers
Volant CAI, Helix TBS, 2* Advance
Borla Dual Exhaust
husker1206 is offline  
post #7 of 11 (permalink) Old 03-12-2008, 10:23 AM
Registered User
 
Pops's Avatar
 
Join Date: Apr 2007
Location: Okc
Posts: 8,849
Thanks: 2,269
Thanked 2,945 Times in 1,788 Posts
iTrader Score: 1 reviews
Re: Squeaking in front end??

Quote:
Originally Posted by husker1206
By stabilizer bar you are refering to sway bar right?? If so, I dont have mine hooked up. I unbolted it at the links, but I guess it could still be moving around in there and making noise. I will just take it all the way out today and see if that fixes it.
Yep. Stabilizer, Anti-Sway, whatever... I think completely removing it might likely fix this for you.

2005 Armada LE 4x4
Pops is offline  
post #8 of 11 (permalink) Old 03-12-2008, 05:46 PM Thread Starter
Registered User
 
husker1206's Avatar
 
Join Date: Jan 2008
Location: Nocona, Texas
Posts: 190
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 2 reviews
Re: Squeaking in front end??

alright its gone now. I took the sway bar out. Thanks Pops


2005 CC LE 4x4: 2" leveling kit
35-12.50-18, Nitto Mud Grapplers
Volant CAI, Helix TBS, 2* Advance
Borla Dual Exhaust
husker1206 is offline  
post #9 of 11 (permalink) Old 03-12-2008, 07:01 PM
Registered User
 
Pops's Avatar
 
Join Date: Apr 2007
Location: Okc
Posts: 8,849
Thanks: 2,269
Thanked 2,945 Times in 1,788 Posts
iTrader Score: 1 reviews
Re: Squeaking in front end??

Nice!!!!!!!

2005 Armada LE 4x4
Pops is offline  
post #10 of 11 (permalink) Old 03-12-2008, 09:44 PM Thread Starter
Registered User
 
husker1206's Avatar
 
Join Date: Jan 2008
Location: Nocona, Texas
Posts: 190
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 2 reviews
Re: Squeaking in front end??

Well I take that back. It stopped for a little while, but now it is doing it again lol..any more sugestions??


2005 CC LE 4x4: 2" leveling kit
35-12.50-18, Nitto Mud Grapplers
Volant CAI, Helix TBS, 2* Advance
Borla Dual Exhaust
husker1206 is offline  
post #11 of 11 (permalink) Old 03-12-2008, 10:01 PM
Registered User
 
Pops's Avatar
 
Join Date: Apr 2007
Location: Okc
Posts: 8,849
Thanks: 2,269
Thanked 2,945 Times in 1,788 Posts
iTrader Score: 1 reviews
Re: Squeaking in front end??

One way of troubleshooting is to pop the hood, climb on top of the radiator and bounce on it to see if anything squeaks. You can also jack it up to move the parts by hand or with a pry bar to narrow it down.

There's all kinds of bushings in the suspension and also a thin rubber "pad" on the bottom of the coilover spring that dampens the spring from the bracket. You can use WD40 to spot spray different joints on the UCA, LCA, and Shock connections to see if and where spraying puts a permanent stop to it and that rubber piece coming dislodged has caused some some Armadas to squeak. Other things to check are Hood Hinges, Hood Latch, Billet Grille, and Bug Deflector. I know of one that a squeaking Hood Hinge sounded like it was coming from the suspension for some reason.

Climbing on the Nerf Bars or front end and Bouncy bounce jump jump are how I usually try to narrow them down then lift a little and drop with a floorjack a few times to narrow down further.

You could also use a car wash high pressure to spray all over the suspension inside the wheels wells and underneath really good to see if it's just some Winter Grime that can washout easily.

2005 Armada LE 4x4

Last edited by Pops; 03-12-2008 at 10:20 PM.
Pops is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Titan Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Bed is squeaking? PSNissanFleetMgr Titan General Discussion 4 02-23-2008 09:16 PM
Brakes still squeaking TopMyTitan Titan Wheels, Tires & Brakes 6 02-14-2007 06:12 PM
brake squeaking? titanmike Titan General Discussion 7 02-13-2007 11:49 PM
Brakes are squeaking jnoriega23 Titan Problems & Dealer Service 1 10-06-2005 01:04 PM
HELP! Chassis Squeaking titancrazy Titan General Discussion 10 07-26-2005 11:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On