dead battery / clicking sound & gauges fluctuate - Nissan Titan Forum
Titan Problems & Dealer Service Having a problem with your truck? Dealer service got you down? Let us know here.

Reply
 
LinkBack Thread Tools Rate Thread Display Modes
#1 (permalink) Old 10-08-2008, 05:40 PM
Registered User
 
Join Date: Apr 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
dead battery / clicking sound & gauges fluctuate

About a month ago my 05 titan wouldn't turn over. When I would turn the key there was a series of clicks and the gauges would jump around for 20 to 30 secs but that was it. Got a jump and drove it home. That night I cleaned / tightened the battery cables and all seemed fine. Today the same thing happened and again it jump started just fine. When I got it home though the battery hadn't taken any charge from the 20 mile trip and of course it wouldn't start. I've stuck the battery on a charger and tested alternator (is fine). I'm guessing I've got a loose cable from alt to battery or battery to ground, but I'm worried about those clicks and jumping guages. My guess is that they are caused by the low battery, but I thought I would ask in case someone smarter than me knows if they (clicks / jumping gauges) indicate anything else. Thanks in advance.
cowboyx is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-08-2008, 05:45 PM
Banned
 
bbomar's Avatar
 
Join Date: Feb 2006
Posts: 27,782
Thanks: 612
Thanked 969 Times in 631 Posts
iTrader Score: 12 reviews
Re: dead battery / clicking sound & gauges fluctuate

The battery is dead!!

Replace it!

Lucky you, I wasn't able to jump mine!
bbomar is offline  
#3 (permalink) Old 10-08-2008, 06:44 PM
Registered User
 
ptvolly's Avatar
 
Join Date: May 2006
Location: Cincinnati
Posts: 372
Thanks: 0
Thanked 19 Times in 12 Posts
iTrader Score: 1 reviews
Re: dead battery / clicking sound & gauges fluctuate

Mine just did the same 2 days ago. Jumped it and it's run fine since, but yeah, both our batteries need replaced!

'05 Smoke CC LE 4X4
PC 6" Stage 1
PC 8188 18X9
PC Xtreme A/T 325/65/18
Bully Dog / Magnaflow "cat-back" / Tint / NISMO CAI / 6k HID / Westin Bull w/ PIAA lights / Truxedo / Carriage Works Grill / Airlift rear bags / Bushwacker Pocket Flares
My super duper MPG doubler- a 1996 Grand Prix coupe!
ptvolly is offline  
#4 (permalink) Old 10-08-2008, 07:12 PM
Registered User
 
Goliath's Avatar
 
Join Date: Jul 2008
Posts: 53
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: dead battery / clicking sound & gauges fluctuate

In my experience w/ a battery is once the cranking amps go, it's time to replace. I don't the difference b/w cranking amps and normal running amps(???) but the activities you describe are exactly those of a dying battery. I have used and stand behind interstate batteries. They are pricey but they last better than any battery I've used.
Goliath is offline  
#5 (permalink) Old 10-09-2008, 06:11 AM
Registered User
 
Join Date: Jan 2007
Location: Weatherford, Texas
Posts: 288
Thanks: 3
Thanked 16 Times in 11 Posts
iTrader Score: 0 reviews
Re: dead battery / clicking sound & gauges fluctuate

Just replaced mine with an Interstate about a month ago. Same scenario except mine started, it just turned over slower than normal. Killed it and tried again, dead. The factory batteries are absolute junk in these things! A lot of people will boast Optima, but it's a little to pricey for my needs.

crash519 is offline  
#6 (permalink) Old 10-09-2008, 08:56 AM
Registered User
 
AF-Medic's Avatar
 
Join Date: Jun 2006
Location: Cabot, Arkansas
Posts: 1,689
Thanks: 11
Thanked 54 Times in 39 Posts
iTrader Score: 4 reviews
Re: dead battery / clicking sound & gauges fluctuate

Get a new battery. The OEM ones aren't known for there quality. Better get it now before you get stranded somewhere

2007 SE Granite C/C 4X4 BT,OR,RF,Bed Package
Born 12/18/06 in Mississippi/ adopted 03/31/07 in Anchorage. Man that stork had a good drive.

Improved with Westin black aluminum nerf bars, Husky floor liners, Vent visors, Full billett grill, Black XE door handles,American racing Teflon THUG'S, Top Dawg folding tonneau cover, AEM brute force CAI with prefilter,
PRG 4INCH PERF Package with Saw's, Two 12 volt tech underseat subs with CDT 4100 and cdt replacment door speakers,MD DVD player with 8.5 screen Shift Pass You
AF-Medic is offline  
#7 (permalink) Old 07-14-2009, 04:23 PM
Registered User
 
Join Date: Jul 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: dead battery / clicking sound & gauges fluctuate

I am having the exact same problem and my batter is only two weeks old! It's something besides that. i have no clue. any help?
nickgoebel is offline  
#8 (permalink) Old 07-14-2009, 04:32 PM
Registered User
 
MRS.WIKEDVK's Avatar
 
Join Date: Apr 2009
Location: San Diego, CA
Posts: 4,988
Thanks: 1,361
Thanked 1,449 Times in 836 Posts
iTrader Score: 4 reviews
Re: dead battery / clicking sound & gauges fluctuate

my truck did the same thing about two weeks ago.. it freaked me out at first.. but then the blonde jumped it.. and drove it for about twenty min shut it off.. did the same thing.. new bat.. have not had a problem since.. =)

1/4 12.868@104.12 Famoso Racway

yeah, you just got beat by a girl

<3<3<3<3<3

BABY WIKED ON THE WAY
MRS.WIKEDVK is offline  
#9 (permalink) Old 07-16-2009, 01:43 AM
Registered User
 
iamsmithy's Avatar
 
Join Date: Apr 2008
Location: Dubai, UAE
Posts: 48
Thanks: 1
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Re: dead battery / clicking sound & gauges fluctuate

Mine died in an IKEA car park yesterday and wouldn't start even when jumped. Just clicked quickly when trying with jump leads attached, nothing when not. Its 41 degrees outside and I spent too long trying!!

Got a new battery installed this morning and it started up right away...

Fingers crossed that the alternator is still working though!

05 Galaxy Black Crew Cab 4x4 LE

iamsmithy is offline  
#10 (permalink) Old 08-08-2009, 02:26 PM
Registered User
 
Mikes05Titan's Avatar
 
Join Date: Jan 2007
Location: McKinney, TX
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: dead battery / clicking sound & gauges fluctuate

My 05 Titan has had the same battery problems. The fisrt time two years ago I replaced the OEM with a mega-tron Interstate battery. It lasted for about eight months. Ever since the initial battery going out I have had to replace the battery after roughly eight months. This past January I thought I'd try something different other than the Interstate and had the Nissan dealership install a Nissan battery. They tested all of the mechanics that use the battery, alt. etc. No problems. Just a dead battery. Just today, my Nissan battery went cold dead, overnight. Same thing with the gauges ticking and just ALL of the signs of a dead battery. I took the battery out and hauled it up to the dealership. They told me that they do not simply replace batteries without the vehicle (so they can test the alt, cables, etc.). They insisted that I have the vehicle towed to the dealership. So I complied. I just got a call from my service rep and he said that the truck was being washed and that nothing was wrong with the truck, other than having a dead battery. I guess I'll be back up there next April to get another battery!

2005 Titan Blizzard LE
Magnaflow Exhuast EC,CC/AEM Brute Force CAI/27560R20, 3 in. Body Lift w/ Gap Guards
Mikes05Titan is offline  
#11 (permalink) Old 08-10-2009, 09:37 PM
Registered User
 
Join Date: Feb 2006
Posts: 93
Thanks: 2
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
Re: dead battery / clicking sound & gauges fluctuate

Looks like the stockers are lasting about 3 years.

My '06 just started going dead...after towing my camper.

Pull the pop-up from Denver to Mt. Rushmore, drive truck for 2 days, hook up to drive home and nothing. Click-click-click

get jump, drive home, clean the connections, no issues for two weeks.

Go camping again, hook up camper, drive to camp, let truck idle for 1/2 hour un-hooked (in case draw was from the camper) turn off, re start no issues.

Get up Sunday, start truck no problem. go to leave and thing dead again.

weird stuff

Rod M.
'06 Silver SE CC, w/big Tow
Rodzilla is offline  
#12 (permalink) Old 06-23-2010, 09:52 AM
Registered User
 
josjohnson99's Avatar
 
Join Date: Aug 2006
Location: Jacksonville FL
Posts: 78
Thanks: 2
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
Send a message via AIM to josjohnson99
Re: dead battery / clicking sound & gauges fluctuate

bumpy..mine is doing this same thing now..its a 05 le BT i got it on 06 and since then the dealer has replaced the batt about 3 times..they say that there interstate batts.. i would like to get a aftermarket one but its still 100% covered under the warranty..
josjohnson99 is offline  
#13 (permalink) Old 06-23-2010, 09:54 AM
Premium User
Nissan Titan Status - Premium Member
 
baseballfanz's Avatar
 
Join Date: Jun 2005
Location: Sugar Land, Republic of Texas
Posts: 17,064
Thanks: 2,197
Thanked 3,263 Times in 2,171 Posts
iTrader Score: 1 reviews
Re: dead battery / clicking sound & gauges fluctuate

Quote:
Originally Posted by josjohnson99 View Post
bumpy..mine is doing this same thing now..its a 05 le BT i got it on 06 and since then the dealer has replaced the batt about 3 times..they say that there interstate batts.. i would like to get a aftermarket one but its still 100% covered under the warranty..
Duralast Gold here. 3 years free replacement is a plus, got one replaced free of charge after 2.5 years of use.


2014 Wrangler Unlimited Sahara

Titan/Armada Part Numbers

Frequently asked fuse locations


305.5 WHP, 370.4 ft/lbs tq
baseballfanz is offline  
#14 (permalink) Old 06-24-2010, 07:11 AM
Registered User
 
UWSkier's Avatar
 
Join Date: Jul 2006
Location: Brew City, WI
Posts: 253
Thanks: 4
Thanked 10 Times in 10 Posts
iTrader Score: 0 reviews
Re: dead battery / clicking sound & gauges fluctuate

Same here. Duralast Gold from Autozone. Replaced last fall and it cranked the truck over this winter better than the stocker ever did.

Hemi? I've got CHUNKS of Hemi in my STOOL!
'06 CC BT LE in Red Alert.
Airbox Mod, scAmsoil hi-flow filter, Bullydog GT, timing bump, Lorado Tonneau, 8000K 55w HIDs, Silverstar Hi's, Vent Visors, billet grille, axle vent mod, Revo's.

UWSkier is offline  
#15 (permalink) Old 07-12-2010, 03:47 PM
Registered User
 
Join Date: Feb 2009
Location: Oceanside, Ca/Menifee,Ca
Posts: 886
Thanks: 34
Thanked 167 Times in 110 Posts
iTrader Score: 1 reviews
Re: dead battery / clicking sound & gauges fluctuate

i had the same thing happen, i cleaned my battery posts and it was fine. I thoguht it was a dead battery but i made sure i cleaned everything off before i bought one.

..........Under destruction.



It's lifted, sounds like a bike with cards in the spokes and goes fast like Ricky bobby

I.E. Titan is offline  
Reply

Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Battery & SES Light & MAF sensor 1BadTitan Titan General Discussion 17 01-08-2008 02:26 PM
Dead Battery squirm88 Titan General Discussion 7 09-17-2007 12:39 PM
Gauges ALL DEAD!!! 1BadTitan Titan Problems & Dealer Service 10 04-29-2006 03:02 PM
dead battery again rcantu Titan General Discussion 37 10-14-2005 04:27 PM
New clicking sound Dula_titan Titan Problems & Dealer Service 6 10-01-2004 07:22 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On