Troubleshooting Help!!!! - Nissan Titan Forum
Titan Visual & Audio Discussion Forum for discussion of Visual and Audio modifications, etc.

 
LinkBack Thread Tools Rate Thread Display Modes
#1 (permalink) Old 03-03-2008, 12:41 PM
Registered User
 
Join Date: Nov 2007
Location: Sayre, PA
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Troubleshooting Help!!!!

I have an 08 titan pro4x with R/F stereo. i purchased a mtx thunderform with amp. had a local stereo place install and you cant believe how much crap it sounds like. you cant here these subs over the factory sub. Everything is stock, and he used an LOC into the rear stock speakers. gain is all the way up. if i unhook the right or left rca it weakens. any suggestions?
fab410 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-03-2008, 01:17 PM
Super Moderator
Nissan Titan Status - Premium Member
 
bestatchess's Avatar
 
Join Date: Feb 2004
Posts: 17,041
Thanks: 468
Thanked 2,839 Times in 1,880 Posts
iTrader Score: 4 reviews
Re: Troubleshooting Help!!!!

Is the LOC tapped directly at the rear speakers, downstream from the oem amp?

If you tap upstream from the oem amp (at the back of the RF HU) you will get extremely low signal level, which is the only thing I can think of that wouldn't blow you out of the cab with the sub amp gains maxed.

The oem sub will sound like crap next to any decent aftermarket sub.
bestatchess is offline  
#3 (permalink) Old 03-03-2008, 01:45 PM
Registered User
 
Join Date: Nov 2007
Location: Sayre, PA
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Re: Troubleshooting Help!!!!

just called the installer and said its tapped in by the rear seat pillars. i gave him the info from the sticky post above on hooking up to a stock R/F stereo LOC diagram. and he said he followed it directly. but who knows. Is it ok to tapp it in behind the rear seat? if so, maybe try a different LOC would that make a differance? Is there a certain brand or type of LOC to use. Ive installed aftermarket stereos for years now but ive never had to use a LOC before so this is all new to me.
fab410 is offline  
#4 (permalink) Old 03-03-2008, 01:56 PM
Premium User
Nissan Titan Status - Premium Member
 
vipzach's Avatar
 
Join Date: Dec 2006
Location: Choctaw, OK
Posts: 32,744
Thanks: 11,652
Thanked 3,412 Times in 2,652 Posts
iTrader Score: 6 reviews
Re: Troubleshooting Help!!!!

pm TECH12VOLT. I used the brand of LOC he suggested. It is not a cheap LOC, IIRC, it was around $50 and has its own gain adjustments. I just can't remember the brand of it.

Why is there never enough time to do it right the first time,
But always enough time to do it again?

Zlacher whore™
vipzach is offline  
Reply

Jump to top


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



  Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help troubleshooting lights Kronos1965 Titan General Discussion 5 12-11-2006 07:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On