Nissan Titan Forum banner
loss of power
1-7 of 7 Results
  1. New Member Introductions
    hello fellow Titan owners I’m new to here and purchased a used Titan just before Xmas I started having problems with my truck last week. During the day it looses power but only after I have been driving for a while. It almost stalled out on me. Initially I thought it was the fuel pump but after...
  2. Titan General Discussion
    Your gonna think I'm crazy but my 2013 titan sv surges, or bucks when its snowing. The snow doesn't even have to be sticking on the ground or be icy. Trac light stays off also. Its like it sees snow and acts up. Ive read some stuff. I bought new tires, 4 wheel alignment, new air filter, new...
  3. Titan Talk Site Polls
    My New 2018 2wd Titan s now with 65,000 miles has been having several problems are any of you having these problems 1) - the blue tooth only links to my phone haphazardly some times it does many times it doesn't work if I restart the truck 3 time on the third start is will often link up...
  4. 2016+ Titan General Forum
    I work for Nissan service in 8525 Leesburg Pike, Vienna VA 22182 and we have had an increase on 2017-2018 Nissan Titans XD with the gas engine. Some customers are experiencing a knocking while the engine is cold and also a loss of power. Nissan has launched a bulletin (NTB19-057) if you are one...
  5. Titan General Discussion
    I work for Nissan service in 8525 Leesburg Pike, Vienna VA 22182 and we have had an increase on 2017-2018 Nissan Titans XD with the gas engine. Some customers are experiencing a knocking while the engine is cold and also a loss of power. Nissan has launched a bulletin (NTB19-057) if you are one...
  6. Titan General Discussion
    My 2007 that has 46000 miles on it occasionally gives a sensation of momentary loss of power. I have hammered it a couple of times since this has happened and it has run fine during aggressive acceleration. It seems to be worse when the vehicle is cold. Took it to the dealership today but it...
  7. Titan Problems & Dealer Service
    Please help, I just had my service engine light come on and ever since, I have noticed a pretty significant loss in power but mainly notice it at and over 3000 rpm. feels like it starts missing pretty bad. I went to Auto Zone today and they pulled a P0420 code. Catalist system efficiency below...
1-7 of 7 Results
Top