Nissan Titan Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hey fellas, need your help. I've got a 2004 Titan LE (Crew Cab) with 194,*** miles. I don't know much about the maintenance on this truck as I'm a used auto dealer and just bought it from a auction. Now, for starters heres my issues:

1. It had a bad engine and I installed a used one
2. Fuel pump went out 2 weeks after driving and was replaced
3. After driving for a while ses light came on with these codes (P0420,P0430,& P0430), i've cleared the codes several times and the light goes out but returns after extended idling.
4. Power Locks don't work and I've traced everything including removing the driver and passenger side switches from my Infiniti QX56 and plugging it into the Titan. (I'm thinking the BCM is bad)
5. When the a/c is on the condenser fan don't run at all.... haven't tested for power yet.
6.****Transmission seems to be a little rough, When in OD and you let off the accelerator it feels like the torque converter is unlocking rather harshly but it DOESN'T do this if you put the gear selector in '4' which essentially is eliminating the overdrive.
7. Now,I do see that the relay in one of the slots of the IPDM is missing and it looks likes the cooling fan relay but I swapped one from my Infiniti and the condenser still dosn't come on.
8. Have you noticed that the a/c doesn't blow very hard from thevents or is this another problem? Kinda weird because the Titan and my Infiniti has basically the same a/c system but the Titans airflow is less from the vents. I did chek with the Nissan dealer andshe the service rep told me that this truck has not had the IPDM recall done so........

Thanks, for your help. I've searched quite a few of the forums on here to research my problems but couldn't come up with solid solutions.
 
1 - 2 of 2 Posts
Top