Nissan Titan Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Went to JL and had the oil changed 3 days ago. The next day I got up, cranked the truck and it ran rough. Noticed the oil pressure gauge running low at idle but after reading threads here it sounds like that's common. Oil level is correct according to dipstick.

Headed down to Miami and the truck cut out a handful of times at 70 mph. Just staggered but didn't stop. Cruise control cut itself off 3 times without me touching anything. 4WD light flashes when it's cutting out. Stalled at idle 2 or 3 times. I just turned 100k. Any ideas?

By the way, nav etc. all seem to be working fine. I didn't see anything obvious under the hood. I did have the recall work done about a month ago for the ECM or whatever it was. It cut out once or twice before that but quit after the recall work was done and I've never had the issues with the CC or the 4WD light.
 

·
Registered
Joined
·
2,840 Posts
may be coincidental - hardly doubt that an oil change would cause any type of electrical issues or cutouts or whatnot

Let me guess - no codes or check engine lights?
 

·
Premium Member
Joined
·
17,244 Posts
Perhaps, the ECM recall was for the ECM relay on the IPDM, the IPDM itself could still go bad. Cruise & 4wd light issues would make me guess a wheel speed sensor cable got mangled by one of the geniuses at Jiffy Lube, but that is just a guess. Inter-related problems like that are difficult to figure out unless you have a code or the dealer's Consult II computer.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #9 ·
Perhaps, the ECM recall was for the ECM relay on the IPDM, the IPDM itself could still go bad. Cruise & 4wd light issues would make me guess a wheel speed sensor cable got mangled by one of the geniuses at Jiffy Lube, but that is just a guess. Inter-related problems like that are difficult to figure out unless you have a code or the dealer's Consult II computer.
Thanks for the help.

Would my code still be coming up 0000 if it was the wheel speed sensor cable?

Also, where would I look for it? If they can get to it, I can get to it right?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #11 ·
I'll have a look and see.

Just went for a drive. Stalled out a couple of times at 5 mph. Started shaking and tach bouncing with dash lights flashing for about 5 seconds and died. Cranked back up. Thought I smelled gas like a few other folks here. Managed to get stopped before getting on the railroad tracks. Drove home ok after that. Freaked out the wife though.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #12 ·
I've noticed in some of the other posts that there seems to be a new and an old IPDM. If I get a new one, should I get the newer one? If so, is the part number different? My guess would be the old would be discontinued but there may be some NOS out there.
 

·
Registered
Joined
·
3,728 Posts
Have your battery tested. Mine did the EXACT same thing with 4wd light and cutting out about a week before my battery died. I thought for sure ECM relay and even ordered a new IPDM, but before it arrived at the dealer the bat died so I replaced it and problem solved. No issues since i installed my optima almost 2 years ago.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #16 ·
Haven't tried swapping the relays yet. I'll throw a load on the battery and see what comes up. Then I'll reset the computer. Relays next. Thanks for the info guys. I love my truck.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #17 ·
So I did the reset procedures here: http://www.titantalk.com/forums/titan-faq-howto-area/25118-how-ecu-reset-throttle-accelerator-position-learning.html and it wouldn't start at all. Grumbled like it was out of gas for a couple of seconds and I shut it off. This morning I checked it and it was doing the same thing. Disconnected the (-) and swapped the relays. Now it fires up just fine. Supposedly the dealer swapped the ECM relay a month ago when I took it in for the recall work. Should I call them back or just order more relays?
 
1 - 20 of 20 Posts
Top