Nissan Titan Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
My 06 with 16,000 mile has a whistle between 1500 and 2000 rpms under a slight load. The shop can't find any vacuum leak. And a help line said it is common. Plus my mileage is 13 mpg with the big toe. Anyone also have this noise?
 

·
Registered
Joined
·
302 Posts
stosh said:
My 06 with 16,000 mile has a whistle between 1500 and 2000 rpms under a slight load. The shop can't find any vacuum leak. And a help line said it is common. Plus my mileage is 13 mpg with the big toe. Anyone also have this noise?
Do you have the stock intake?Mine didn't whistle until I installed my AEM CAI.Now it whistles at the same rpm yours does.But if Im going uphill or the engine is under a load then it does not whistle.And I do not have a TBS.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
I have the stock air box but I did modify it. My whistle comes on at 1500 and stops at 2000, no more no less. Its a light load when it happens. I told the shop about the poor mileage (315 per tank) and they did some leaning out on some mixtures. He told me to let him know in a tank or two how it is. Man 16 mpg would be great!!! The one think I have not tried is to disconnect the hose to my air box and see it the noise goes away.
 

·
Registered
Joined
·
3 Posts
I have a similar problem but I don't think it's the same. As I accelerate past second the slightest presure on the throttle causes an increasingly loud whistle that is drinving me f$%cking crazy. I'm at my fifth local stealership because the previous four could not diagnose the problem. This dealership that I'm at now is telling me it's the trany and that they're going to replace it.
Just wondered if you had any thoughts or if maybe this is the same problem.

Also, do carfax reports pick up on warranty work like a trany replacement?
 

·
Registered
Joined
·
461 Posts
boya544 said:
Do you have the stock intake?Mine didn't whistle until I installed my AEM CAI.Now it whistles at the same rpm yours does.But if Im going uphill or the engine is under a load then it does not whistle.And I do not have a TBS.

Ditto on the AEM intake whistle. And I don't have a TBS
 

·
Registered
Joined
·
219 Posts
I have the K&N 77 series intake and I have a slight whistle under a light load but Ive had a TBS before and nothing like that. Curious how it will sound when I get my 90MM TB.
 

·
Registered
Joined
·
52 Posts
My problem is identical. My truck is completly stock. What is average mileage for these things? I sometimes get 315 miles per tank and think that is great compared to what I have gotten before.
 

·
Registered
Joined
·
461 Posts
Titan460 said:
My problem is identical. My truck is completly stock. What is average mileage for these things? I sometimes get 315 miles per tank and think that is great compared to what I have gotten before.
I live in a hilly area so locally I get about 320. Highway I get almost 400.
 

·
Registered
Joined
·
461 Posts
stosh said:
My 06 with 16,000 mile has a whistle between 1500 and 2000 rpms under a slight load. The shop can't find any vacuum leak. And a help line said it is common. Plus my mileage is 13 mpg with the big toe. Anyone also have this noise?

Your big tow must be heavy, LOL. When I first got my truck the MPG sucked. Only because I wanted to hear the engine roar. Then after awhile I got it out of my system and my MPG went up. Then I went and put the AEM intake on and my MPG went down again, Because I wanted to hear the intake roar. Just something to think about when you mash the pedal down. Otherwise I can't complain about my MPG it is pretty good for a fullsize truck.
 

·
Registered
Joined
·
682 Posts
i had a whistle on mine also stock, it was the intake. now it louder w/ the TBS. its completly normal
 

·
Registered
Joined
·
16 Posts
samething here. stock 06, same whistle at same rpm sorry to say but its normal and annoying. dealerships say its the way the air passes over certain parts in the intake
 
1 - 13 of 13 Posts
Top