Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, I have an 06 Titan with 154k on it. A month or so ago I was having some rough idle and hesitation with jittery acceleration so I put new plugs in and seemed to be running a lot better. Today my in laws barrowed the truck and it started running really rough. Then a loss of power like it's hard to get to 40 mph. And then we noticed it was starting to smoke under the hood. Smells like exhaust. Couldn't see a leak or anything. It never came close to over heating or anything. Am I looking at a cracked header? Or any other suggestions would be greatly appreciated.
 

·
Registered
Joined
·
1,273 Posts
Start the truck unplug your coils one at a time. So say you unplug a coil it still runs rough it’s not that cylinder. When you unplug one and it runs better that coil is bad so replace that one.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Would a bad coil cause smoking under the hood? I'm getting some smoke coming from the passenger side of the motor , smells like exhaust and not like burning coolant or anything like that.
 

·
Registered
Joined
·
5 Posts
Would a bad coil cause smoking under the hood? I'm getting some smoke coming from the passenger side of the motor , smells like exhaust and not like burning coolant or anything like that.
Welcome to cracked exhaust manifold hell. All first gen exhaust manifolds will crack at some point. This forum is a fan of Cajun B-pipes cracked manifold kits. There are tons of posts on this topic with a lot more info than I will be able to put into one post.


Sent from my iPad using Tapatalk Pro
 

·
Registered
Joined
·
1,273 Posts
Yeah most likely manifold but the smoke is odd. Could be the header. The coil is just a thought


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
292 Posts
going to go with A/F sensors (Upstream O2 sensor) beginning to fail.
at a 154K have you replaced the coils or the A/F sensors?
First I would clean your MAF, second I would replace your A/F sensors....then you need to check the rest of your exhaust system for other issues (cracks in the manifold, holes, shot cats).
I am guessing that you couldn't break 2k RPM? if you floored it it try to downshift and go above 2k RPM...but it wouldn't?
 
1 - 8 of 8 Posts
Top