Nissan Titan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I read some of the threads regarding the "NO HEAT" but no one posted the FIX.

What is the fix?

I just bought one and now I have no heat. Truck warms up fine (gauge goes to normal) but no heat.

Any help would be greatly appreciated!
:bump:
 

·
Registered
Joined
·
1,820 Posts
I think you top off your coolant levels, but be care you can blow out your radiator easily like I did.
 

·
Premium Member
...08 Pro4X...
Joined
·
70,396 Posts
Heater control valve is what I read...
 

·
Premium Member
Joined
·
15,661 Posts
mine was the heater control valve. Its up on the firewall behind the battery. I took the cover off, and spun the valve back and forth a few times and it cleared up.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thanks everyone. I found the heat control valve, removed teh cover (3 screws) and turned the top gear. Seems to work fine. What a silly set up!
 

·
Premium Member
Joined
·
15,661 Posts
the problem is that thing closes every time you shut off the truck. if it gets gummed up it will close and not reopen. this is when you get no heat.
 

·
Registered
Joined
·
839 Posts
Any pictures of the heater control valve?
 

·
Registered
Joined
·
839 Posts

·
Premium Member
Joined
·
4,160 Posts
Its still 100* where I live. I don't think I will have to use my heater this year .
 

·
Registered
Joined
·
45 Posts
I never did replace the incorrect valve i used to replace the broken valve.
Have not noticed any down sides to just manually opening it.

So save yourself $100, put the cap back on it, with turned open, and throw away that 'double geared plastic piece of junk stick' -- or it will forever remind you that your truck isn't 100%.

Horrible design.
 

·
Registered
Joined
·
35 Posts
My '07 is doing the same thing. No heat. If I turn the heat all the way to cold, leave it a second, then turn all the way to hot, it SOMETIMES results in heat.

My questions:
-What does the shaft connected to the gears do?
-If I remove the shaft, can I still have control of the heat/AC from the cab?
 

·
Registered
Joined
·
839 Posts
My '07 is doing the same thing. No heat. If I turn the heat all the way to cold, leave it a second, then turn all the way to hot, it SOMETIMES results in heat.

My questions:
-What does the shaft connected to the gears do?
-If I remove the shaft, can I still have control of the heat/AC from the cab?
The shaft connects the electric motor gear to the valve gear. Ie motor opens the valve.

Yes you still ccontrol the heat. We might be loosing some AC efficiency as the heater core in the dash is still circulating hot water thru it.
 

·
Registered
Joined
·
2 Posts
Dustinm, I have the same issue exactly! I replaced the heater control valve and still have the problem! The valve is not opening, the hose is hot on one side of the valve but not the other, I checked to see if there is power getting to it and there is not. Any suggestions??
 
1 - 14 of 14 Posts
Top