Nissan Titan Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
dont know if its going to work but im bored and just got my new intake in and im anxious to see what is going to happen...if all goes well i will leave a detailed description of the part and steps necessary. right now i cant seem to find anyone who can say for sure what CAI works and i cant wait...07' seems the same as the 08'...:cheers:
 

·
Registered
Joined
·
334 Posts
I have a 08 se, and my s&b fit perfect.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
got it all apart and i cannot get the last bolt from under the bottom of the bottom of the stock intake...how did u?
 

·
Registered
Joined
·
1,062 Posts
...are you reffering to potential fitment issues? I'll tell you if it "works", if you tell me what kind it is...(if by "works" you mean fits correctly).
 

·
Registered
Joined
·
23 Posts
if you are talking about the bolt that you have to take the washer bottle out to get to. i had to drill a hole through the bottom of the intake to get to it. it didnt matter to me because i wasnt keeping it anyway.
317_TITANs said:
got it all apart and i cannot get the last bolt from under the bottom of the bottom of the stock intake...how did u?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #6
thats it! this is the best forum ever! i was debating on taking it to nissan in the morning...thanks to u guys i dont have to...common sense should have told me to do that but maybe its because ive been...:smoke:
 

·
Registered
Joined
·
334 Posts
I have an 08, and didnt have any of these issues. Take some pics of what your issue was, I am curious.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #9
guess what everyone was right, and thanks TRE5 for responding...the gentleman who advised me to just "drill through the box, cause you wont need it anyway," gave me the most direct and way of doing it. maybe it was a little unprofessional and it ruined the stock box, so i cant sell it or anything just trash. i will say that i am much happier with the intake in now! thanks to everyone and i will be posting a picture to go with this endeavor's accomplishment!:haveredfl
 

Attachments

·
Registered
Joined
·
669 Posts
All you had to do was pull the box up and out. The rubber grommet on the mounting bolt allows for the box to be removed without removing it.
 

·
Registered
Joined
·
334 Posts
Thats what I told him in a PM, so I think he got it handled.
 

·
Registered
Joined
·
334 Posts
It probably has to do with the intake you purchased. There has been some talk on here about some of the CAIs making the mixture too lean. I bet that is your problem. I have the S&B, and have had it for about 350 miles with no issues, other than I want to get something to put inbetween the plexi and the box to make it shut up a little. If you can return that one and get a S&B, I would do that.
 
1 - 13 of 13 Posts
Top