Nissan Titan Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
I mentioned this in another thread but didn't want to continue hijacking it. I've had my '08 LE CC LWB for a week now after replacing my '04 Titan. I was dismayed to see that the display for SAT radio hadn't changed since the original model. I also used to have Sirius but at least I got all 14 characters as opposed to the only 8 I get with XM now. But, a few days after delivery, I noticed all of a sudden I was seeing 14 characters on all my XM channels. However, it has not been consistent. It seems to come and go at will which is driving me crazy and making me think I'm seeing things. At this point, I don't know what I'm going to get when I start up the truck. Sometimes it'll show all characters and sometimes only 8 or even less.

If the Nissan Sirius tuner has 14 character capability, then I would think the Nissan XM tuner would also have the same code built in the hardware. So, am I to assume this relates more to XM's signal as it relates to this tuner or is it simply a hardware only problem? In other words, is this something XM can rectify with their signal? That just doesn't make sense to me, though.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #2
Ok, after a couple of weeks of proving things out, I've come to a conclusion. This is what I've discovered, at least for my situation.

If I start my truck with the radio already in XM mode, about 90% of the time there will only be 8 characters max on the display. However, if I start my truck with the radio in any other mode such as FM or AM, then switch to XM, all 14 characters are displayed. This has occured 100% of the time. Even if I start the engine in XM and see 8 characters, I can switch to FM or AM, kill and restart the engine, then switch to XM and all 14 again. Now, I'm not so anal that I'll be restarting my engine just to resolve this goofy issue every time I forget though. I have tried simply powering it off and back on but that does not help.

Hopefully Nissan will provide some sort of fix for this since it's their tuner that obviously has the problem. I'd be interested to see how many of you are experiencing the same thing.
 

·
Registered
Joined
·
3 Posts
I have a 2007 Xterra and having the same issues. I was looking around to see if anyone else was having XM display problems and found your post. Nissan keeps telling my dealer that it is XM's fault but I don't think so. They have changed out my modular and receiver and this still has not fixed the issue.
It actually worked for a while today so I took it by and showed them. I think they thought I was crazy or something. Like you it is driving me nuts also. I like to see who is singing what. Maybe we can figure this thing out.
I haven't tried putting it in another mode to start Truck. I will try that and see if I have the same results.

Thanks!
 

·
Registered
Joined
·
178 Posts
Discussion Starter #4
I'm still batting a thousand with it being fine as long as I start the truck with it in a different mode. I've gotten pretty good at remembering to change it to an FM channel before I kill it. If I don't, I can count on a screwed up XM display when I start her back up. It's really a stupid deal. Definitely a tuner problem and they're probably just replacing them with tuners affected by the same issue.
 

·
Registered
Joined
·
3 Posts
I tried starting mine in a different mode and it worked. I guess that is what I'm going to have to do until they figure something out. Thanks for your post it helped a lot.
Do you ever race your Titan? My boyfriend has a Tundra and tries to get the Titan guys out to the race track close to San Antonio. He is curious to what they can do. I really like my Xterra but don't plan on racing it. :) Take Care!
 

·
Registered
Joined
·
210 Posts
I have noticed the same thing! I was just about to put a post up about it and then I saw this one...I will have to try it out!
 

·
Registered
Joined
·
3 Posts
My dealer (Gunn Nissan) is working on this issue with the Nissan Tech Line. They left a message on my answering machine and said they have new info on it but I haven't been able to get a hold of them yet. I will let you know what they say about it.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #8
07XNightArmor said:
My dealer (Gunn Nissan) is working on this issue with the Nissan Tech Line. They left a message on my answering machine and said they have new info on it but I haven't been able to get a hold of them yet. I will let you know what they say about it.
Hopefully they'll have something new on it. Keep us posted for sure.
 

·
Registered
Joined
·
564 Posts
I am confused. I have my truck in XM all the time and set the display to always show the Title. I have never seen the issue.

Could they have fixed something or am I not doing the same thing as everyone else?
 

·
Registered
Joined
·
143 Posts
My 08 Titan does the same thing and has since I have had it (about 3-4 months) It is mostly not showing all 14 characters and it bothers the crap out of me.

My wife has an 08 Path and I have not noticed it doing this. Everytime I have driven hers, the XM display works fine.

I will have to try the new "fix" to see if mine works. If you guys hear of a real fix, please let me know.
 

·
Registered
Joined
·
564 Posts
My 2008 was build 10/07 and I still haven't seen the issue.
 

·
Registered
Joined
·
779 Posts
can you press the display button to change the display shown?

I don't have the factory XM in my truck, but had a loaner for a while with it, I seem to remember it works like my wifes Murano, when you press display button it cycles thru various display options for XM.
 

·
Registered
Joined
·
178 Posts
Discussion Starter #13
Learjet said:
can you press the display button to change the display shown?

I don't have the factory XM in my truck, but had a loaner for a while with it, I seem to remember it works like my wifes Murano, when you press display button it cycles thru various display options for XM.

Yes, the Display button cycles through Name, Title, Channel, etc. but does not have any effect.
 

·
Registered
Joined
·
138 Posts
I'm not the only one!!! I thought I'd lost my mind...or at least the radio did. I definitely miss all the information an aftermarket radio will show you, but 14 characters is still better than 8.
 

·
Registered
Joined
·
18 Posts
Hi guys, new to the site. My 08 LE is doin the same. You would think Nissan would put something as simple as a scrolling text feature to fix it.
 

·
Registered
Joined
·
2 Posts
I have a BRAND NEW 2011 Frontier and I am experiencing the SAME issue. When I change it to AM, turn it off and on again, it displays all 14 characters.

1) 8 characters is unacceptable.
2) For these IDIOTS at Nissan to have not fixed this in 3 years is beyond pathetic.
3) Has ANYBODY heard back from the tech line or anybody through this Gunn Nissan?
4) This XM display sucks! 1 line of text is pretty crappy, but to have a defect like this is the end of the line. I am planning on contact NISSAN tomorrow. I am NOT happy.

PLEASE....if anybody is experiencing this problem, please contact me. Thanks.

Brad, Cave Creek, AZ
 

·
Registered
Joined
·
779 Posts
I think they might be busy with other issues on the Titan.
 

·
Registered
Joined
·
2 Posts
I have a BRAND NEW 2011 Frontier SV. It's doing the SAME thing. Other folks had an Xterra too. I just got back from the dealership, and they called Tennessee, and there is NO fix for this.

This is what I have learned:

1) This tells me it has been happening since 2007, and Nissan has NOT fixed this.
2) DO NOT BUY a Nissan with a factory radio and XM unless they can prove to you that the full 15 digits will work.
3) You are better off to purchase an aftermarket radio (you will lose most or some of your steering wheel controls) or better yet a sat receiver like an Audiovox Express.
4) Shame on Nissan for equipping the Frontier with a SUB PAR piece of garbage one line display! It should have a minimum of 3 lines for CHANNEL, ARTIST, and SONG, or at least fill all 15 characters, and rotate between the 3 pieces of info.

It was a disappointment to find out my radio would not work the way XM had intended it to. It was also sad to spend so many hours researching this, and driving out to the dealership to find there was no fix.

As for Nissan, they make AWESOME and RELIABLE cars... however, don't expect the FACTORY XM to display properly. The entire head unit should be recalled on all models, if you ask me!
 
1 - 19 of 19 Posts
Top