Nissan Titan Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I purchased the three relays from nissan and installed them. trailer turn signal , brake and flashers work. Why do the tail lights not work.
No voltage at the connector. What do I need to do to make it work?
Please help.
 

·
Registered
Joined
·
15 Posts
if your lights are not working and you have an 04 or 05 or newer titan or armarda. check directly under the nee panel straight down below the keys to the right of the go pedel, there is a sub harness we put in at the shop that has 2 small fuses in it to protect the bcm. if fuses 1or2 is poped replace and if it plows again check the trailer wireing for any defects.

stevie ray
nissan technician
 

·
Registered
Joined
·
1 Posts
I recently installed a hitch on my 2006 Armada and ran into this same problem. I installed the standard 3 relays, checked the fuses under the hood and looked for the inline fuses under the dash (never found them) but still could not get it working.

Eventually I discovered a connector for a 4th relay under the dash. It is located right next to the connector for the electric brake controller. I plugged in one of the blue relays (the ones for the left and right trailer lights) and now the running lights work. I talked with the guys at Valley who make the trailer connector kit. They never heard of this 4th relay but said they would send me another relay.
 

·
Premium Member
Joined
·
17,446 Posts
I recently installed a hitch on my 2006 Armada and ran into this same problem. I installed the standard 3 relays, checked the fuses under the hood and looked for the inline fuses under the dash (never found them) but still could not get it working.

Eventually I discovered a connector for a 4th relay under the dash. It is located right next to the connector for the electric brake controller. I plugged in one of the blue relays (the ones for the left and right trailer lights) and now the running lights work. I talked with the guys at Valley who make the trailer connector kit. They never heard of this 4th relay but said they would send me another relay.
The 06 Armada and newer that did NOT come with tow package will need the 4th relay.
 

Attachments

·
Registered
Joined
·
1 Posts
Can some body tell me exactly where is the 2006 Titan tow relay under the left dash I was looking and lookin for it and nothing I found
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top