Nissan Titan Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
147 Posts
Anyone else finding the reception quality is subpar on FM radio
Worse than that in mine.... ughhhh it's terrible
 

·
Registered
Joined
·
7 Posts
2017 SL here, reception is **** and the radio station I use is based outta the town I live in; Minot, ND. My work truck is a 2011 F-350 and I get no issues with reception on that. I've become accustomed to just plugging my phone in and using the radio app to listen to the same station. It's not a big deal but it's the principle of it being a brand new truck and all. I haven't mentioned it to the dealer but I will next oil change and see what the say.

Is there an actual update out there for the stereo system?
 

·
Registered
Joined
·
50 Posts
so know that the trucks ship from factory with the rods not installed on the fender. then the dealer does the install at pre-delivery.
so if the dealer doesn't torque it down good, or if the truck sits for a while and the screw threads in the nub on the fender are not clean, then reception suffers.

maybe unscrew the rod off the fender, check the screw threads, then re-install. sometimes it's an easy fix.
 

·
Registered
Joined
·
190 Posts
so know that the trucks ship from factory with the rods not installed on the fender. then the dealer does the install at pre-delivery.
so if the dealer doesn't torque it down good, or if the truck sits for a while and the screw threads in the nub on the fender are not clean, then reception suffers.

maybe unscrew the rod off the fender, check the screw threads, then re-install. sometimes it's an easy fix.
Well on my new 2017 PR just realized today I don't have AM radio reception. FM works fine, AM doesn't work at all, like the antenna isn't connected? FM seems to work perfect though.

As you described here, where is this at?
 

·
Registered
Joined
·
50 Posts
I was tefering to the rod itself on the fender. Right above he rubber grommet is two flats at the bottom of the rod. Wrench there to unscrew the rod from the base inside the grommet
 

·
Registered
Joined
·
22 Posts
My 2017 SV was in the shop for 4 days because of non-existent AM & FM reception. Per the dealer, they verified that the radio wasn't the problem. Supposedly they had to replace a wire harness as well as the antenna.

All I can say is that both AM and FM work extremely well now.
 

·
Registered
Joined
·
190 Posts
My 2017 SV was in the shop for 4 days because of non-existent AM & FM reception. Per the dealer, they verified that the radio wasn't the problem. Supposedly they had to replace a wire harness as well as the antenna.

All I can say is that both AM and FM work extremely well now.
Good to know. I'm dropping my 2017 PR off on Thursday to get the Transmission "E" update (well at least request it) and to get my non-working AM issue also looked at. I am hoping they are quicker than 4 days.
 

·
Registered
Joined
·
282 Posts
My AM works fine, although I only listen to 1, maybe 2, different stations.

My FM is terrible. I was told originally it's the way our county is because of all the lines and what not. I just laughed it off because I don't listen to much FM radio, but as my son gets a little older, sometimes even sports talk bores him.
 

·
Registered
Joined
·
22 Posts
Good to know. I'm dropping my 2017 PR off on Thursday to get the Transmission "E" update (well at least request it) and to get my non-working AM issue also looked at. I am hoping they are quicker than 4 days.
Supposedly there was a one day delay for the dealer to receive the radio "tester"...which turned into two days. Then once the dealer verified that the radio was good, they had to order an antenna. When that didn't work, supposedly they had to order a wire harness. It's hard to figure what a wire harness had to do with reception, but that was the service advisor's story.
 

·
Registered
Joined
·
14 Posts
Mine is terrible as well. I have a 6" lift and barely fit so when a storm rolls in and I want to pull it in the garage I have to take the antenna off so it doesn't get caught up on the door. I bought a Stubby antenna in hopes of not having to do this, and reception is so bad with it that I sent it back. Now when I pull into my garage or the airport garage I have to remove the antenna before entering. I will talk to my dealer at next service visit to see if there is a fix they know of.
 

·
Registered
Joined
·
65 Posts
Original antenna worked fine for me, I changed it out for the Stubby since I don't like the stock look. Still works fine but isn't as good due to the shorter antenna. Not a big deal since I just stream Pandora.
 

·
Registered
Joined
·
190 Posts
Supposedly there was a one day delay for the dealer to receive the radio "tester"...which turned into two days. Then once the dealer verified that the radio was good, they had to order an antenna. When that didn't work, supposedly they had to order a wire harness. It's hard to figure what a wire harness had to do with reception, but that was the service advisor's story.
Well mine was a "headunit failure" so they will be replacing the whole unit. They said they tested out all the parts and it had nothing to do with the antenna, wires, etc. The guy told me they have a Titan expert who will change it out without marking up the console. We shall see. It sucks as I don't listen to AM very often... however, they I do listen occasionally and having to stream the channel from my phone every time is an unneeded hurdle so I'd rather just get it fixed. I actually never use FM.

As with everything I seem to see with Nissan parts on this forum, it's on backorder with an estimated delivery of 2-3 weeks. They will call me to schedule the install when the replacement headunit arrives.
 

·
Registered
Joined
·
16 Posts
I have been dealing with this for 4 visits to dealers. They always told me everything tested fine. I contacted the BBB and the next day Nissan called me and said they were sending out a tech expert. He noticed the tuner/nav was in need of some Service Bulletins that should have been installed previously. Installed the updates took over 2 hours of loading.. So I took my truck after and drove home.. there seemed to be some improvement but still got some minor static where before it was heavy. So I ordered a new antenna today that was rated good on this site. Will see if that makes the reception any better the seller says if it don't I get a full refund. Nothing much to loose. Then I will see if I can get them to try out a new headunit if it don't work. I think Nissan wants it fixed now especially since the BBB is involved. They have been my go to before and do a great job.. it was not related to a car...
 
1 - 17 of 17 Posts
Top