Nissan Titan Forum banner

21 - 34 of 34 Posts

·
Premium Member
Joined
·
191 Posts
My 2019 p4x has car play it came that way from the factory. My truck currently has 20x9 fuel rims I have a 4" front lift 2" rear lift with blistein 5100 shocks all the way around with airbags in the rear. To help with the addendum weight of my 41 gallon auxiliary fuel tank I also have a ARB onboard air compressor.
 

·
Registered
2017 texas titan 4x4
Joined
·
2,797 Posts
Dang, 41 gallon add on tank? Wow, that's a long range driving there
 

·
Registered
'21 PR '20 P4X (sld) '06 SE (sld) '16 SS
Joined
·
947 Posts
This thread did not age well. :ROFLMAO: :ROFLMAO: :ROFLMAO: I had to bump it to remind myself of the truck you had before trading it in.
 

·
Registered
Joined
·
387 Posts
So today I added a “Carlinkit 2.0” for wireless CarPlay and 1st impressions are pretty good. Had to disconnect the initial Bluetooth connection and “forget this car” and delete my phone from the Titan. But, initial setup is simple and the connection is much quicker than I expected. I had an Alpine ilx-107 in my F250 and it was a wireless CarPlay head unit, loved it. This Carlinkit 2.0 seems like a PERFECT adaptation for the Titan. Time will tell.
How did this device turn out 7 months later? And where did you place it? I’m kinda interested.
 

·
Registered
2020 Titan Pro4X
Joined
·
489 Posts
Discussion Starter · #30 ·
How did this device turn out 7 months later? And where did you place it? I’m kinda interested.
I used it consistently, daily, in & out of the truck. It connected successfully 9 out of 10 times. The last update was a good one. Very stable and near zero lag. Maps, music, voice recognition, speech to text, etc, all worked like it should. I never had to reach out to the company directly but I know some people complained about the customer service - but I never needed them. The updates work really smoothly and I'd just check in every other month or so, just to make sure the version that I was running was current. The Armada has wireless CarPlay so, I gave the unit to my daughter, in a 2020 Rogue, and it works just as well in her ride. I would buy again.
 

·
Registered
Joined
·
387 Posts
I used it consistently, daily, in & out of the truck. It connected successfully 9 out of 10 times. The last update was a good one. Very stable and near zero lag. Maps, music, voice recognition, speech to text, etc, all worked like it should. I never had to reach out to the company directly but I know some people complained about the customer service - but I never needed them. The updates work really smoothly and I'd just check in every other month or so, just to make sure the version that I was running was current. The Armada has wireless CarPlay so, I gave the unit to my daughter, in a 2020 Rogue, and it works just as well in her ride. I would buy again.
I’ve been debating on getting one to try it out. Where did you place it in the truck? Under the cell phone holder/cup holders? Or in between the heated seat knobs? Or somewhere more out of sight?
 

·
Registered
2020 Titan Pro4X
Joined
·
489 Posts
Discussion Starter · #32 ·
I’ve been debating on getting one to try it out. Where did you place it in the truck? Under the cell phone holder/cup holders? Or in between the heated seat knobs? Or somewhere more out of sight?
Yep, in the bin just below the usb outlet, in the cavern below the cup holders and cell phone holders. Just used some 3m double sided tape to hold it in place. Worked like a charm.
 

·
Registered
Joined
·
387 Posts
is this your truck @CBEllis ???? I’m only guessing because of the exhaust. Idk where that dealer is so pardon me if it’s way off.
 
21 - 34 of 34 Posts
Top