Nissan Titan Forum banner

1 - 6 of 6 Posts

·
Banned
Joined
·
9 Posts
Discussion Starter #1
2010 LE without navigation or entertainment. Previous owner left the amp (JL Audio 250/1) and all the wires. 3 sets of RCA cables. What am i missing? The plugs under the seat are spliced into a set of wires that goes to something.
15683269353495905105163775527005.jpg
15683269660315223077184513988108.jpg
1568327049328346460057177019596.jpg
Thanks.
15683273899498904329501557572039.jpg
 

·
Registered
Joined
·
98 Posts
That is obviously aftermarket equipment and cabling. The question is: what is presently installed and is it working. If the original equipment is present and working then what you see are remnants of an aftermarket install that were not removed. If something is installed and not working then there needs to be an investigation (ie pull the radio) as to what is there and what is wired (or not wired).
 

·
Banned
Joined
·
9 Posts
Discussion Starter #4
From what i can see the factory sub under the seat is missing. Also the speakers in the rear doors work but they are not as loud as the speakers up front. Fade=0 balance=0.
I know its aftermarket stuff, i said the previous owner left it in the truck. Im planning on adding aftermarket subs to this amp the previous owner left in the truck. I just dont understand why there is 3 sets of rca cables, with 1 set spliced into what i assume is factory wires. My previous truck was a GMC with nav, bluetooth, onstar...etc so im not familiar with the Fosgate setup in a Titan. I figured someone here would be and could save me the time and effort required to pull the radio and whatever else that needs to be removed to find the other end of the rca cables.
 

·
Registered
Joined
·
98 Posts
Unfortunately, the only person to really know what that wiring is there for is the person (or persons) who did the aftermarket install. Original equipment in a Fosgate system included a sub under the drivers seat and an amp on the firewall behind the brake pedal.

There are a number of modifications that could have been done. I'm guessing, but I suspect the factory headunit and amp were kept. The output going to the factory sub was tapped and routed to an external amp which was used to drive aftermarket subs. If that was the case then what you have is miscellaneous cables and an amp that is not doing anything. To discover the actual purpose or use try to track down where the wiring actually goes.

The design of the Fosgate system uses the front door speakers and dash speakers as the main staging, the rear door speakers merely fill in. In other words you don't get much from the rear speakers.

In the two Titans I have owned (2004 and 2007) with the Fosgate system, I installed an aftermarket HU, bypassed the factory amp and added larger speakers (in enclosures which I made) to the rear cabin. That configuration allowed a HU with more features and moved the sound stage to the rear, which is what I prefer.
 

·
Registered
Joined
·
81 Posts
Im gonna guess that there was a second amplifier installed, or possibly a DSP unit that was removed, hence the additional wiring. The RCA's that are tapped into factory wiring are likely inputs for the amp/amps. The coupler on the one RCA kind of gives me pause, I can't see where that would have been used. If not for that, I would have guessed that the short set thats tapped into factory was the input, and the other 2 are actually ends of a single cable, with the slack tucked under the carpet to hide it, that came out of the 250/1 (on the bypass outputs) and were inputs for a second amp. As stated above, I wouldn't hook anything up until you trace all the wires.... The only one that knows at this point is the one who put them there, and I've seen some really shady Sh*t over the years.
 
1 - 6 of 6 Posts
Top