Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys- new here and this may have been answered before so I apologize if so. I have an 09 Titan Pro-4x. It is currently not wanting to go into 4x4. All the sounds sound normal and my dash readout is there. I have had multiple shop tell me actuator motor and then those that say no because the dash readout is there. No warning lights. It just acts like its not getting communication to front tires to engage. I can get it to switch back and forth on dash with controls like normal and sounds normal but it wont allow go back to 2wd after doing so at random. Any ideas? Sensor? Vacuum leak? Actuator motor? Or something totally different. I just don't want ripped off at a service center. I must add just in case its important that the vehicle I sat undrove for a couple months before this happened.
 

·
Registered
Joined
·
6,012 Posts
Probably not the issue, but if your ABS/Slip lights are on, the 4WD won't work.
 

·
Registered
Joined
·
559 Posts
I'm not sure I'm following, so please take this in positive spirit - what makes you think it's not going into 4WD? Is it the front wheel indicators blinking, or loss of traction, or something else?

You may already know this, so please excuse if so - when you switch to 4WD, the lights indicating the front wheels will blink until you drive forward quite a bit. That is normal vehicle function. After driving forward a bit, they should turn solid color (no blinking, after perhaps a few hundred feet), indicating the transfer case is locked in 4WD. Is that happening, but you don't get front wheel driving traction? That would be a problem.

Also, when switching out of 4WD, it is normal vehicle function to have the lights blink for a few hundred feet, until the transfer case shifts back out of 4WD - it's not necessarily immediate. Rarely, if the lights don't stop blinking after driving forward a few hundred feet, backing up 50-100 feet will allow the transfer case to shift out of 4WD, and the lights for the front wheels will "clear."

Let us know if you are having a problem regarding the 4WD indicators or with lock-up/ 4WD traction.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
That's just it I have no warning lights on dash at all. The truck does perfectly fine in 2wd I just cant get 4wd to function
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I have owned the truck since 12 so I know what the lights should be doing and it is. I have no warning lights on or anything to tell me there is an issue but my front wheels seem to have no power and when its showing its in 4wd I have no traction. I only have the rear wheel drive part.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
front wheel had no power even though it showed on dash to be in 4wd and got stuck just night before last in 3 in of snow
 

·
Registered
Joined
·
559 Posts
OK, got it.

Interesting that the lights aren't showing an issue, which could indicate there's an electronic/control issue, so there may be something mechanical that's the problem. Next step is a check of the transfer case and other front driveline components, including the front differential. The transfer case "shift" motor is a usual suspect.

I wouldn't necessarily expect it on an '08, but on earlier models, there was an issue with the front axle shafts popping out of the differential. In that case, since the front differential is an open style, the power is directed to the "wrong" side and you'll get no traction. Probably best to make sure the axles are fully seated, CV joints are OK, and the front drive shaft U-joints are OK when the transfer case and front diff are checked.

Good luck!
 
1 - 7 of 7 Posts
Top