Nissan Titan Forum banner

41 - 60 of 61 Posts

·
Registered
Joined
·
686 Posts
I hate to revive an old thread like this, but be careful when you order the part. I took mine apart and it was a P141NF55, the number is easily visible right on the chip itself, using a magnifying glass. This part costs $2.59 + Shipping.

Good Luck!
 

·
Registered
Joined
·
175 Posts
What's the difference between the VBC and the resistor? I easily located the VBC, but am unable to locate the resistor that the dealer sold to me. How much of the dash do I need to take apart in order to locate the blower motor resistor on a 2005 Titan? Thanks.



The part on the left is what I can locate on my Titan. The part on the right is what the dealer insisted I buy.
I need the one the rite does anybody have a link or a part # for it

Sent from my EVO using AutoGuide.Com Free App
 

·
Registered
Joined
·
686 Posts
I need the one the rite does anybody have a link or a part # for it

Sent from my EVO using AutoGuide.Com Free App
PM your VIN# to me and I should be able to look it up for you.
 

·
Registered
Joined
·
2,673 Posts
I'm going to attempt this...I never solder before but is worth the try...
The shopping list from clubarmada
solder iron
solder removing bulb
Transistor from digikey (including S/H)
Soldering wire
Thermal Grease/Paste
 

·
Registered
Joined
·
1 Posts
I've replaced my blower motor and resister. Resister shorts out, was told by a tech that the motor is not grounded? Need to know where it grounds to so I can track it down, I don't have confidence in the tech and feel I'm being overcharged.
 

·
Premium Member
Joined
·
185 Posts
Just did mine last night with the part from digikey. Worked like a champ...I'm out about 8$ since I bought 2....just in case...I think shipping was 12$, so, in it for about 30 min and 20$ total.
 

·
Registered
Joined
·
1,209 Posts
Hey guys, if my AC doesnt blow where it should, what part do i need? these AZ temps are killing my black truck already!

If i put it on face, turn the ac on, and then turn the knob up, it blows out the defrost. if i put the knob on foot, it blows... out of nowhere?
the know is put on properly, but isnt sending air to the correct area?

anyone?
help?
 

·
Registered
Joined
·
1 Posts
i have an 07 titan and the a/c was working until yesterday but only on high. But now blower motor stopped completely. Looking at the controls, they still have power and click when the knob is turned on but no blower. I think it is the relay and blower motor and would like to do the work myself, anyone done this before and could give me any pointers instead of me having to pay 400-500 to have dealship fix it when the parts are only $175?
 

·
Registered
Joined
·
103 Posts
Sounds like the vbc to em and part is like 70 dollars.

i have an 07 titan and the a/c was working until yesterday but only on high. But now blower motor stopped completely. Looking at the controls, they still have power and click when the knob is turned on but no blower. I think it is the relay and blower motor and would like to do the work myself, anyone done this before and could give me any pointers instead of me having to pay 400-500 to have dealship fix it when the parts are only $175?
 

·
Registered
Joined
·
3 Posts
For those of you that want to fix this as cheaply as you can, and possibly quicker depending on dealer stock, I found the following thread over on CA.

Front A/C fan OFF or HIGH - Nissan Armada Forum: Armada & Infiniti QX56 Forums

The part is $2.44 + tax from Digikey, with about $2.00 shipping for first class mail.

MOSFET N-CH 55V 80A TO-220 - STP80NF55-08

This is for the electronically inclined, which involves replacing the transistor inside the VBC. For those of you that are up for the task, like me, you will also need heat resisting grease and a soldering station.

Good luck gang.
Digikey is out of these. Any idea of other places to source them?

Thanks!!!
 

·
Registered
Joined
·
1 Posts
Thanks so much! Such an easy fix, took a little while to clean the solder off the board to make room for the new transistor but other than that the variable switch works great again!
 

·
Registered
Joined
·
11 Posts
Where is the blower motor relay on a 2007 titan? My manual mentions the relay and even shows how to test it, but does not give a clue where it is located. I've checked a couple of relay boxes under the hood on the passenger's side.
 

·
Registered
Joined
·
4 Posts
What's the difference between the VBC and the resistor? I easily located the VBC, but am unable to locate the resistor that the dealer sold to me. How much of the dash do I need to take apart in order to locate the blower motor resistor on a 2005 Titan? Thanks.



The part on the left is what I can locate on my Titan. The part on the right is what the dealer insisted I buy.
The part on the left is what I have in my 2008 Titan SE 4X4 Crew cab ( my part has 3 heavy fins on the back not 5 ) the part on the right is what the dealership says I need because mine don't have auto controls. I have to stay with the same thing that came in the truck is there an updated part # so I know I'm getting the right part. Thanks
 

·
Registered
Joined
·
2 Posts
On my '08 SE, my VBC went out, and my mechanic changed both the blower motor and the VBC. Now after the blower has ran for more than 15 minutes, I can not run the blower on high or the blower will stop for about 15 seconds, then try and startup again. It just keeps cycling like this until I turn the blower speed down a couple of notches. Does not matter whether it is on heat or air. This is the 2nd set of motor and VBC he has put in. Both sets acted basically the same way. Any idea what is causing this? (on above pict of parts, my VBC looks like left one only 4 fins).
Thanks

Fixed! Turns out the new fan and VBC did not play nice with each other. Went with a different brand of VBC and everything works fine.
 

·
Premium Member
Joined
·
151 Posts
Phooey -- I just changed the VBC thingy and no change -- the fan still runs on HIGH whenever I turn fan on. When I turn the fan control know it "clicks" as I move it for position to position but it doesn't change speed. This happened one day after had worked properly all the time

M2006 SE 4WWD had the 5-fin VBC in it and the replacement was the 4 fin version -- did I make a mistake?

Any suggestions where I should look next?
 

·
Registered
Joined
·
2 Posts
Did the same thing to me. I changed the module and fan motor and now the motor only runs on high. Ive even replaced the module a second time and no change. Have no idea what else to do from here.
 

·
Registered
Joined
·
2 Posts
Don't know if this helps, but

My brother has an older Pathfinder. I assume the systems are similar. He had to change out his temperature control unit also with the VBC to fix his blower problems.
 

·
Registered
Joined
·
1,868 Posts
what complete nonsense! Many work fine with new VBC. , many fail again in a couple days or a couple minutes, many say to change motor also (just in case it causes VBC failure). Nissan lists two different parts, one for auto climate control, one for manual. My truck has manual climate control, but came from the factory with the automatic CC version of the part! And peeps here say its how many fan speed settings you have determines what part you need. Not auto or manual climate control. I have some soldering skills, a soldering gun and solder, and little money, so was considering that route, but not a solder sucking bulb and the link to purchase transistor doesn't work anymore. Hmmmmm 🤷‍♂️🤷‍♂️ And nissan, if your listening, we dont want 16 fan speeds, we want something that works right and lasts long time!

update: found good price on quality branded replacement VBC and ordered it without farther diagnostics, since its not likely the fan speed switch, the other potential fault, as seen here. The reason for multiple failures is the blower motor itself drawing to much current and thus frying your replacement VBC. If that happens, replace them both, or just replace them both up front if you don't want to chance it. Or measure the blowers current draw and compare to spec. before installing new VBC
 
41 - 60 of 61 Posts
Top