Nissan Titan Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
398 Posts
Discussion Starter #1
im not *****!ng about this first off.... just on a need to know basis if these things are common and have happened to others, first off, everytime io crank it up it knocks for a few seconds (5-15), then it quits and is fine until it is cold again, 2nd, when i drive it down the road in the morning it makes a bad noise under the dash like plastic ruffling, only when actually driving, it stops when the vehicle slows under 5 mph, then starts again, 3rd, when i take off from a dead stop it has a slight hesitation such as a loose u joint or something but it's not, kind of like it engages 1 second after take off, i even thought it may be the gears slipping, hell i dont know any suggestions or should i carry my fat a$$ in and let them warranty it?
 

·
Registered
Joined
·
514 Posts
I have an 07' and don't have any of those issues. I didn't have knocking with the stock oil or after the first oil change. No plastic russling and it seems smooth gettin' out of the hole. Lettem fix it , could just need some tuning .
 

·
Registered
Joined
·
1,690 Posts
No problems with my 07 either. Had 10 degreee waether when I first bought it and no cold knock. Just go trade it it on the off road one you been wanting. Last week you told a member no problem and love your 07, this week you hate it. Could get it fixed under warranty too. Good luck
 

·
Super Moderator
Joined
·
93,287 Posts
Only problem I have had with my 07 is that after sitting overnight the brakes seem like they are rubbing? for about 20 yards or so and then it goes away. Anyone else experience that?
 

·
Registered
Joined
·
150 Posts
The hesitaion on the take off could be from the electronic throttle. I used to have a subaru wrx with a cable throttle and when I got my titan it seemed to have a very slight hesitation compared to my wrx. Other than that I love it, even though I have only had it 3 months.
 

·
Registered
Joined
·
578 Posts
Arachnid said:
Only problem I have had with my 07 is that after sitting overnight the brakes seem like they are rubbing? for about 20 yards or so and then it goes away. Anyone else experience that?

yes are you talking about a high pitch screech from the rear axle? I get that every morn for about 20 yards
 

·
Registered
Joined
·
6,370 Posts
Previous years had some complain about dash noise, slight noise when starting, and hestation. Solutions were (???) something needed tightened in the dash area (search back a year or two years), different weight oil or different oil filter, and get the 2 degree timing advance asap. Nissan Filter proven to be a good one, along with Havoline Regular 5W30, and Mobile 1 5W30. Just for a start. Many threads and variety of thoughts on oil and filters (too many! :) ). I use WIX Filter and M1 5W30 year round now.
 

·
Registered
Joined
·
718 Posts
titanical said:
when i take off from a dead stop it has a slight hesitation such as a loose u joint or something but it's not, kind of like it engages 1 second after take off, i even thought it may be the gears slipping
Could be axle wrap. Is normal.
 

·
Registered
Joined
·
13 Posts
I got my '07 Titan on Dec.23rd/06. Since then I have out on 23 000 km (it's my work truck). I live in Northern Alberta, Canada, and about 60% of the milage is on gravel roads, logging roads or lease roads.

Anyways, I haven't had any of the complaints that you mentioned, and I would definitely at least bring it to the dealerships attention, especially the knocking at start-up. I do notice that I have to keep the starter engaged about 1.5-2.5 seconds to start the truck, but I'm sure that's nothing to worry about.

Other things I have noticed:

-Rear mudlfaps fall off too easy.

-Towing plug-in metal is very weak and gets banged up pretty bad.

-Plastic insert on bumper where license plate is could be secured better (just clips in)

-Poor heating system for back seat

All-in-all, relatively minor stuff. The Titan is by far the best truck I've ever had.
 

·
Registered
Joined
·
2,481 Posts
i have the noise from rear brakes after being parked for a long time.... seems to moan, but not constantly, more like a quick moan once every revolution of the wheel..... goes away after a few feet, or brake application...
 

·
Registered
Joined
·
23 Posts
Arachnid said:
Only problem I have had with my 07 is that after sitting overnight the brakes seem like they are rubbing? for about 20 yards or so and then it goes away. Anyone else experience that?
I have an 06 SE CC 4x4 I bought last November (currently 10,000 miles) that does the same thing every morning I leave for work. It sounds/acts like the brake pads (or some other functioning part of the brakes) do not fully release until I start driving down the road. It often does the same thing when I leave work and/or when I get home and pull into the driveway. I had the dealer check this out at the 7,500 mile service but they could not reproduce the noise. It is unpredictable other than first thing in the morning. :wierd:
 

·
Registered
Joined
·
23 Posts
StuntDriver06 said:
i have the noise from rear brakes after being parked for a long time.... seems to moan, but not constantly, more like a quick moan once every revolution of the wheel..... goes away after a few feet, or brake application...
Same with my 06 CC.
 

·
Registered
Joined
·
2,481 Posts
this really doesnt concern me though.. it seems to me the brake pad is just slightly rubbing the rotor at the high point of the rotor.... who knows.... thats what warranties are for anyway......
 

·
Registered
Joined
·
8 Posts
5-15 seconds of knocking sounds like oil filter is bad. I had fram filter that have back flow valve bad had same problem.

Just change oil and change it to a good filter.
 

·
Registered
Joined
·
514 Posts
You know since I read this post I heard rustling plastic sound under the dash. I wonder what that was.
 
1 - 19 of 19 Posts
Top