Nissan Titan Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Abs/ slip light won't shut off. I had a bad front bearing and replaced it, topped of my brake fluid, still on. It shuts off maybe 5% of the time otherwise it's constantly on and the 4wd won't engage. Any suggestions are appreciated.
 

·
Registered
Joined
·
2,942 Posts
Check the ABS connector at the hub. May have messed it up while you were changing it.
 

·
Registered
Joined
·
101 Posts
Abs/ slip light won't shut off. I had a bad front bearing and replaced it, topped of my brake fluid, still on. It shuts off maybe 5% of the time otherwise it's constantly on and the 4wd won't engage. Any suggestions are appreciated.
did you check the code?
 

·
Registered
Joined
·
741 Posts
did you check the code?
I have a similar intermittent issue (whenever I turn my wheel full lock left), and it never throws codes. Pretty much everything lights up, to include the brake and 4wd lights from occasionally. But still no codes. I'm assuming it's one of the connectors is either loose, or clogged up, but I've just been too busy/lazy to pull it apart and check it all.

I've looked at both cables while someone else turns the wheel back and forth though and it doesn't look like anything is stretching, or pulling, or pinching...so I don't know honestly.
 

·
Registered
Joined
·
167 Posts
Abs/ slip light won't shut off. I had a bad front bearing and replaced it, topped of my brake fluid, still on. It shuts off maybe 5% of the time otherwise it's constantly on and the 4wd won't engage. Any suggestions are appreciated.
did you check the code?
I checked for codes on my truck when the SLIP light came on and didn't have any codes.
 

·
Super Moderator
Joined
·
37,156 Posts
On the slip light , check the rear axle seals and see if they are leaking ...
 

·
Registered
Joined
·
355 Posts
1 - 7 of 7 Posts
Top