Nissan Titan Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
718 Posts
Discussion Starter #1
2006 Titan
99,500 miles

I'm 500 miles away from my extended warranty expiring, so I want to get everything fixed asap.

The only real problem I have now is that my AC will not quit when it reaches the set temp.

For instance: I just drove home, with the AC set to 79F. It started cooling and then just kept going. By the time I pulled into the driveway, it had cooled the cab down to 71.6F (measured in the warmest place - the dash), and was still blowing ice cold air at fan setting 4 :huh:

I can only get the AC to quit by turning the temp to 90F, or simply switch it off completely.

Anyone else here have this problem?

I took it to dealer, but they didn't find fault codes so in this age of the computer that means the problem doesn't exist.

Thanks.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #3
Ehhh..... Sounds like a faulty thermostat.
My thought as well. However, since there's no fault code, that has been ruled out by Nissan...

Also, the heating does work as it should, so the thermostat works in that
case.

:confused:
 

·
Registered
Joined
·
718 Posts
Discussion Starter #4
For those interested:

It turned out to be the sensor for the cab (inside) temperature; its reading was 10 degrees off.

Fixed under extended warranty :) Between two new headers and now this temp sensor, I've more than earned my money back on the extended warranty. The rental cars alone would have cost me $300 to $400 for the time the truck was out of action.
 

·
Registered
Joined
·
24 Posts
Anybody see the problem with the AC Compressor stays on no matter what you do with the controls. The only thing that will shut mine off is if you switch off the ignition. Had it to the dealer 3 or 4 times and finally got tired of giving up my vehicle. They replaced the controller, then the power block or something like that (I guess the thing that interfaces from the computer to the real world). Re-flashed the program. Nothing worked.

I have a 2007 LE Crew w/o nav.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #6
This has been an issue with owners from the the first model year. I think the consensus was that it worked as designed. My previous, 2004 Titan worked that way.

I thought they changed it in later model years though? My 2006 doesn't do it, unless it's on defrost IIRC. Now I'm confused :). Will play with it next time I drive it.

Just so I understand you correctly: your AC is always on, no matter what setting it's on (defrost or not, cooling or heating, etc.)?
 

·
Premium Member
Joined
·
4,177 Posts
My compressor kicks on if I have the vents set to defrost and floor, If I turn it all the way cold and just let it run, you can hear the compressor kicking on. If I do it over the summer the windshield gets frosty...Still need to get it in for that one.
 

·
Registered
Joined
·
718 Posts
Discussion Starter #8
It's all slowly coming back to me now...

Do you have the automatic climate control or the manual one where you set the dial yourself to cold or hot? The auto doesn't have the 'compressor is always on when on defrost' problem, the manual HVAC does. I remember now that was one of the things I liked when going from my 2004 (with manual controls) to my 2006 (which is auto).

I think you're stuck with that behavior. Do a search for it, there have been many postings on it in the (distant) past.

They may have changed it in later model years, I'm not sure. My most recent experience is with the 2006 model.
 

·
Registered
Joined
·
24 Posts
@RVANDAM - you are correct, it only is an issue when I use the Defrost/ AC feature and it is Auto climate control. I like to use the Defrost feature in summer. If it is on for only a little while there isn't a problem. If it is on for 20 minutes or more then it won't turn off. I've had to stop at the dealer on a drive home, park with it running and drag a service tech out to prove the problem existed!
 

·
Registered
Joined
·
615 Posts
Bump


Anyone find the right fix ? Noticed my ac comes on while in vent mode .. if I push the button to turn it on, then off again it stops, but then if I swtch to defrost, the ac is on again wtf ?
 

·
Banned
Joined
·
3,359 Posts
Bump


Anyone find the right fix ? Noticed my ac comes on while in vent mode .. if I push the button to turn it on, then off again it stops, but then if I swtch to defrost, the ac is on again wtf ?
Defrost/Defog will always run the compressor to reduce humidity.
 
  • Like
Reactions: Titan332009
1 - 12 of 12 Posts
Top