Nissan Titan Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,095 Posts
Discussion Starter #1
For some reason I can't get the middle prong on the lid to go into it's hole. The left and right prong go in fine, but I can't get the middle one to go in for the life of me. It seems like the box is warped from the picture or something rather. I have a K&N air filter in, I don't know if that is any help to my question at all. Does anyone else have this problem? It whistles a little when I accelerate. Does the air leak cause anything like maybe loss in power or mpg?


Disregard my dirty engine. I like to go out and play alot!
 

Attachments

·
Registered
Joined
·
5,748 Posts
Same problem I was having. That's how I ended up with my K&N intake kit. I actually got really pissed after fighting it for an hour and "accidentally" put my fist through the top of the box, trying to get the lid to go in all the slots.
 

·
Premium Member
Joined
·
58,644 Posts
I have a K&N filter in the stock air box and it fits. I have to mess with it a little but no more than I had to with the stock filter.
 

·
Registered
Joined
·
6,053 Posts
Just push down on the tab and it will snap into where it needs to go.
 

·
Registered
Joined
·
6,823 Posts
54warrior said:
Just push down on the tab and it will snap into where it needs to go.
You're absolutely correct. I started laughing reading about the filter problems. When you put the lid on, just use your fingers to guide the tabs in, this isn't rocket science.
 

·
Registered
Joined
·
1,095 Posts
Discussion Starter #7
sudden urge said:
You're absolutely correct. I started laughing reading about the filter problems. When you put the lid on, just use your fingers to guide the tabs in, this isn't rocket science.
You know what, nevermind..
 

·
Premium Member
Joined
·
1,557 Posts
if you ran it with the lid off... isnt that considered a mod?! lol

I cant help much more than say keep trying or if you got some money maybe get the K&N filter?
 

·
Registered
Joined
·
1,095 Posts
Discussion Starter #9
I'm going to go back again and try to mess around with it. I have the K&N air filter in it right now, Faith+1. I had just taken it out to clean it and noticed when I put it in the middle prong was being a little devil. LoL
 

·
Registered
Joined
·
978 Posts
i had a similar problem with a Purolator filter, could not get it to go on. The foam was a little thicker than the Frams i was using, which i liked because it would give a better seal. I ended up returning it and going back to a fram. The day i was putting it on was a cool day so the foam might have been a little stiff, i should have brought it in and used a hair dryer to soften up the foam first. Try that and along with all of the above and see if it fits.

As well, it sure looks from your picture that you engine bay is a mess, might want to spray some engine cleaner in there and clean it up.
 

·
Premium Member
Joined
·
1,557 Posts
billaj said:
I'm going to go back again and try to mess around with it. I have the K&N air filter in it right now, Faith+1. I had just taken it out to clean it and noticed when I put it in the middle prong was being a little devil. LoL
hmm... that stinks.. I wonder if Kman is on to something with expansion from the filter??
 

·
Registered
Joined
·
1,095 Posts
Discussion Starter #12
I just went out and tried again. The actual holes where the tabs are suppose to go in do no line up. The middle tab hole of the box is warped out about 1/2 to 3/4 an inch and won't budge.
 

·
Premium Member
Joined
·
31,154 Posts
Sounds like something is warped or distorted from heat or time...

Good luck...
 

·
Registered
Joined
·
978 Posts
clean it up, take it to your dealer and see if you can get it replaced.
 

·
Registered
Joined
·
2,900 Posts
mine fits weird too. seems like all the holes dont line up perfectly and like the bottom part of the air box is a little bowed out in the middle where that pesky middle tab goes. i have used a screwdriver on mine to stick in the hole enough to torque it so that the tab will go in. another reason to save some pennies to get a CAI i guess.
on a positive note, with these long life air filters, you dont have to clean them as often.....but from the fun it looks like you have, maybe you do. :cheers: good luck. let us know what happens
 

·
Registered
Joined
·
4,668 Posts
This happened to me also. One of the holes (plastic loops) on the bottom of the box actually cracked and broke so I had to buy a new bottom.
 

·
Registered
Joined
·
23 Posts
Man I am having the same problem.Ijust installed a K&N filter and now the lid wont close.Its almost closed but not all the way.What can happen from this?/Can i leave it like it?
 

·
Registered
Joined
·
6,823 Posts
FOURRUNNER said:
Man I am having the same problem.Ijust installed a K&N filter and now the lid wont close.Its almost closed but not all the way.What can happen from this?/Can i leave it like it?
Use your fingers to push down on those three guide tabs as you wiggle the lid back and forth till it slides all the way in. The center tab is the one that hangs up, just push that tab down and the lid will go all the way in and close properly.
 
1 - 18 of 18 Posts
Top