Nissan Titan Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2,635 Posts
Discussion Starter #1
If you did not know my truck died on me before about 500 miles ago because the battery died while I was driving. The symptoms were: brake light on with brakes off, and umm now that I think I dont remember which other light was on.

NOW I turn on my truck about 4 hours after I lost drove it, and the abs, slip, brake, and tire pressure lights are all on ! I drive home turn it off then back on and the lights went out except for the tire light, I guess nissan never got around to fixing the leak.. anyways I checked my battery with a multi meter and it checked out fine, I reset the ecu and I am about to go drive 15 miles to see if any lights come up. (thats what my friend told me, he was a nissan tech for a while)

Also the first time I broke down was about a week after I installed my HID's in my headlights.. I installed HID's in my fogs 2 nights ago.. maybe they are both shorting out ? Ill look at that later... after the dealers get it..

anyone have these kind of problems ? if so explain ??? I just dont want to be stranded on the side of the rode AGAIN within 1 month !! If anyone has any idea on what could be the problem please let me know... even if your not sure your thoughts will be apreciated ! Thanks in advance !
 

·
Premium Member
Joined
·
31,154 Posts
Trade it in for a Tundra !!!!!!!!!!!! LOL......NOT !!!
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #3
redneckpapa1996 said:
Trade it in for a Tundra !!!!!!!!!!!! LOL......NOT !!!
nahhh I would not do that this soon, if anything I will look into getting a new 07 if there is any left.. right now ferman nissan has 10k off new ones for the rest of the week... so idk !!! we will see !
 

·
Banned
Joined
·
1,183 Posts
I had that happen and one of the causes that was easy to fix was low brake fluid. Your brake fluid doesn't have to be down much to cause the lights to come on. It doesn't mean that you necessarily have a fluid leak, as your brakes wear, it takes more fluid for the brakes to operate.
the other reason I had these lights come on is because the ABS unit burned up, but this only happens when you use the ABLS a lot, for example the slip light is activated for 5 minutes or more in a an hour.
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #5
ok, what would cause my abls to be on for over an hour ? the longest my slip light is ever one is when the road is wet and I loose traction for a second or two. more info please while i go check my brake fluid. thanks!
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #6
ok, brake fluid is about 1/10 of an inch under the max so basicly its full... any ideas skyhammer?
 

·
Banned
Joined
·
1,183 Posts
Well, those were the two fixes to my lights being on.Since your lights are still on, have you tested the truck to see if your ABS brakes are working and that your ABLS is still working?It should be easy to find some gravel or sand near pavement to check out your brakes and ABLS. If not, then maybe your ABS unit is malfunctioning, I had 3 ABS units fail one on the 04 and two on 05.
If those are still working, it could be an ECU, electrical type problem, which would need a dealer to decipher.
Sorry, that is about all I have for now.
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #8
No I said that they turned off when I restarted. but thanks for the advice !.. I drove about 30 more miles tonight with my sister behind me and she ended up getting a flat ! so it just all sucks ! lol
 

·
Registered
Joined
·
198 Posts
killcatzforfun said:
if anything I will look into getting a new 07 if there is any left.. right now ferman nissan has 10k off new ones ....
I'll buy your step rails if u r really gonna trade it for an '07 - :coolsmile
 

·
Banned
Joined
·
27,783 Posts
ireallywishyouwouldusecommasandperiodssowecouldreadthissh¡tbetter
andwouldhavetotryandguesswhatyouretryingtosay!!!!!!
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #11
Miked1 said:
I'll buy your step rails if u r really gonna trade it for an '07 - :coolsmile
Ill get back with you on that...as for now the problem seems to have quit.
Im not going to trade in unless it leaves me stranded again, which has yet to happen.
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #12
bbomar said:
ireallywishyouwouldusecommasandperiodssowecouldreadthissh¡tbetter
andwouldhavetotryandguesswhatyouretryingtosay!!!!!!

No comment, everyone else can read it without problem. Maybe this is a personal problem ?
 

·
Registered
Joined
·
409 Posts
HEY....killcatz.......my 05 Titan had a short spell of all those dash lights coming on....yea, I checked the brake fluid level and all...that wasn't it....it just stopped doing it one day and never came back...lol


I did here of several doing it back then...but not since......has the dealer checked it out yet?
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #14
Nah, I do not want to go to the dealer without any lights on... but they still have a leaking wheel, and squeeky seat to fix, so mabye ill be there soon !
 

·
Registered
Joined
·
1,390 Posts
I hate to be redundant, but I think skyhammer had it right, I was only a quarter inch down on the brake fluid and had the same lights on. they cleared multiple times over a couple weeks before I consulted you guys to find the problem. (thanks by the way)
 

·
Premium Member
Joined
·
92,554 Posts
Mine did this today. I took off pretty quickly, spun the tires a bit on some loose gravel, and the lights came on. They stayed on until I turned the truck off. Turned it back on and they were gone. It's happened a couple times before and always goes away. Mine's triggered by my rear tires slipping.
 

·
Registered
Joined
·
2,635 Posts
Discussion Starter #17
ok, so they went on again at 60 something miles. I left the truck running to go into 7-11 and came back and popped her in reverse and they all lit up again...drove half a mile home, and shut her down and restarted, they were all gone...

The only light that stays on is my tire light.. after a week im already at a little over 10psi !! the light never goes off since it leaks so bad.. ill take it to the dealer monday, address that as well as the never ended squeek in the seat and my weird lights ! Ill keep you guys posted.. oh and BB, nothing triggers mine.. they are random...
 

·
Registered
Joined
·
1,237 Posts
killcatzforfun said:
No I said that they turned off when I restarted. but thanks for the advice !.. I drove about 30 more miles tonight with my sister behind me and she ended up getting a flat ! so it just all sucks ! lol
Never forget --- if it has t!ts or wheels it will give you problems!!!! :jester: :cheers:
 

·
Registered
Joined
·
198 Posts
killcatzforfun said:
I'm not going to trade in unless it leaves me stranded again, which has yet to happen.
Hope that doesn't happen - don't covet your rails that badly :sunshine:
 
1 - 19 of 19 Posts
Top