Nissan Titan Forum banner

21 - 30 of 30 Posts

·
Registered
Joined
·
1,389 Posts
That was my next suggestion. Pull the sensor tips out a bit to keep the light off. Thanks dpeteland
I ran my DTLT headers with catless b pipes for a few weeks while UpRev was sending me my ROM file.
 

·
Registered
Joined
·
1,389 Posts
yup, keep the cajuns and get a set of these...I'm running the same setup and I have no codes!

304 Stainless Steel Oxygen Sensor Life Extension Heat Sink 02 Bung Spacer Pipe | eBay

Mine are like that but a bit longer to trick the Secondary O2 sensors.

Stock headers. Did the non-fouler solution as well. My friend Nick owns his own shop. Earlier in the week we put the truck on the lift and checked the pipes. Then checked again. And again. Tightened and retightened. He told me beforehand, to expect a CEL once I put the pipes on and explained to me why it would happen. I have followed every bit of advice that has been offered to me. You guys are frigging great for that. Unfortunately, I have already removed the pipes. And this is nothing against Jeff (nightowl) in any way. I think the cajuns are great. But something (wish i knew what) is causing them and my truck to not get along. It could certainly be something I did. I don't know what, and because I can't pinpoint the cause I'm not blaming anyone or anything. It sucks because I liked them, but on the bright side, I appreciate all the help you guys try to offer when dealing with these kinds of things. Makes me happy I bought a T.


Sent from AutoGuide.com Free App
Tell you what..... Give me your addy, I will send them to you and if it works we can call it $20 shipped and we will be even steven. If not ship them back to me and no big deal, at least you gave it a shot.

Extenders pull the 02 sensor tip out of the flow to prevent any cel. With stock manifolds you shouldnt need extended bungs.
Thanks Nightowl!
 

·
Registered
Joined
·
1,027 Posts
Sorry OP not trying to thread jack you... But would these work..

My secondary O2's aren't hooked up so it would be for the primary..
 

·
Registered
Joined
·
16 Posts
@ 97low: Not sure what set up you have, but im running JBA LT Headers and have no pri cat, and there is no way to install a defouler on the primary without causing rub on the cable. however might be different if your running stock manifolds, i'm not sure, didn't have mine long enough to try.

Has anyone asked what codes he is actually throwing? with as touchy as these damn titan are with any mod, you'd be suprised what codes pop up where... just a thought.
 

·
Registered
Joined
·
6 Posts
I am having the same issues... 2017 Pro 4x Gasser. the dummy light only comes on After i travel a few hours of Highway travel or any road trip... my daily commute is fine. and it always codes bank 1 and 2 downside O2 sensors... i have just kept going back to my mechanic to wipe the code, cuz yes it DOES affect the gas mileage. you can smell it as well. so i am just going to invest in my own diagnostic reader
COdes 2017 P4x.jpg
 

·
Premium Member
Joined
·
19,557 Posts
zedaus, more information is needed. Are you running OEM exhaust manifolds? Aftermarket b-pipes?
 

·
Registered
Joined
·
6 Posts
zedaus, more information is needed. Are you running OEM exhaust manifolds? Aftermarket b-pipes?
haha yea that might help.... yes... Stock manifolds, High flow Cajun B-Pipes.. Jba cat back exhaust.
after posting my initial comment though... i went to their website and it states that "Light is possible with these cats" So... i have to deal with it till i get past warranty coverage, then i can go full blown Headers and Uprev (is my plan at least) only a couple years to go!
 

·
Premium Member
Joined
·
19,557 Posts
It's possible that the catalytic converters in your OEM exhaust manifolds are toast.

I had been running highflow aftermarket b-pipes for maybe 60,000 miles when I swapped to JBA LT headers. The b-pipes should have been able to handle the headers but I think the b-pipes were worn out. I put in new b-pipes and the emissions light went away.
 

·
Registered
Joined
·
6 Posts
i only have 33000 Miles now... i put them on last summer. maybe 12k miles ago?
It's possible that the catalytic converters in your OEM exhaust manifolds are toast.

I had been running highflow aftermarket b-pipes for maybe 60,000 miles when I swapped to JBA LT headers. The b-pipes should have been able to handle the headers but I think the b-pipes were worn out. I put in new b-pipes and the emissions light went away.
 
21 - 30 of 30 Posts
Top