Nissan Titan Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,381 Posts
Discussion Starter · #1 ·
Great night exhausted. I believe I got a dozen runs in with over two hours of breaks. I'll post some time slips tomorrow. My average times were 14.7-14.8. My first run ever was a high 15 :bangit: getting used to it give me a break. Second run was a high 15 as well because the lovely gentlemen told me I would have to slow down or get a helmet when he read my 1000ft time which was 13.00 flat.

I had my kills and my losses. Got some videos as well. haha. Losses, there were three. Lost to a fully bolted Charger R/T by 3/10 of a second and 6/10 of a second. He wanted me bad because of my "...beat a Hemi" sticker. Another loss was to a fully bad*** modded mustang 5.0 fox body. Thing spanked me by 2 full seconds. I tried.:bangit:

Again I'll post slips and vids later. PPL loved my exhaust. And MAJOR THANKS to Dale aka SLOride for coming out for support man. By the way your Titan is sick. Love how it looks!
 

·
Premium Member
Joined
·
46,453 Posts
Sounds like you had a great time, a dozen runs and three losses? Sounds like you had 9 wins! Sweet.
 

·
Registered
Joined
·
1,518 Posts
Win or lose, as long as you have fun. I usually end up going up against fully tricked out race cars (chevelles, novas, camaros, etc.), so I'm used to getting beat by 2 - 3 seconds :D . There is also a diesel performance company (from middleburg) that comes out and they have a F250 that runs low 12s as well as a ranger with diesel engine that's running 10-11 ish. Have fun, that's what it's all about.
 

·
Registered
Joined
·
949 Posts
yeah I had a good time, I looked at my GPS on my phone once I got home and it said 105 miles from my bedroom to the track. Damn that truck pulls hard and I think your exhaust setup is one of the cleanest installs i've seen, sounds great too.
 

·
Registered
Joined
·
1,381 Posts
Discussion Starter · #5 · (Edited)
Here's some video links for those that care haha. The guy in the charger r/t claimed he had full bolt on's. Tune, LT's, CAI. The other r/t which was black and wouldn't line up with me was running high 15's. The only reason the red one raced was because of my sticker lol.

VS. 5.0 stang full bolt on's, horrible driver haha maybe?


Me and the Charger r/t


Me and Charger r/t again.


Me and VW TDI


Me vs. supposed turbo 5.0


1st run vs Cummins 2500 edge tuned
 

·
Registered
Joined
·
5,522 Posts
Nice vids man!! Thanks for posting, your truck sound awesome with that new set-up!!

PS: Your buddy is cracking me up.
 

·
Registered
Joined
·
1,381 Posts
Discussion Starter · #7 ·
Nice vids man!! Thanks for posting, your truck sound awesome with that new set-up!!

PS: Your buddy is cracking me up.
Thanks deer! Yeah after watching them I told him he's coming to the track with me from now on as my narrator or commentator for the races lol.
 

·
Registered
Joined
·
7,353 Posts
killin em bro!
 

·
Registered
Joined
·
2,383 Posts
sweet videos man, looks like you definately had a good time...what was the DA?
 

·
Registered
Joined
·
1,381 Posts
Discussion Starter · #13 ·
sweet videos man, looks like you definately had a good time...what was the DA?
It was awesome. I think I got around eight or ten runs that night. Plus I took like a two to three hour break to let my truck cool and watch some of the races. I think it was 2161 I put it in my sig. I plan on doing it again soon once my truck is out of the shop. Two days after racing I get rear ended and pushed into the car in front of me. Now I'm truck sick.
 

·
Registered
Joined
·
1,381 Posts
Discussion Starter · #14 ·
I wish they had TruTrac out for the 08's yet I'm still waiting. I've emailed them a couple times and they said they are still developing one.
 

·
Registered
Joined
·
2,383 Posts
your time corrected if you were to run in a 0 DA is 13.94 @ 98.5 good job!
 

·
Registered
Joined
·
1,381 Posts
Discussion Starter · #16 ·
your time corrected if you were to run in a 0 DA is 13.94 @ 98.5 good job!
Hey man I'm sorry I put the non corrected DA in my sig. My slip times were 14.7 at like 93. So I need to fix my Sig. Sorry for the confusion. I wished I was hitting 13.9
 
1 - 16 of 16 Posts
Top