Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,865 Posts
Discussion Starter #1
so my front is all jacked riding, the shocks move, you can see the main bolt cruising around out of the coil bucket while the truck is moving.

these are from my phone :(

on the inner side where the shaft goes thru the coil cap.



the top side of the shock that mounts to the trucks coil bucket



just seeing if anyone can tell me that's all that's wrong besides the rubber bushing popping off the shaft and all that LOL. and does that affect anything? thanks!

Tom
 

·
Registered
Joined
·
1,019 Posts
You have them installed wrong. The silver washer goes on first and you reuse the washer from the old shock on the top. It should be: silver washer, rubber bumper, coil bucket, rubber bumper, old washer from old shock, and nut.
 

·
Registered
Joined
·
1,019 Posts

·
Registered
Joined
·
1,865 Posts
Discussion Starter #4
I paid a shop twice I paid them like $550+ at this point and need to pay them again probably even tho I had it written out with pix... I was just making sure I knew exactly. I understand there's supposed to be the stock washer under there but they just don't know how to read or ask questions.. they stuck it on the highest setting with my 2.5" leveling spacer still there, I had it set to the middle setting when I dropped it off, at ride height my prg a-arm was sitting on top of the bucket meaning if I jacked the truck off the ground tires wouldn't go any further drooped. then I paid them to redo it as I told the owners brother and showed him.. at this point, I KNEW the idiots didn't put the washer in. but wasn't sure if that's where the noises were coming from lol. I KNEW it was wrong and the washer was missing but I needed someone else to confirm basically lol

THANKS MAN!

I'll look for the reciepts I paid over 300 for the 1st installation, over 250 for the 2nd installation, keep in mind I bought the shocks all this bunk shop did was install them... fricken irritates me... they're now the only 4x4 shop in town so I can't really burn my bridge but I do have pix of the primary screw up which they didn't even admit was a screw up, like it's totally fine to run around with the a arm ON the coil bucket at ride height...
 
1 - 4 of 4 Posts
Top