Nissan Titan Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
575 Posts
Discussion Starter #1
My mechanic put on the basic yellow blisteins and the 08 and up heavier front springs on my 04 which worked great but now i've got a problem. On 1 of them the shock bushing pushed through the upper mount and the shock just rattles around. On top is a nut then a retainer which is cupped facing up. Looking at it I'm thinking maybe he put it back wrong that the cupped retainer basically a huge washer should be UNDER the top shock mount inside the strut assembly to hold the bushing from squeazing up through the top mount???

How bout a picture/diagram or something on how this should be.

I've only got light duty spring comoressor for my 280zx or i would have done it myself to begin with:crying:
 

·
Registered
Joined
·
49 Posts
On the install you have to reuse the washer from the stock strut plus the one that comes with the Bilsteins. There have been threads about this. Search for Bilstein strut install gone wrong.
 

·
Premium Member
Joined
·
1,788 Posts
My mechanic put on the basic yellow blisteins and the 08 and up heavier front springs on my 04 which worked great but now i've got a problem. On 1 of them the shock bushing pushed through the upper mount and the shock just rattles around. On top is a nut then a retainer which is cupped facing up. Looking at it I'm thinking maybe he put it back wrong that the cupped retainer basically a huge washer should be UNDER the top shock mount inside the strut assembly to hold the bushing from squeazing up through the top mount???

How bout a picture/diagram or something on how this should be.

I've only got light duty spring comoressor for my 280zx or i would have done it myself to begin with:crying:
The large washer that came with the shock needs to go on first. Then you re-use everything else from the old setup. I bet if you look at the top of the coil bucket you are going to find your mechanic put the big washer on the top NOT the bottem. Easy enough mistake but they need to fix it for you.
 

·
Registered
Joined
·
14,534 Posts
another screwed up install. I dont understand why some mechanics cant install shocks properly. This is why I do most of my work myself. Heres the proper install of the front shocks on our titans, make sure you install them as the manual states.
 

Attachments

·
Registered
Joined
·
575 Posts
Discussion Starter #7
AAARRRRRRGGGGGG this thing is back in the shop today for the same issue, seems the bottom washer is "missing". When i looked at it on the truck it looked like the large washer was on top (after install). i don't know what it looked like before because I never checked it.:crying::crying::crying:

He's telling me to get all the washers top and bottom at the dealer and bring it back. do they actual have both or is there now an extra one that came with the shock that i'm missing?

Looking at the exploded picture posted above is part #15 the bottom washer, or is that a bushing. it's called upper seat.

Should i just have him move washer # 20 to the bottom and simply get a large washer at the hardware store to put on top of the bushing??

thanx to all for the help.
 

·
Registered
Joined
·
14,534 Posts
item 15 is like a washer but its not. The only washer is the top one #20. Item 17 there are 2 of them, one on top and the other under #18
 

·
Registered
Joined
·
4,047 Posts
Saving this! May come in handy on my 5100 install.
 

·
Registered
Joined
·
575 Posts
Discussion Starter #10
Ok so then i need part# 15 OR am i totaly missing another washer that came with the new shock? can anybody post the actual Bilstein instructions?

thank you for all the help. It's frustrating if I did it myself i would have read the intructions and taken my time and wouldn't be in this mess.
 

·
Registered
Joined
·
14,534 Posts
dont use the washer that came with the shocks! just use the parts that came off your old ones. Install the hardware in the smae order that they were removed. When I replaced my shocks I bought all new hardware online from www.courtesyparts.com
 

·
Registered
Joined
·
1,684 Posts

·
Registered
Joined
·
575 Posts
Discussion Starter #13
Yes I read through the 5100 section,

the washer on the bottom that goes on first is "missing" on my truck there is just the rubber bushing that goes on top of the washer
 

·
Registered
Joined
·
1,684 Posts
Yes I read through the 5100 section,

the washer on the bottom that goes on first is "missing" on my truck there is just the rubber bushing that goes on top of the washer
That is the bilstein washer. Call them and they'll send you another one for free.

The Droid was here.
 
1 - 14 of 14 Posts
Top