Nissan Titan Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
So my blower motor will randomly shut down and in Sacramento heat this can be very frustrating. It doesn't matter what setting it is on but after a few minutes of driving it will just turn off. If I restart the truck, it will work for a few minutes again. After doing a bunch of research on this forum, I replaced the VBC. Still having the issue, I pulled the blower motor. I don't think it's the original. see photos. Any help or advice would be appreciated.

Thanks

Nick


Sent from my Nexus 5X using Tapatalk
 

·
Registered
Joined
·
92 Posts
does it work on the highest position....blower resistor ...common issue
 

·
Registered
Joined
·
3,488 Posts
Spin the motor by hand. Do you feel any bearing roughness? Most likely issue is the motor is going or the bearings are going. You can test it by checking the voltage at the motor when it's running and again when it stops, using a multimeter. You could have a harness short and this is the quickest way to identify that. Also, check to see if the motor is hot when running or hot when it stops running. You can check current but it takes a clamp-on to avoid blowing your multimeter, most of the time. I'd bet you have a short or a failing blower motor.
 
  • Like
Reactions: ns4787

·
Registered
Joined
·
32 Posts
Discussion Starter #5
Spin the motor by hand. Do you feel any bearing roughness? Most likely issue is the motor is going or the bearings are going. You can test it by checking the voltage at the motor when it's running and again when it stops, using a multimeter. You could have a harness short and this is the quickest way to identify that. Also, check to see if the motor is hot when running or hot when it stops running. You can check current but it takes a clamp-on to avoid blowing your multimeter, most of the time. I'd bet you have a short or a failing blower motor.
So I took it to my local shop after replacing the VBC and blower motor. They chased the issue to a bad relay.

Sent from my Nexus 5X using Tapatalk
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
So I took it to my local shop after replacing the VBC and blower motor. They chased the issue to a bad relay.

Sent from my Nexus 5X using Tapatalk
Also, yes, the motor was very hot!

Sent from my Nexus 5X using Tapatalk
 

·
Registered
Joined
·
11 Posts
Where is the blower motor relay on a 2007 Titan. My manual mentions the relay a few times and shows how to test it, but never bothers to say where it is located. I've looked in two different relay boxes under the hood on the passengers side and didn't find the relay.
 

·
Registered
Joined
·
29 Posts
Will the relay fix allow the blower motor to work on low speeds? Right now mine is only working on the top 2 speeds. What is the VBC?
 

·
Registered
Joined
·
511 Posts
speed issues come from three places, the relay, the resistor and the controller. A failing blower motor will usually be slower at all speeds, many times will have a bearing squeal or rattle. A hot motor is usually a voltage issue, but can be from a tight bearing.

Most likely given your description is the resistor, but go here, follow the write up.....http://www.titantalk.com/forums/tit...eater-fan-failure-troubleshooting-repair.html
 

·
Registered
Joined
·
47 Posts
Take it to an AC guy and have them put gauges on the system.
Mine did it because of too much pressure on the low side.

I took mine to the Nissan dealer and he didn't have to add any just let some out.
That was last year and my blower and AC have worked great since.
 
1 - 11 of 11 Posts
Top