Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I just had an engine swap from my 197k original engine that smoked to an engine with 52k out of a "like new" type place. during the swap also threw on jba long tubes and cajun catless bpipes. I have uprev to tune it, and i did a base tune and it still didn't stop any smoke. Power is there and it definitely runs stronger than my old engine, but the smoke concerns me. It pours out like a smoke machine at idle, when i rev there is a plume of smoke that comes out proportional to how high my rpms go. It calms down some cruising at 55 or 70. It smells like a 4 wheeler exhaust, or like oil is burning. I changed the oil 400 miles after the swap. We found a vacuum leak yesterday on the rear passenger side of the intake manifold, looking at fixing that/seeing whats causing it next. If that doesn't work, what is the next thing to check? Warranty on the engine has about another month left.
 

·
Registered
Joined
·
3,506 Posts
If you re-used your valve covers and pcv valves, check both for sludge buildup. You also need to run a compression test and a leak-down test to see if you have ring or valve stem seal issues.
 

·
Registered
Joined
·
171 Posts
following...
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Valve covers came on the new engine, im not sure about the pvc valve. The mechanic that did the work isn't the best but thats a story for another time. I had two codes that came up (disregarding the exhaust threshold codes that we deleted with uprev) one for a random multiple cylander misfire, and one for a high ide speed (which was 1k rpm, should be about 500 right?) im guessing that has to do with the vacuum leak from the intake? I told him to change the pvc, run a compression test and leak down test. Im just really hoping its not gonna end up being a bad engine. Ill have updates in a couple days. Bad labor at a slow pace = bad combination... but its what im stuck with.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Heres some pictures of the swap my dad took since its gettin worked on back in Slidell while I'm up in Alexandria for school. Steady hoping it isn't a head gasket, that new motor looked nice and clean when we got it, and at 52k there shouldn't be any problems, i'm hoping its something that went wrong with the install that can be fixed under our warranty. Any input or ideas would be awesome!
 

Attachments

·
Premium Member
Joined
·
20,956 Posts
You can't judge an engine by (the outside of) its covers.

Good luck with the troubleshooting!
 

·
Registered
Joined
·
2 Posts
I just had an engine swap from my 197k original engine that smoked to an engine with 52k out of a "like new" type place. during the swap also threw on jba long tubes and cajun catless bpipes. I have uprev to tune it, and i did a base tune and it still didn't stop any smoke. Power is there and it definitely runs stronger than my old engine, but the smoke concerns me. It pours out like a smoke machine at idle, when i rev there is a plume of smoke that comes out proportional to how high my rpms go. It calms down some cruising at 55 or 70. It smells like a 4 wheeler exhaust, or like oil is burning. I changed the oil 400 miles after the swap. We found a vacuum leak yesterday on the rear passenger side of the intake manifold, looking at fixing that/seeing whats causing it next. If that doesn't work, what is the next thing to check? Warranty on the engine has about another month left.
I just had an engine swap from my 197k original engine that smoked to an engine with 52k out of a "like new" type place. during the swap also threw on jba long tubes and cajun catless bpipes. I have uprev to tune it, and i did a base tune and it still didn't stop any smoke. Power is there and it definitely runs stronger than my old engine, but the smoke concerns me. It pours out like a smoke machine at idle, when i rev there is a plume of smoke that comes out proportional to how high my rpms go. It calms down some cruising at 55 or 70. It smells like a 4 wheeler exhaust, or like oil is burning. I changed the oil 400 miles after the swap. We found a vacuum leak yesterday on the rear passenger side of the intake manifold, looking at fixing that/seeing whats causing it next. If that doesn't work, what is the next thing to check? Warranty on the engine has about another month left.
 

·
Registered
Joined
·
2 Posts
So what ever came about it because im having a ton of snoke an like you say but if i lay it to the floor i get black smoke like ita diesel and when you let off mine will back fire can someone help
 
1 - 8 of 8 Posts
Top