Nissan Titan Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2004 4x4 Endurance Titan LE with about 68,0000 miles on it

I have read everyone's horror stories about the brakes going out. My "SLIP", "BRAKE" light, and "ABS" light come on couple times a week off and on. Always as a group which is annoying enough. But when just my "BRAKE" light comes on my brakes instantly don't work and pedal goes to floor locking front brakes up and making grinding noise. Has happen about 4 times and usually under 40mph.... I went to dealership for "ECM" recall hoping that would fix the problem. Sure enough it did not work brakes went out again a week later going about 40mph.... Dealership said its the brake booster and told me its about $850 to replace!!!!! Is that the problem? Is that cost accurate? Why is there not a recall on 04 titans for this issue.... Appreciate any one's input.... Can a local mechanic put in booster for cheaper???
 

·
Premium Member
Joined
·
22,408 Posts
Have you checked your brake fluid level? I had all three lights come on at once, once and it ended up being the fluid level as my front pads were at the end of their life. Sounds to me like the dealer is trying to soak you.
 

·
Premium Member
Joined
·
17,244 Posts
1. Drive truck
2. Park truck on level ground, take foot off brake pedal
3. Turn ignition off, keep foot off brake pedal
4. Wait about a minute
5. Push brake pedal

If brake pedal is immediately very stiff on first pump: booster, vacuum line, or check valve is probably leaking.

Courtesy Parts has the booster for trucks with VDC showing at $335. Non VDC boosters are cheaper. And yes, a local mechanic can very likely install cheaper.
 

·
Registered
Joined
·
358 Posts
the delta sensor on the brake booster is failing, common to early titans and to fix it, have to change the brake booster assymbly. hope this help search on here and you will find many members with same problems
 

·
Registered
Joined
·
1,865 Posts
SLIP and ABS stay on forever, dealer did my ABS actuator and it didn't fix it, that was close to a grand so I'm guessing that it's the same thing as a brake booster?
 

·
Registered
Joined
·
3 Posts
anyone ever figure out if replacing the booster fixed this issue. I have slip. Abs, brake, and 4wd lights on and the dash lights flash off when i press the brake completely to the floor. New wheel bearings/hubs, w/new abs sensors rotors pads and calipers in front so far
 

·
Registered
Joined
·
8 Posts
My 06 LE with 86K just started doing this last month. Only it is the Brake, VDC, and slip mils that light up. Most of the time the mil lights are on with no other changes. Some times those 3 mils are on and the brakes pulsates or shudders when applied. Had anyone had this happen?

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
3 Posts
GEE with all theses similar problems maybe nissan should issue a recall before I give to spend more money guessing since the dealership can't get it right
 

·
Registered
Joined
·
6 Posts
I know this is a very old thread, but I want to know if anyone got Nissan to actually replace their booster after the law suit? Hope you all know Nissan lost the suit, but the info I received indicated I'd get about $20 since I have an original 2004. I continue to drive it with this random sensor issue. It tends to act up in the summer heat. A quick off-on resets the sensor and keep on driven.
 

·
Registered
Joined
·
14 Posts
Even older thread now but I still have the same issue, on an 04 2x4 CC w/ 90k miles. Other than this she runs great. I never replaced the booster or anything because it's fixed with a turn on/off and almost always only happens when I first start the truck up.

Has been happening on and off for at least 5 years tho and I'm getting annoyed of it. Sometimes it's the 3 lights mentioned, sometimes it's the Brake/Slip/VDC off lights that are on. Sometimes no lights at all but same brake grinding.

I got my brakes done recently (had original pads on there) and a week after this happen again 2 times within a week, took it by because I was close the second time and they said it seems like the ABS is kicking on. No lights tho and they said it'd be easier to test if lights were on. Well going on 2 months and as usual, hasn't happened again since haha.

Sure would be nice if Nissan would fix this issue with a recall but doesn't seem like it. Sure doesn't make me want to get a new Titan tho! Might need to go get me a Bronco or better yet a Nikola or Cybertruck
 
1 - 10 of 10 Posts
Top