Nissan Titan Forum banner
1 - 10 of 10 Posts

· Registered
Joined
·
949 Posts
Discussion Starter · #1 ·
Have any of you who have bull bars on your trucks had any alignment problems when bolting it on? My damn bull bar would not line up with the bolt holes on the drivers side for nothing without a pry bar on it and it still fought me. Its the all black smittybuilt one.
 

· Registered
Joined
·
113 Posts
I don't know what year your truck is, but I've read that some of the newer trucks ('09 and up?) may be slightly different and some accessories like bull bars and front receivers don't bolt up well.
 

· Registered
Joined
·
358 Posts
I put a Westin on mine a few months ago and 3 of the bolts went in fine, but the short one on the drivers side was a b!tch to get in. So I ended up using the stock short bolt for that hole and the ones that came with the bull bar for the other ones. Idk why but the stock bolt fit fine. Had to tighten and loosen them a few times to get it right.
 

· Registered
Joined
·
949 Posts
Discussion Starter · #7 ·
mine is a smittybuilt which is the exact same thing as n-fab, they build them in the same plant just put different names on them and I ordered it from summit racing for $139.00.......I'll post some pics when I get all my new stuff installed
 

· Registered
Joined
·
2,578 Posts
I put a Westin on mine a few months ago and 3 of the bolts went in fine, but the short one on the drivers side was a b!tch to get in. So I ended up using the stock short bolt for that hole and the ones that came with the bull bar for the other ones. Idk why but the stock bolt fit fine. Had to tighten and loosen them a few times to get it right.
yeah that thing was a b!tch to get on there!
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top