Nissan Titan Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
i got a 8'' cst spindel lift , and from a dead stop it makes a rubbing noise. so i was told that the carrier bearing has to be droped.if someone can shead some light on this and help me out i would appricate it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
thanks for the info. did you install this your self? and was it hard to do, how long did it take? thanks again.
 

·
Registered
Joined
·
5,338 Posts
emtitan said:
thanks for the info. did you install this your self? and was it hard to do, how long did it take? thanks again.
I didn't install it myself. My friend did it, but I could easily do it myself now.
You just cut that cross-member where you see it was cut on mine, on both sides of the driveshaft, then put the drop bracket in there and tighten down.
 

·
Registered
Joined
·
5,541 Posts
Hey i intalled the carier bearing and when i take of i hear a poping noise??? anyone have an idea?????
check your rear tranny mount. known to tear and cause a popping sound when pegging the gas. i had a popping sound but my tranny mount was fine. turned out to be my passenger side leaf spring pack collar was broken. just removed it and sound gone.
 

·
Registered
Joined
·
89 Posts
i have the deaver pack that greg at PRG put together and spec'd. mine is the c30 pack. provides between 2.5" to 3"s of lift and the ride is much better in the back.

PRG Products
So the Deaver spring pack rides better than stock? In my experience with other trucks, add a leafs and lifted spring packs were always super stiff which is why I opted for a block for my lift. The stock springs feel way to stiff, just not enough weight on the rear end.
 

·
Registered
Joined
·
2,990 Posts
So the Deaver spring pack rides better than stock? In my experience with other trucks, add a leafs and lifted spring packs were always super stiff which is why I opted for a block for my lift. The stock springs feel way to stiff, just not enough weight on the rear end.
The deaver pack is totally opposite ride of a add-a-leaf.
 

·
Registered
Joined
·
28 Posts
So the Deaver spring pack rides better than stock? In my experience with other trucks, add a leafs and lifted spring packs were always super stiff which is why I opted for a block for my lift. The stock springs feel way to stiff, just not enough weight on the rear end.
Dude i have the deaver lift srings i belive there 4" theres i think 9 of them and prg shackles and i love the ride its smooth i love it!!
 

·
Registered
Joined
·
28 Posts
Hey anyone knows if i installed a carrier bearing on my truck and want to take off the lift will it affect it??
 

·
Registered
Joined
·
121 Posts
Hey anyone knows if i installed a carrier bearing on my truck and want to take off the lift will it affect it??
I have the same issue as FLAKO, the "Popping" sound coming from the rear underside of my truck after i did my PRG coil over Radflos up front and the 1.5blocks on the rear. Its annoying because i dont know if anything is getting messed up when i have to lean into the throttle a bit to make passes or get on the freeway. Even taking off from stop signs or lights, i usually have to ease into the throttle so it does not make the popping sound. It sucks not being able to hit the throttle when ya wanna drop another truck. LOL:redblob"

Im thinking of either trying a 1in block to see if things line up better or just doing the carrier bearing and hope it works for me and stops the popping.:bangit:

Thanks for any other posting of what works!

M :teethmast
 

·
Registered
Joined
·
28 Posts
I have the same issue as FLAKO, the "Popping" sound coming from the rear underside of my truck after i did my PRG coil over Radflos up front and the 1.5blocks on the rear. Its annoying because i dont know if anything is getting messed up when i have to lean into the throttle a bit to make passes or get on the freeway. Even taking off from stop signs or lights, i usually have to ease into the throttle so it does not make the popping sound. It sucks not being able to hit the throttle when ya wanna drop another truck. LOL:redblob"

Im thinking of either trying a 1in block to see if things line up better or just doing the carrier bearing and hope it works for me and stops the popping.:bangit:

Thanks for any other posting of what works!

M :teethmast

Ok dude when i had that problem my u bolts where not tight inoph. I made my sister get on and give it gas n stop in drive and seen that i was getting axel wrap so check ur you bolts whit your hand pull n push side ways and try torqueing them good...
 

·
Registered
Joined
·
5,541 Posts
Hey anyone knows if i installed a carrier bearing on my truck and want to take off the lift will it affect it??
no, it will not affect it... you can leave it in.

also, adding blocks exponentially increases the axle wrap. either remove the blocks or add traction bars to eliminate.
 

·
Registered
Joined
·
5,541 Posts
I have the same issue as FLAKO, the "Popping" sound coming from the rear underside of my truck after i did my PRG coil over Radflos up front and the 1.5blocks on the rear. Its annoying because i dont know if anything is getting messed up when i have to lean into the throttle a bit to make passes or get on the freeway. Even taking off from stop signs or lights, i usually have to ease into the throttle so it does not make the popping sound.
M :teethmast
i had the same popping sound or a popping sound on acceleration and it turned out to be the oem leaf spring collars which had broken off. its worthless or so says PRG, so i removed them from both sides and the popping sound suffice it to say is no mo...
 

·
Registered
Joined
·
121 Posts
Ok dude when i had that problem my u bolts where not tight inoph. I made my sister get on and give it gas n stop in drive and seen that i was getting axel wrap so check ur you bolts whit your hand pull n push side ways and try torqueing them good...
Hey Flako, Yeah the u bolts were the 1st things Greg at PRG told me to check. They were tightened to the specs in the instructions but i went ahead and downloaded the factory tech manual for my truck and tightened the bolts to 89ftlb like it stated and it still makes the sound. So i went 2ftlbs more and so now im still trying to get rid of it. My drive line is super close to the original factory line spec after i installed the pinion shims to angle the rear end up to line up with the drive line, but i guess its still not enough. So I guess i will be trying to get a hold of Greg at PRG so i can get the carrier bearing drop kit and hope that solves the issue. Then i can move on to better things to upgrade! :eveilgrin

Hooligan, I will look into the parts you mentioned as well. Appreciate it!

Thanks for the replies Flako / Hooligan and anyone else!
M :thumbsup:
 

·
Registered
Joined
·
28 Posts
Hey Flako, Yeah the u bolts were the 1st things Greg at PRG told me to check. They were tightened to the specs in the instructions but i went ahead and downloaded the factory tech manual for my truck and tightened the bolts to 89ftlb like it stated and it still makes the sound. So i went 2ftlbs more and so now im still trying to get rid of it. My drive line is super close to the original factory line spec after i installed the pinion shims to angle the rear end up to line up with the drive line, but i guess its still not enough. So I guess i will be trying to get a hold of Greg at PRG so i can get the carrier bearing drop kit and hope that solves the issue. Then i can move on to better things to upgrade! :eveilgrin

Hooligan, I will look into the parts you mentioned as well. Appreciate it!

Thanks for the replies Flako / Hooligan and anyone else!
M :thumbsup:
Hey dude you should try to install the carrier bearing i had my truck whit out it for a few weeks i had it just too lazy to install it also poping because of that too you might need it so... I got mine from prg greg i pick it up local. Good luck dude.
 
1 - 19 of 19 Posts
Top