Nissan Titan Forum banner

21 - 32 of 32 Posts

·
Registered
Joined
·
138 Posts
It was just a thought. All I can say is thank god for the 100k warranty. But two trucks in a row having issues? I must have a dark cloud over my head somewhere.

Here is another thought I had about these trucks. This truck was manufactured in November of 18. That means this truck sat for almost one year as I took delivery on October 17th 2019. Since they are not selling well, I wonder if the trucks with issues are due to them sitting on dealer lots for so long. I don’t know. I’m trying to understand why I have had an 18 with many issues and now a 19 with an issue after only 2k miles on it. I may be over reacting because if the 18. This could just be a simple issue. God I hope it is a simple issue!


Sent from my iPhone using Tapatalk
I'm sure it's something simple. My truck also sat on the lot for ~8 months before I purchased it and I've had no issues. I've also only driven it for 1 week in the last 6 months. My brother just drove it ~90 miles yesterday and he said it's still doing fine. Started right up when he went to pull it out of storage. The last time I started it after it had sat for 3 months, I expected a little more engine noise than usual at first start up. But it was perfect and smooth sounding. That's actually one of the big things that turned me off from RAM. The HEMIs sound like an old clunker when you first start them up.
 

·
Registered
Joined
·
246 Posts
Discussion Starter #22
Well. It’s not something simple. Well, so far as parts are concerned. It seems there is a TSB associated with letting too much water int the fuel tank. I guess there is an evap filter that fails or something like that. The fix supposedly replaces the filter and includes some fix so it doesn’t happen again. Call me super frustrated.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
107 Posts
Well. It’s not something simple. Well, so far as parts are concerned. It seems there is a TSB associated with letting too much water int the fuel tank. I guess there is an evap filter that fails or something like that. The fix supposedly replaces the filter and includes some fix so it doesn’t happen again. Call me super frustrated.
Could be much worse, I guess. Hopefully the new part lasts longer than the original!
 

·
Registered
Joined
·
639 Posts
My truck isn’t in limp mode though. I wonder if it is the gas I’m putting in it?


Sent from my iPhone using Tapatalk
Well. It’s not something simple. Well, so far as parts are concerned. It seems there is a TSB associated with letting too much water int the fuel tank. I guess there is an evap filter that fails or something like that. The fix supposedly replaces the filter and includes some fix so it doesn’t happen again. Call me super frustrated.


Sent from my iPhone using Tapatalk
Easy fix but damn it seems some of u guys are cursed with the issues!!

Maybe we call it being plagued with the “Titan Curse”.....
 

·
Registered
Joined
·
132 Posts
Get it scanned, I know your truck is in warranty but an OBD2 scanner is not expensive and many can work with an app on your phone. Even you may have the dealer fix something, sometimes it can save you time and effort just to know where you stand depending on the code. It might just be a temp issue and you can clear codes to see if your simple fix worked.
 

·
Registered
Joined
·
149 Posts
Who knows what it is just let us know...

Been driving mine like an animal.. Over 11k miles and nothing to complain about yet except for the noisy azz General Grabber tires..

Only thing they “grab” is your attention with all the clunky noise they make...
I'm getting new tires because I really hate these tires. Mine have never grabbed anything... especially in wet weather i have to totally babysit any acceleration and we all know it's not full throttle when i punch it. Lol.
 

·
Registered
Joined
·
639 Posts
I'm getting new tires because I really hate these tires. Mine have never grabbed anything... especially in wet weather i have to totally babysit any acceleration and we all know it's not full throttle when i punch it. Lol.
Discount Tire offered me $8 each for trade in!!!

Confirming these tires really do suk!!!
 

·
Registered
Joined
·
1,119 Posts
I just spent three days in a ice and snow storm with my Cooper Discoverer AT3 4s tires and they moved through that crap like nothing. Ice is ice no tire grips that but these tires did fantastic


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
246 Posts
Discussion Starter #29
Got my truck back. All seems well with the emission system. Just waiting till the next thing goes wrong


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
107 Posts
Got my truck back. All seems well with the emission system. Just waiting till the next thing goes wrong
Did you get a full new 5/100k warranty with the truck exchange, or just the remainder of your original?
 

·
Registered
Joined
·
246 Posts
Discussion Starter #31
Did you get a full new 5/100k warranty with the truck exchange, or just the remainder of your original?
I got the equivalent of buying a brand new 2019 Titan. Everything was reset to zero


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
137 Posts
Own a 6.0 Ford Excursion and then we can talk about problems! I have spent over 28K on engine and related issue with only 129k miles on it. Oil changes done religiously etc..
 
21 - 32 of 32 Posts
Top