Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
My Titan won't start. I just got a die hard battery less than a year ago. I jumped it and still all it did was click at start up. Days leading up to this sometimes it would be hard to start up and would I have to hold the key for a second or 2 and it would slowly start up. Other times it would take a few clicks and eventually start. I hear the clicking noise best right in the middle of the engine where the thermostat or air duct is. Could it be a relay or the starter? Bc the battery and alternator are fine. Weird... Also my engine has been going it seems and I'm getting a new one soon. Could it be interconnected or is it strictly electrical in this case? Any suggestions would help. -thanks!
 

·
Registered
Joined
·
1,518 Posts
It may be the ECU relay. You can put the fog light relay in it's place as a work-around, but need to get it replaced asap. There is a recall on this. That might be it. You can search for ECU relay and there might be some more info on it.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
I'll try that thanks. And you were right, there is a recall and I never got anything in the mail about it so I'll make them do it. Thanks again
 

·
Premium Member
Joined
·
15,660 Posts
sounds like the started solenoid to me. hope you figure it out.
 

·
Registered
Joined
·
447 Posts
i just replaced my batt in dec with the same problem i think you are having and the new batt fixxed it but the last two days its doing it again.... did you have any luck with the dealer
 
1 - 5 of 5 Posts
Top