Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
620 Posts
Discussion Starter · #1 ·
Ever since I installed my spindles I have been getting an occasional "clunk" sound or a dull metal on metal contact sound with my steering wheel at full lock. I usually only hear it if I have the wheel turned and hit a dip (like going into my driveway) or go over a speed bump or something. of course I take it slow but it still concerns me. Is this something that is normal? I dont have a spacer or 5100's on yet so I know its not the infamous clunk from installing them wrong and it shouldnt be coilbucket contact with no spacer. I have also retorqued everything and nothing was loose so thats not it either. anyone have any ideas or suggestions?
 

·
Registered
Joined
·
792 Posts
Maybe make sure your lower ball joint is pressed all the way in? Or check for marks on your tie rods. Mine were pretty close to contacting the coils at certain points on the turning radius. Did you have cam bolts installed when you put the spindles on?
 
  • Like
Reactions: ketel27

·
Registered
Joined
·
620 Posts
Discussion Starter · #3 ·
Ya I had cam bolts installed right after I put the lift on. Could it just be them needing to be adjusted a little to keep the contact from happening? I had them installed at the top suspension shop in town so I figured the job would be done right haha but I will have them recheck the bolts for me when I get my tires. thanks guys
 

·
Registered
Joined
·
777 Posts
Could be Coil Bucket Contact.
 

·
Registered
Joined
·
984 Posts
Pop the wheel off and look for markings to find the culprit.
 
1 - 5 of 5 Posts
Top