Nissan Titan Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
7 Posts
Also another note... one I do start the truck..... it will keep starting all day long. Until the next morning, then nothing
 

·
Registered
Joined
·
7 Posts
I will check for voltage drop test. But I do think Nisan performed this when I had it at the dealer. But maybe this tested out good when the truck was at that point starting.
 

·
Registered
Joined
·
1 Posts
Could be a bad cell in the battery. I had that happen to me. It wouldn't start with a jump but as soon as I got a new battery it started.It would just sit there and crank and test right on the meter.
I replaced my battery and negative cable fusible link both relays positive terminals. Still won’t start . But if I jump it it starts. Have no clue what the problem could be.
 

·
Registered
Joined
·
92 Posts
710 should definitely do it.

I would give this video a watch and consideration...

 

·
Registered
Joined
·
1 Posts
I have a 05 Nissan Titan that I've had for about 6 years.The internet was and still is my only mechanic help so I've had a hell of a journey. I had a crank no start issue multiple times for different reasons like Ipdm,ecm, security chip, battery,mass air flow,fuel pump.I thought it was the cam shaft sensor this time but no codes just like always so I replaced it.Still no start so I start reading threads for the millionth time and read the genius who banged on the gas tank🤦🤣🤣🤣😳So my genius *** hits it with a coconut and boom starts with no codes for now but I'll be back probably 😁
 
21 - 25 of 25 Posts
Top