Nissan Titan Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Anybody know what would cause the cruise "SET" light to start flashing while driving? I was not using cruise, just rolling through town @ 35mph. Its an 04 and I have used cruise control less than a dozen times. Had to reset the ECU, have not seen the light since.
 

·
Registered
Joined
·
461 Posts
nzimmermann said:
Anybody know what would cause the cruise "SET" light to start flashing while driving? I was not using cruise, just rolling through town @ 35mph. Its an 04 and I have used cruise control less than a dozen times. Had to reset the ECU, have not seen the light since.

I had the same thing happen while driving to work the other day. At the next light I shut the truck off and restarted it and it works fine ever since. I use it every day for 30 to 40 miles and no problems yet. If it happens again I will go to the dealer and get it checked
 

·
Registered
Joined
·
194 Posts
BuckyBadger said:
Pg 5-17-5-18
What that says is take it directly to the dealership. That kinda sucks. My set light started blinking one day, but when I restarted it was fine. It would happen every once in a while, and got worse until it finally the cruise control light never even came back on after a restart. No blinking set light no cruise light, nothing. I would appreciate anyones input on this, as my warranty, of course, just ran out.

edit: Just checked the ACDS switch at the brake pedal and it is adjusted correctly. I'm guessing it must be a problem with the switch in the steering wheel?
 

·
Registered
Joined
·
218 Posts
mine started blinking and it turned out to be a blown fuse
 

·
Registered
Joined
·
194 Posts
I checked both fuses, and even though they looked good, I still changed them. I dunno about a button being stuck. The external piece of the button is fine. Are you talking about an internal part?
 

·
Registered
Joined
·
177 Posts
stnjohnson said:
I checked both fuses, and even though they looked good, I still changed them. I dunno about a button being stuck. The external piece of the button is fine. Are you talking about an internal part?
I have had an internal part short and cause that but the best way to find out is to hook up to it and find out what codes is in it or if you have access to a consult you can find out what the switches are doing or if the circuit is open.
 

·
Registered
Joined
·
19 Posts
Glad to see I'm not the only one having trouble with the cruise control. Highly intermittant, but would typically quit on the 200 mile trip to the cabin. Usually once on the way there and once way home. Could not resume or set new speed when it happened Turning off/on with steering wheel control would allow me to use cruise control again. LAST weekend the SET light flashed when it failed... new symptom. Could NOT correct by turning off / on at steering wheel. Cruise was a vegetable until I turned off engine and restarted. About 10 miles down the road I noticed the SES light was on.
Suspect it came on as soon as I started it up again. Took to dealer and they ordered new switch. Didn't say what switch, but the paperwork says : " P1564 ASCD Light. Light cleared & parts ordered. ASCD switch internal failure " I will update next week after they finish the job. This is warrantee work on my 2005.
 

·
Registered
Joined
·
194 Posts
Neverlate, it would be really helpful if you could ask them what they installed and fixed in layman terms.

From some other threads it seems like the ASCD switch is the little switch under the steering wheel that tells whether the brake pedal is depressed or not.
 

·
Registered
Joined
·
19 Posts
stnjohnson said:
Neverlate, it would be really helpful if you could ask them what they installed and fixed in layman terms.

From some other threads it seems like the ASCD switch is the little switch under the steering wheel that tells whether the brake pedal is depressed or not.

Will do stnjohnson!
 

·
Registered
Joined
·
484 Posts
I finally got this fixed on mine, they tried to replace the ASCD switch at first as that is what the nissan program (don't know what its called, swift or something like that). Anyways the problem never went away and then I took it back and they replaced the switches on the steering wheel and it has been fine since. I had the same flashing SET light problem off and on over the years usually only when doing long periods of highway driving but it got worse and finally just never worked. Have not had a problem in over 2 weeks since I got it fixed and have used it quite a bit.
 

·
Registered
Joined
·
19 Posts
STNJohnson, I got mine back from the dealer and Bighitter nailed it already in the last post. They replaced the whole 3 switch assembly on the sterring wheel rH side. The invoice states the part number is 25551-7S110 'switch assembly.' Wish I could tell you how much it cost, but I'm still warrantee, so the invoice says N/C. Encouraged to hear it fixed it for Bighitter, since I won't know untill my next long drive to the cabin (usually failed once or twice on the 3 hour trip). Good luck !
 

·
Registered
Joined
·
57 Posts
My CC blinks, first time I've ever tried to use it (great). I called the dealership and they said that they'll have to check to see if I'm under warranty. Reason being, my 05 has 45000, so the "fix" might fall under the 36k warranty or the 60k. Sweet......... Damn used trucks, my passenger heated seat doesn't get very hot and now the CC.
 

·
Registered
Joined
·
43 Posts
Count me as another with the same problem. Started on a trip from Nashville to Cincinnati last Fall. Blinked for awhile, worked for awhile, quit working altogether. My long trips stopped a couple weeks later so I forgot about it.

Now I'm getting ready for the longest trip ever in the truck (Nashville to Cape Hatteras), so wanted to get it fixed. After reading this thread, I went out and checked the fuses. Fuses look fine. Started the truck and tried to turn on the cruise. It blinked. Turned off the truck and restarted. Cruise light came on like it's supposed to.

Still under warranty (purchased 8/06) may get it 'fixed' anyway, even if it doesn't seem to be broken at this moment.

Dead
 

·
Registered
Joined
·
57 Posts
futuredeadguy said:
Count me as another with the same problem. Started on a trip from Nashville to Cincinnati last Fall. Blinked for awhile, worked for awhile, quit working altogether. My long trips stopped a couple weeks later so I forgot about it.

Now I'm getting ready for the longest trip ever in the truck (Nashville to Cape Hatteras), so wanted to get it fixed. After reading this thread, I went out and checked the fuses. Fuses look fine. Started the truck and tried to turn on the cruise. It blinked. Turned off the truck and restarted. Cruise light came on like it's supposed to.

Still under warranty (purchased 8/06) may get it 'fixed' anyway, even if it doesn't seem to be broken at this moment.

Dead

Leave a post after you get it fixed.
 

·
Registered
Joined
·
624 Posts
Has anyone tried putting a set of the new lighted swiches from 08 in place of the non-lit ones from 04-06 or 07? My second set to switches are now failing and I am out of warrenty.
 

·
Registered
Joined
·
234 Posts
Glad to see I'm not the only one having trouble with the cruise control. Highly intermittant, but would typically quit on the 200 mile trip to the cabin. Usually once on the way there and once way home. Could not resume or set new speed when it happened Turning off/on with steering wheel control would allow me to use cruise control again. LAST weekend the SET light flashed when it failed... new symptom. Could NOT correct by turning off / on at steering wheel. Cruise was a vegetable until I turned off engine and restarted. About 10 miles down the road I noticed the SES light was on.
Suspect it came on as soon as I started it up again. Took to dealer and they ordered new switch. Didn't say what switch, but the paperwork says : " P1564 ASCD Light. Light cleared & parts ordered. ASCD switch internal failure " I will update next week after they finish the job. This is warrantee work on my 2005.
Same thing happened to mine last night, was quoted at $450+ to replace? That included the $150 diagnostic charge. It is crazy was dealers charge... not more dealers for me.
 
1 - 20 of 26 Posts
Top