Nissan Titan Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So ive had my 04 titan for like 2 month only drive it on weekends and havnt hardly put any miles on it. After about a couple of weekends in the truck i realize the rear speakers are horrible!
I go ahead and put some Kenwoods in there put everything back together jump in my truck crank it up and head down the road. As soon as i pull out into the road i realize something doesnt feel right i look down and no gauges are working. all i got is the lights and and P R N D 4 3 2 1 no mileage or anything else. Also it doesnt shift into any gear just stays in wat seems like a high gear also manual shift towing does not work.
I dont think the new speakers have anything to do with the problems but its deff something freaking out!!!!!!!!!!!!!!!

Any Help Would Be Kool
 

·
Premium Member
Joined
·
1,557 Posts
Nice first post.

Did this problem exist prior to the speakers?

Interestingly enough I just drove my truck to my office. I constantly looked at my gauges (Speed) because of where I live and the nice police officers hiding for tickets. I guess its just me but I tend to look at my gauges a good amount when driving.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
nope never before its really weird i backed outta the garage look down put it in drive and noticed

O and i drove it to the end on my street and it does change gears just seems to stay in one gear. doesnt seem like 1st gear because it doesnt tach out or anything even with the pedal to the floor it just pulls
 

·
Premium Member
Joined
·
1,557 Posts
B3Cool said:
nope never before its really weird i backed outta the garage look down put it in drive and noticed
Well if you did something electrical it can easily have affected your electrical gauges. I would see if there is any easy way to disconnect what you put in (maybe removing power at the battery or possibly the HU since I dont know what you put in I cant offer much advice).

B3Cool said:
O and i drove it to the end on my street and it does change gears just seems to stay in one gear. doesnt seem like 1st gear because it doesnt tach out or anything even with the pedal to the floor it just pulls
What? Your truck doesnt change gears? If thats the case you need to stop driving it before you break something expensive and get it checked out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
yea ive disconnected the battery for like 30 minutes to see it would help but same deal ima bout to go and check all the fuses and check the speakers i put in

by the way i put in just really kenwood door speakers unplugged the stock ones and wired them in.............


is there a program that tell the truck to cutt these things off to save energy or something
 
1 - 5 of 5 Posts
Top