Nissan Titan Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
177 Posts
Discussion Starter #1
I installed a 55w low beam and a 35w fog kit in my T. I noticed that when the lights are on, I have radio interference on certain stations. I also seem to be having a higher voltage output, appears to be about 14 or so. Anyone else with these issues?
 

·
Registered
Joined
·
4 Posts
I'm looking to install 55w low beam on my titan and wondered if you needed the HID Harness, Error Eliminator, or Adaptor cables? How bad is the interference?
 

·
Registered
Joined
·
984 Posts
55w's tend to throw interference. It depends on the radio station to be honest. If I am nearby a good sized town/city it isn't bad, but when I hit the highway between places if the lights are on there isn't a snowballs chance in hell i'd get a good station. I don't mind, that's where the iphone comes in.
 

·
Registered
Joined
·
2 Posts
thats weird i havent noticed any problems like that with my hids... i got 2007 titan with 55w lows and 35w highs. Even with highs on i dont have any problems with my radio picking up stations no matter where i am
 

·
Registered
Joined
·
46 Posts
I don't have any problems with mine. I have 35w hi,low and fogs. I love them. I didn't need anything but the kits.
 

·
Registered
Joined
·
44 Posts
I had the same issue, try moving the transformer box to a different location, moved the box in my wifes minivan and reception went back to normal. Her nagging was enough for me to open everything back up, I just use my Ipod in the Titan. Wraping the wires might work along with the transformer.
 
1 - 9 of 9 Posts
Top