Nissan Titan Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Went to start my truck this morning and I get a clicking noise and the motor won't start. Seemed like a dead battery, so I jump start using my girlfriend’s car and it starts right up.

My truck is a 2006 SE Crew Cab with big tow. I purchased the truck in November of 2006, so I still haven’t had the truck for a year. The odometer reads 15,000 miles. I also didn’t leave any lights on. On my drive to work the amp gauge stayed around 10 amps. So I'm guessing it won't be starting again without a jump start.

Any ideas why the battery would fail prematurely? Think the battery would be covered under warranty? If not any suggestions on which replacement battery to purchase?
 

·
Super Moderator
Joined
·
37,049 Posts

·
Premium Member
Joined
·
141,094 Posts
My 03 Altima battery died yesterday and we had to bring the car home on a hook. First problem ever in 54 months and about 30,000 miles.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #5
Thanks for the help guys. I just called the dealer to see if by any chance it was covered under warranty. To my surprise since the failure occurred before the battery was one year old, they'll be replacing the battery under warranty free of charge.

RobKar, I was thinking of getting an Odyssey and was already looking up prices when I thought of calling the dealer. Once the new stock battery dies I'll be buying an Odyssey.

By the way, went to start the truck during lunch and it did not start. Battery did not hold a charge from the hour drive to work this morning.
 

·
Registered
Joined
·
1,690 Posts
squirm88 said:
Thanks for the help guys. I just called the dealer to see if by any chance it was covered under warranty. To my surprise since the failure occurred before the battery was one year old, they'll be replacing the battery under warranty free of charge.

RobKar, I was thinking of getting an Odyssey and was already looking up prices when I thought of calling the dealer. Once the new stock battery dies I'll be buying an Odyssey.

By the way, went to start the truck during lunch and it did not start. Battery did not hold a charge from the hour drive to work this morning.
Yea the stock battery is hit or miss. Sounds like you got a bad one. I would see if the dealer will credit you the replacement cash for the new one to put towards a better one.
 

·
Registered
Joined
·
386 Posts
It's because you live in florida... It's hott. My battery died about a month ago, wouldn't even turn over on a jump, the clicking noise was all I got. I'm in Scottsdale, Arizona and the heat just kills batteries, spent $70 on a new OEM battery from the dealership.
 

·
Registered
Joined
·
727 Posts
I’ll second Advocate & AF-Medic.
OEM seems to be hit or miss even with BT option, now combine the heat component. I suppose our S.FL. heat is exceeded in other places US geographically, but we probably have more days in the red per season. Regardless, mine performed 3years +, but I wasn’t willing to push my luck considering some evidence indicated it was about time. Mine sans BT was not maintenance free & the cells did require some refill & corrosion reoccurred regularly but in the end slower cranking was what did it for me considering some members reported one day it worked fine just to be stranded the next day.
 
1 - 8 of 8 Posts
Top