Nissan Titan Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2,198 Posts
Discussion Starter #1
Had fogs installed at the dealer today. Got a discount because they owed me for a problem on delivery day. They wiggle alittle to the touch. Checked the Xterra we have, same way. My old 2002 Frontier did not. Whats up, does anyone else's move? It's not bad, but road vibration could cause them to shake maybe. Can you guys check yours out for me. Don't wanna go back and say anything if they all wiggle alittle.

Had my cargo door taken off today also and it will have some dimple/dents at the top taken out and some scratches fixed, will be totally repainted. It was from people trying to close it with the keys in their hands and also slamming it because the latch needs to be adjusted. This was noticed on the day of pick up and was put on a "we owe". Looks weird driving down the road with it off. Get it back Mon or Tues.
 

·
Super Moderator
Joined
·
34,523 Posts
FLfinfan said:
Had fogs installed at the dealer today. Got a discount because they owed me for a problem on delivery day. They wiggle alittle to the touch. Checked the Xterra we have, same way. My old 2002 Frontier did not. Whats up, does anyone else's move? It's not bad, but road vibration could cause them to shake maybe. Can you guys check yours out for me. Don't wanna go back and say anything if they all wiggle alittle.

Had my cargo door taken off today also and it will have some dimple/dents at the top taken out and some scratches fixed, will be totally repainted. It was from people trying to close it with the keys in their hands and also slamming it because the latch needs to be adjusted. This was noticed on the day of pick up and was put on a "we owe". Looks weird driving down the road with it off. Get it back Mon or Tues.
Mine were factory installed and I have to really push on them to get them to move at all.

37L1
 

·
Registered
Joined
·
230 Posts
I installed mine myself and there's a little play in them, but only if you press hard. The setup isn't that sturdy, only one bolt/nut holding them in place with two press-lock points (? not sure what to call them?). But they make the truck look better and they work just fine for me.

Are you noticing any wiggle in the light pattern when driving? If so you may want to get under there and make sure the press-lock points are actually snapped in properly and that the nut is tightened down. I had trouble with one of mine. :)
 

·
Registered
Joined
·
2,198 Posts
Discussion Starter #4
Went out and tightened up that nut/bolt you mentioned. One light is rock steady and the other one barely moves at all. No shaking of the lights at night before, so now should be perfect. Thanks. Can't believe the tech left 'em that lose. Sheeze!
 
1 - 4 of 4 Posts
Top